LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-10-2005, 01:09 PM   #1
solar1951
Member
 
Registered: May 2005
Location: France
Distribution: Ubuntu Feisty and Mint Cassandra
Posts: 86

Rep: Reputation: 15
slow ripping speed


Mandakelinux 10.1, KDE 3.2.3, LG DVD rom
When trying to rip audio CD's using either k3b or kscd the rip speed is very slow - around playback speed I would guess and therfore to rip an entire cd would take forever.

I have a dual boot system and under Win XP the dvd runs up to full speed during ripping - no problem.

How do I get the DVD to run at full speed under Linux ?
 
Old 07-10-2005, 01:29 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
turn DMA on (hdparm -d1 /dev/cdrom) and also try not to use ide-scsi emulation on that drive, as that'll slow it right down too.
 
Old 07-10-2005, 04:19 PM   #3
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
It could be dma not being activate on the drive but I've got the same problems regarding ripping audio cd's (dma is on so dvd playback etc. is fine)

The way I got round it is to use the (python I think) program ripit and tell it to use cdda2wav rather than cdparanoia which admittedly has better error correction but almost always goes for a wee sleep on the beach until I give up and kill it.

Using ripit with cdda2wav I get speeds comparable with ripping & encoding with windows media player or windows Real Player.
 
Old 07-10-2005, 04:44 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
well also don't forget that you can turn off a few of the more extreme cdparanoia options. most ripper gui's will either wholly handle, or allow passthrough, of cdparanoia options... just use -Z instead of -YZ for example
 
Old 07-10-2005, 05:09 PM   #5
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Just had a look at the cdparanoia website page (which probably should have done before) and the bloke is aware of one specific problem which seems to be exactly the same as mine - my drive seems to be exhibiting the class signs of "bimodal jitter pattern" (the poor wee thing ). He suggests a fiddly fix to experiment with until the next release where the problem will be addressed.

Anyway not to distract anymore from the original poster...
 
Old 07-11-2005, 07:22 AM   #6
solar1951
Member
 
Registered: May 2005
Location: France
Distribution: Ubuntu Feisty and Mint Cassandra
Posts: 86

Original Poster
Rep: Reputation: 15
Sorry folks I seem to have confused you.
The problem I have is the physical speed - revolutions per minute - of the DVD drive during ripping. It stays at a slow speed and therefore rips slowly. I dont think there is anything wrong with the DMA as I can play DVD's fine.
The other pointer which may help is that when I insert a music CD, KsCD starts automatically to play even though this option is disabled.
Any help ?
 
Old 07-16-2005, 05:52 AM   #7
solar1951
Member
 
Registered: May 2005
Location: France
Distribution: Ubuntu Feisty and Mint Cassandra
Posts: 86

Original Poster
Rep: Reputation: 15
Has anyone got an idea on how to control the speed of this DVD drive in order to rip at higher speed ?
If Windoze XP can do it I am sure that Linux can ???????????
 
Old 07-16-2005, 06:49 AM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Well hdparm has an -E option for setting the speed although man page says you shouldn't have to use it, so as root

hdparm -E whatever_number /dev/hdc

if /dev/hdc is your drive assignment.

Don't know if it'll make a difference though
 
Old 07-16-2005, 08:54 AM   #9
solar1951
Member
 
Registered: May 2005
Location: France
Distribution: Ubuntu Feisty and Mint Cassandra
Posts: 86

Original Poster
Rep: Reputation: 15
This is the output from hdparm -I dev/cdrom
dev/cdrom:

ATAPI CD-ROM, with removable media
Model Number: HL-DT-STDVD-ROM GDR8163B
Serial Number:
Firmware Revision: 0L23
Standards:
Likely used CD-ROM ATAPI-1
Configuration:
DRQ response: 50us.
Packet size: 12 bytes
Capabilities:
LBA, IORDY(can be disabled)
DMA: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2 udma0 udma1 *udma2
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* NOP cmd
* DEVICE RESET cmd
* PACKET command feature set
* Power Management feature set
HW reset results:
CBLID- below Vih
Device num = 1

Does this indicate anything out of the ordinary to you ?
 
Old 07-16-2005, 09:31 AM   #10
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
The only real difference between yours and mine is your drive has more features. Wonder if the power management feature is causing it? You can turn it off with (it wouldn't do anything permeanent)

hdparm -B 255 /dev/hdc

And don't know if you've looked here yet, but it could give you something more concrete to have a look at and things to check/try out


hdparm improve performance
 
Old 07-16-2005, 10:29 AM   #11
solar1951
Member
 
Registered: May 2005
Location: France
Distribution: Ubuntu Feisty and Mint Cassandra
Posts: 86

Original Poster
Rep: Reputation: 15
Tried the power management option and got
/dev/cdrom:
setting Advanced Power Management level to disabled
HDIO_DRIVE_CMD failed: Input/output error
Maybe it cant be changed on a DVD drive ?
 
Old 01-06-2007, 09:24 PM   #12
locoham
LQ Newbie
 
Registered: Jan 2007
Posts: 3

Rep: Reputation: 0
cdparanoia

This thread is pretty old but I ran across it trying to solve the same issue. I read in another post that the reason for slow speed is actually cdparanoia making sure it does an extra good job. Using the -Z option in the cdparanoia command line will turn off the paranoid ripping quality options (in grip for example). It increased my drive speed from 1x to around 10-12x (about as fast as winbloze media player).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CD Ripping - Why so slow? Zerboxx Mandriva 17 01-06-2007 09:38 PM
ripping audio cd's really slow trey85stang Slackware 10 10-05-2005 11:35 AM
How to speed up ripping audio CDs. springshades Linux - Software 2 08-01-2005 01:37 AM
Ripping CD's is Incredibly Slow linux-rulz Linux - General 1 05-17-2005 01:08 AM
CD ripping speed - mine's bad, what's yours? afshin Linux - Hardware 1 01-29-2003 04:12 PM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration