LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-11-2009, 06:58 AM   #1
Seekret
LQ Newbie
 
Registered: May 2009
Posts: 5

Rep: Reputation: 0
Slackware 12.2 disable eth0 on startup


I'm trying to disable my Ethernet device on startup in Slackware 12.2. I've tried putting 'ifconfig eth0 down' in the /etc/rc.d/inet1.conf file at the beginning but that didn't work. I also tried adding 'ifconfig eth0 down' to the /etc/rc.d/rc.local file but that didn't work either. I'm on a laptop and don't usually have an Ethernet cable plugged in so the laptop has to wait for the DHCP process to timeout before continuing.

Thanks in advance for any help.
 
Old 05-11-2009, 07:09 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,074
Blog Entries: 52

Rep: Reputation: Disabled
This might be the answer, although there isn't a package for 12.2:
http://www.slackware.com/~alien/slackbuilds/ifplugd/
 
Old 05-11-2009, 07:52 AM   #3
Seekret
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by brianL View Post
This might be the answer, although there isn't a package for 12.2:
http://www.slackware.com/~alien/slackbuilds/ifplugd/
Thanks for the link, however I ran into a problem installing the ifplugd daemon. When I run 'make' it fails giving out a few errors saying it has conflicting types for various entries. I included the output below.

Code:
bash-3.1$ make
make  all-recursive
make[1]: Entering directory `/home/frank/builds/ifplugd-0.28'
Making all in src
make[2]: Entering directory `/home/frank/builds/ifplugd-0.28/src'
if test -d "../.svn" ; then \
                if REV=`svn info ".." | grep ^Revision | cut -f2 -d" "` 2> /dev/null ; then \
                        echo -e "#ifndef foosvnrevisionhfoo\n#define foosvnrevisionhfoo\n#define SVN_REVISION \"$REV\"\n#endif" > svn-revision.h ; \
            fi \
        fi
make  all-am
make[3]: Entering directory `/home/frank/builds/ifplugd-0.28/src'
if test -d "../.svn" ; then \
                if REV=`svn info ".." | grep ^Revision | cut -f2 -d" "` 2> /dev/null ; then \
                        echo -e "#ifndef foosvnrevisionhfoo\n#define foosvnrevisionhfoo\n#define SVN_REVISION \"$REV\"\n#endif" > svn-revision.h ; \
            fi \
        fi
if gcc -DHAVE_CONFIG_H -I. -I. -I..    -D_REENTRANT -I/usr/local/include   -DSYSCONFDIR="\"/usr/local/etc\"" -D_GNU_SOURCE -g -O2 -pipe -W -Wall -Wno-unused-parameter -MT interface.o -MD -MP -MF ".deps/interface.Tpo" -c -o interface.o interface.c; \
        then mv -f ".deps/interface.Tpo" ".deps/interface.Po"; else rm -f ".deps/interface.Tpo"; exit 1; fi
In file included from interface.c:27:
/usr/include/sys/types.h:62: error: conflicting types for 'dev_t'
/usr/include/linux/types.h:13: error: previous declaration of 'dev_t' was here
/usr/include/sys/types.h:67: error: conflicting types for 'gid_t'
/usr/include/linux/types.h:27: error: previous declaration of 'gid_t' was here
/usr/include/sys/types.h:72: error: conflicting types for 'mode_t'
/usr/include/linux/types.h:15: error: previous declaration of 'mode_t' was here
/usr/include/sys/types.h:77: error: conflicting types for 'nlink_t'
/usr/include/linux/types.h:16: error: previous declaration of 'nlink_t' was here
/usr/include/sys/types.h:82: error: conflicting types for 'uid_t'
/usr/include/linux/types.h:26: error: previous declaration of 'uid_t' was here
In file included from /usr/include/sys/types.h:133,
                 from interface.c:27:
/usr/include/time.h:105: error: conflicting types for 'timer_t'
/usr/include/linux/types.h:22: error: previous declaration of 'timer_t' was here
In file included from /usr/include/sys/types.h:220,
                 from interface.c:27:
/usr/include/sys/select.h:78: error: conflicting types for 'fd_set'
/usr/include/linux/types.h:12: error: previous declaration of 'fd_set' was here
In file included from interface.c:27:
/usr/include/sys/types.h:235: error: conflicting types for 'blkcnt_t'
/usr/include/linux/types.h:124: error: previous declaration of 'blkcnt_t' was here
interface.c: In function 'interface_detect_beat_mii':
interface.c:106: warning: dereferencing type-punned pointer will break strict-aliasing rules
interface.c:115: warning: dereferencing type-punned pointer will break strict-aliasing rules
interface.c: In function 'interface_detect_beat_priv':
interface.c:134: warning: dereferencing type-punned pointer will break strict-aliasing rules
interface.c:143: warning: dereferencing type-punned pointer will break strict-aliasing rules
make[3]: *** [interface.o] Error 1
make[3]: Leaving directory `/home/frank/builds/ifplugd-0.28/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/frank/builds/ifplugd-0.28/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/frank/builds/ifplugd-0.28'
make: *** [all] Error 2
bash-3.1$
 
Old 05-11-2009, 08:53 AM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,074
Blog Entries: 52

Rep: Reputation: Disabled
Have you tried installing the package? Download it and run, as root:
Code:
installpkg ifplugd-0.28-i486-3alien.tgz
or create directories for ifplugd and libdaemon, get all the relevant files for each, then run the SlackBuild scripts?
 
Old 05-11-2009, 09:12 AM   #5
Seekret
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by brianL View Post
Have you tried installing the package? Download it and run, as root:
Code:
installpkg ifplugd-0.28-i486-3alien.tgz
or create directories for ifplugd and libdaemon, get all the relevant files for each, then run the SlackBuild scripts?
I did not try that, but I was looking through the scripts in the /etc/rc.d folder to see which ones were running network services at start up and was able to solve the problem by changing the rc.inet1 shell script to have 'ath' as the variable for 'IFNAME' instead of 'eth'. I will still try to install 'ifplugd' with 'installpkg' since I imagine it isn't a bad thing to have. Thanks for the help.
 
Old 05-11-2009, 10:54 PM   #6
forum1793
Member
 
Registered: May 2008
Posts: 312

Rep: Reputation: 34
Can't you just alter /etc/rc.d/rc.inet1.conf?

Remove or comment out the eth ones and start with the wireless part.

Or, alter rc.inet1 so that it is not executable. Then you can start the wireless separately, with your own script, wpa-supplicant, or wicd.
 
Old 05-12-2009, 12:50 AM   #7
Seekret
LQ Newbie
 
Registered: May 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by forum1793 View Post
Can't you just alter /etc/rc.d/rc.inet1.conf?

Remove or comment out the eth ones and start with the wireless part.

Or, alter rc.inet1 so that it is not executable. Then you can start the wireless separately, with your own script, wpa-supplicant, or wicd.
Originally I had tried commenting out the eth devices in rc.inet1.conf but that did not work. Altering the rc.inet1 script to use ath instead of eth has worked out perfectly for me so I'm going to keep that solution. Thanks for the help though.
 
  


Reply

Tags
eth0, script, slackware, startup


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable Text-to-speechmanager on startup, and disable fsck after 20 boots Kristian2 Slackware 2 02-25-2009 11:55 AM
How to disable eth0 ? lali.p Slackware 2 02-26-2007 05:01 AM
how to get eth0 up on startup in slackware? Tritan Linux - Newbie 3 08-16-2006 05:28 AM
Slackware 10: How do you disable hotplug at startup? jtp51 Slackware 6 10-29-2004 05:14 PM
Disable Interupt 16 locks up eth0 david.skinner Linux - Hardware 1 06-09-2004 03:29 AM


All times are GMT -5. The time now is 09:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration