LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   slack: usb memstick howto? (http://www.linuxquestions.org/questions/linux-hardware-18/slack-usb-memstick-howto-360903/)

nadroj 09-06-2005 10:11 PM

slack: usb memstick howto?
 
first day of classes today ( :cry: ) of my last year.. and i will be needing to use my memory stick now.

just wondering what device file i should look for to mount a memory stick i put in the usb port?
when i do toss in the stick i see the I/O light go nuts for afew seconds, but it doesnt automount or autodetect..

thanks for any hints

nadroj 09-06-2005 10:32 PM

ok well i got it :study:

i had to 'modprobe usb-storage' module for usb mass storage support then i could mount the device.. it was /dev/sda.
ill need to add the command to a startup script so its accessable each time.. which script would be most appropriate? if none then i guess just /etc/rc.d/rc.local.. should be easy.

the problem now though, it seems that it displays the dos names of folders etc, ie 'semest~1' for the folder 'semester 5'.. hopefully the mount manual says why.

thanks.

J_K9 09-06-2005 10:34 PM

Ah...with more than 500 points, I knew there'd be something fishy going on...let me read you last post! ;)

nadroj 09-07-2005 12:07 AM

d'oh..
its not working anymore!
lol.

nadroj 09-07-2005 12:53 AM

well, after checking the stick in M$ it turns out its fried...

J_K9 09-07-2005 03:35 AM

Ouch! Poor memstick... - Unlucky, dude! ;)

J_K9

*offers new memstick* Would you like one? :D

db391 09-07-2005 04:36 PM

(Aside from fried USB sticks:)
Quote:

Originally posted by nadroj

i had to 'modprobe usb-storage' module for usb mass storage support then i could mount the device.. it was /dev/sda.
ill need to add the command to a startup script so its accessable each time.. which script would be most appropriate? if none then i guess just /etc/rc.d/rc.local.. should be easy.

Firstly, in Slack you will find the commented line '/sbin/modprobe usb-storage' in /etc/rc.d/rc.modules. Simply uncomment that line.

And as for mounting the stick... and avoiding legacy dos filenames)
1. Add an extra line to the /etc/fstab file. For instance: (I use /mnt/usb)
/dev/sda /mnt/usb vfat defaults,sync,rw,user,noauto 0 0

2. Log in as root and type: mkdir /mnt/usb
You can then 'mount /mnt/usb' as much as you want ;)

Note that the vfat option (as opposed to auto or msdos) allows normal filenames instead of dos filenames; 'semester 5' vs 'semest~1'. ;)

Bear in mind that many USB sticks allocate themselves to /dev/sda1.

nadroj 09-07-2005 08:27 PM

yes, please K9!
lol.. it was an older, i think from last December, memstick.. 32mb. i was planning on getting another, this is an excuse to now! :D still.. i lost data..
at school today i tried the drive and it worked on one computer then stopped randomly afew minutes later and i havent been able to get it going agan :(

db
thanks for the info...
when i mounted it i did have the vfat filesystem type set, and it still displayed the 8.3 filenames.. if i recall, this is what i had: /dev/sda /mnt/usb vfat user,noauto,rw 0 0
oh well, no way of checking now that its junk!

den15 10-12-2005 11:02 PM

Hi!

I have the same problem. whn i try to mount /mnt/usb i get a message:

root@myhost:/etc# mount /mnt/usb
mount: wrong fs type, bad option, bad superblock on /dev/sda,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

root@myhost:/etc# dmesg | tail
Raw sense data:0x70 0x00 0x06 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x28 0x00 0x00 0x00 0x00 0x00
SCSI device sdc: 254720 512-byte hdwr sectors (130 MB)
sdc: Write Protect is off
sdc: sdc1 sdc2 sdc3 sdc4
WARNING: USB Mass Storage data integrity not assured
USB Mass Storage device found at 3
FAT: bogus logical sector size 60165
VFS: Can't find a valid FAT filesystem on dev 08:00.
FAT: bogus logical sector size 60165
VFS: Can't find a valid FAT filesystem on dev 08:00.

nadroj 10-12-2005 11:06 PM

is the stick formatted? do you have an entry for /mnt/usb in /etc/fstab? if not then you will have to specify the full mount command when mounting the stick, ie 'mount /dev/name /path/toMount -t autofs -o rw'
or change the autofs to vfat

den15 10-12-2005 11:09 PM

I should wrote sdc instad of sda. it works now. sda is my hard disk,


but thanx


All times are GMT -5. The time now is 06:52 AM.