LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-18-2004, 03:38 PM   #1
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
SiS 630 - Can't get DRI working (XF86 4.3)


I've been banging on this for months but I just can't get my hw 3D accel and DRI on my SiS 630 laptop running XFree86 4.3.0. DRI is shown as enabled in the X logs but when I run glxinfo, Direct Rendering is listed as disabled. I've been to the Winishoffer site and tried his drivers but nothing works. I got sis_dri.so from the official XF86 4.2 pre-compiled binaries.

lsmod output:
Module Size Used by
sis 50592 2
sisfb 184948 0
sis_agp 3808 1
agpgart 26728 2 sis_agp
af_packet 17384 2
usbnet 11880 0
sis900 17220 0
crc32 3648 1 sis900
ohci_hcd 16804 0
usbcore 93692 4 usbnet,ohci_hcd
rtc 10424 0
unix 23536 22

Entries from /var/log/XFree86.log:
(II) Loading /opt/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /opt/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /opt/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /opt/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "sis"
(II) Loading /opt/X11R6/lib/modules/drivers/sis_drv.o
(II) Module sis: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.6.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
*snip*
(--) SIS(0): fb0: SiS kernel fb driver (sisfb) 1.6.25 detected (PCI: 01:00.0)
(--) SIS(0): sisfb: memory heap starts at 8192KB
(--) SIS(0): sisfb: using video mode 0x30
(--) SIS(0): sisfb: not reserved hardware cursor, using no command queue
(--) SIS(0): Relocated IO registers at 0xA000
(**) SIS(0): Depth 16, (--) framebuffer bpp 16
(==) SIS(0): RGB weight 565
(==) SIS(0): Default visual is TrueColor
(==) SIS(0): Using gamma correction (1.0, 1.0, 1.0)
(--) SIS(0): Video BIOS version "2.02.3b" found at 0xc0000
(==) SIS(0): Using HW cursor
(==) SIS(0): Color HW cursor is disabled
(==) SIS(0): TurboQueue enabled
(==) SIS(0): Usage of built-in modes is enabled
(--) SIS(0): Video ROM data usage is enabled
(--) SIS(0): Detected DRAM type: SDRAM
(--) SIS(0): Detected memory clock: 100.226 MHz
(--) SIS(0): (Adapter assumes MCLK being 100 Mhz)
(II) SIS(0): Assuming DRAM bus width: 64 bit
(--) SIS(0): Linear framebuffer at 0x48000000
(--) SIS(0): MMIO registers at 0x40000000
(**) SIS(0): VideoRAM: 8192 KB
(II) SIS(0): Using 8192K of framebuffer memory
(--) SIS(0): Hardware supports two video overlays
(--) SIS(0): Detected LVDS transmitter (Bridge type 2)
(--) SIS(0): No CRT1 connection detected
(--) SIS(0): Detected LCD panel resolution 800x600 (type 10, expanding, RGB18)
(--) SIS(0): Memory bandwidth at 16 bpp is 400.904 MHz
(--) SIS(0): Bandwidth reserved for CRT2 is 42 Mhz
(--) SIS(0): Bandwidth available for CRT1 is 358.904 MHz
(--) SIS(0): Detected LCD PanelDelayCompensation 16

*snip*

drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmOpenDevice: minor is 0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 7, (OK)
drmGetBusid returned ''
(II) SIS(0): [drm] created "sis" driver at busid "PCI:1:0:0"
(II) SIS(0): [drm] added 8192 byte SAREA at 0xc8064000
(II) SIS(0): [drm] mapped SAREA 0xc8064000 to 0x409ea000
(II) SIS(0): [drm] framebuffer handle = 0x48000000
(II) SIS(0): [drm] added 1 reserved context for kernel
(II) SIS(0): [drm] Registers = 0x40000000
(II) SIS(0): [drm] drmAgpEnabled succeeded
(II) SIS(0): [drm] failure adding irq 0 handler, stereo disabled
(II) SIS(0): [dri] visual configs initialized.
(II) SIS(0): Frame Buffer From (0,0) To (800,5240)
(II) SIS(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Dashed Lines
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
22 256x256 slots
6 512x512 slots
(==) SIS(0): Backing store disabled
(==) SIS(0): Silken mouse enabled
(II) SIS(0): Using SiS300/310/325 series HW Xv
(II) SIS(0): X context handle = 0x00000001
(II) SIS(0): [drm] installed DRM signal handler
(II) SIS(0): [DRI] installation complete
(II) SIS(0): Direct rendering enabled
(WW) SIS(0): Option "DRI" is not used
 
Old 02-18-2004, 04:25 PM   #2
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
SiS DRI was disable in 4.3 because the driver wasn't recompiled with the new MESA libraries. It'll work with XFree 4.2 and 4.4 however.
 
Old 02-19-2004, 12:13 AM   #3
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Original Poster
Rep: Reputation: 30
I just tried it with the official 4.2.0 binaries. Didn't work either. Same problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XFree86 seems to not worth with SiS 630 DarkNice *BSD 3 11-18-2004 01:08 PM
SiS 630 and OpenGL andrewb758 Linux - Hardware 0 03-09-2003 09:46 AM
sis 630 3d acceleration exigent Linux - Hardware 0 08-27-2002 07:06 PM
SIS 630/730 and DRI crashmeister Linux - Hardware 0 06-17-2002 10:03 AM
The Sis 730 being detected as a 630 new2Iinux Linux - General 3 03-20-2002 04:53 AM


All times are GMT -5. The time now is 01:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration