LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   shift+End and Shift+Home key combo doesn't work right (http://www.linuxquestions.org/questions/linux-hardware-18/shift-end-and-shift-home-key-combo-doesnt-work-right-803580/)

santana 04-22-2010 03:11 PM

shift+End and Shift+Home key combo doesn't work right
 
On my notebook, asus g50vt, the Home and End keys are on the numeric key pad, Home is shared with the 7 key while End is shared with the 1 key. Pressing either home or end works fine, and snaps the cursor to either the first or last character on the current line, however

SHIFT+Home and SHIFT+End insert characters 7 and 1 respectively. they are supposed to select from current cursor position to first or last character in the line as the case may be.

How can I fix it? Any ideas?

amani 04-23-2010 10:54 AM

In your case it should be shift + shift + 7/home

santana 04-23-2010 11:59 AM

Quote:

Originally Posted by amani (Post 3945285)
In your case it should be shift + shift + 7/home

hmmm, that doesn't work, same as pressing shift+Home/7, a 7 is inserted...

catkin 04-23-2010 12:04 PM

Replying because long time and no solution yet, not because of expertise ...

The solution probably lies in the area of readline (3) and the associated inputrc files. Based on that you may find some useful information from this Google search.

santana 04-23-2010 12:13 PM

Quote:

Originally Posted by catkin (Post 3945394)
The solution probably lies in the area of readline (3) and the associated inputrc files. [/URL].

not so sure it's related to those. This is happening in graphical apps too. They all seem to have the same behavior. eg, Firefox, Thunderbird, Kate, Kdevelop, those are the ones I use mostly, but I'm confident the same will happen in others.

catkin 04-23-2010 12:32 PM

Quote:

Originally Posted by santana (Post 3945401)
not so sure it's related to those. This is happening in graphical apps too. They all seem to have the same behavior. eg, Firefox, Thunderbird, Kate, Kdevelop, those are the ones I use mostly, but I'm confident the same will happen in others.

The we're into X keyboard mapping, something I know even less about :)

Then the solution may lie in xmodmap, first using xev to determine what code Shit+Home and Shift+End generate. There have been a few threads about these things here on LQ. This Google search may help.

santana 04-23-2010 12:35 PM

[QUOTE=catkin;3945418]The we're into X keyboard mapping, something I know even less about :)

Yeah, me too, I thought this is something to do with X... thanks for trying.


All times are GMT -5. The time now is 04:39 AM.