LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-31-2009, 04:46 PM   #1
mrider
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 22

Rep: Reputation: 1
Set Synaptics preferences when distro has no xorg.conf


Greetings all:

This one is driving me crazy. I have a somewhat older Mac laptop and the right side of the touchpad is placed such that the palm of my right hand causes "tap" and "scroll" events while typing. Currently I'm forced to use xinput to switch the mouse totally off, and then I use an external mouse. I also wouldn't mind tweaking some of the Mac's more annoying keyboard choices.

Ordinarily, I'd just make a few edits to xorg.conf, and use synclient/syndaemon. But I'm testing out Kubuntu 9.10 and it doesn't have an xorg file. I've tried Googling for the problem, but no luck so far. Every link I find talks about how to exit xorg.conf (which I already know), and nobody talks about what to do if there is no xorg.conf. Presumably that's because the concept is so new.

How does one adjust settings like this without an xorg file? Will it work if I create one? and if so, what should it look like? Or is there some other file I should be editing?


Any pointers to a man page or links to a web page would be greatly appreciated.
 
Old 10-31-2009, 05:02 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
http://forums.debian.net/viewtopic.p...uchpad#p257111
 
Old 10-31-2009, 05:10 PM   #3
mrider
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 1
Thank you for that link, I hadn't seen that page yet.

But again, that post talks about how to edit xorg.conf. I don't have one. So should I create one? What should it look like? If there is an xorg.conf file, will it have to have all the old sections like it used to? Or do I just include a mouse section?
 
Old 10-31-2009, 07:03 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
I guess, you have some Ubuntu live cd's, older than 9.10.

Just run the live cd on the computer in question,
and save the xorg.conf to usb-key or to Google Docs.

Or may be, you have a backup with xorg.conf files ?
.....
 
Old 10-31-2009, 07:24 PM   #5
mrider
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 1
Not a bad idea. No this is the first time I've run Linux on bare metal on this machine, but I've never quite warmed up to OSx - so I went out and got an all new HDD and now I'm dinking around trying to decide which distro to finally keep.

But yeah, I can always run a live distro and copy the xorg.conf file from that.

Thanks for the tip!

I'll post back with results in case someone lands here from Google.
 
Old 11-01-2009, 01:59 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,939

Rep: Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601Reputation: 2601
OK , then : Ubuntu is not the best to create an xorg.conf,
anyway. In fact, it's the worst.

The most versatile are 1) PCLinuxOS 2007 ... 2009,
2) The Sabayon KDE - DVD version 3.x .
 
Old 11-01-2009, 07:27 AM   #7
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,348

Rep: Reputation: 184Reputation: 184
run Xorg -configure, without x running, which will create an xorg.conf.new in /root that you can copy to /etc/X11/. If I remember right, been a while since I used Ubuntu, you can set root password from adminstration menu and then from grub, use one of the other ubuntu grub entries to boot straight into a terminal console without X.

Last edited by colorpurple21859; 11-01-2009 at 07:29 AM.
 
Old 11-01-2009, 08:02 AM   #8
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Sounds like you are running a very new version of Xserver ... that does not require an xorg.conf file.
In this case HAL takes care of detecting hardware.

Refer to this Ubuntu Configuration Doc
 
Old 11-01-2009, 09:42 AM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,348

Rep: Reputation: 184Reputation: 184
the new xorg will not always detect hardware correctly, as for me where i need to run a max resolution of 1024x768 and xorg wants to set it to 1400xwhatever without a xorg.conf file
 
Old 11-01-2009, 01:57 PM   #10
mrider
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 1
To dxqcanada:

Yeah, it's Kubuntu 9.10 - which does not have an xorg.conf. My basic problem was that I didn't know what to search for. As that article states, I need to make changes to an .fdi file. I have one now that I'm tweaking now, I don't yet know what I want the final settings to be. But I'm getting closer.



I started by creating an xorg.conf and editing it as I would ordinarily do. But that made things worse rather than better. The problem was that the settings I had in xorg.conf merged with the listed hardware rather than overwriting it. So I went from having one mouse driver that drove me crazy to having two mouse drivers that battled with each other, both of which drove me crazy.



So thanks everyone that helped, I think I'm on the road to solving this. It's just a matter of tweaking the FDI file until the mouse stops surprising me.

And sorry it took so long to get back with my response, I was offline trying different settings and tweaking stuff rather than sitting at the browser.
 
Old 11-01-2009, 05:14 PM   #11
mrider
LQ Newbie
 
Registered: Oct 2006
Distribution: Debian
Posts: 22

Original Poster
Rep: Reputation: 1
Solved

Here's my final resolution. I saved the following as /etc/hal/fdi/policy/appletouch.fdi:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
      <match key="info.product" contains="appletouch">

        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>
        <merge key="input.x11_options.SHMConfig" type="string">On</merge>

        <merge key="input.x11_options.HorizEdgeScroll" type="string">0</merge>
        <merge key="input.x11_options.HorizTwoFingerScroll" type="string">0</merge>
        <merge key="input.x11_options.HorizScrollDelta" type="string">0</merge>

        <merge key="input.x11_options.VertEdgeScroll" type="string">0</merge>
        <merge key="input.x11_options.VertTwoFingerScroll" type="string">0</merge>
        <merge key="input.x11_options.VertScrollDelta" type="string">0</merge>

        <merge key="input.x11_options.FingerLow" type="string">30</merge>
        <merge key="input.x11_options.FingerHigh" type="string">40</merge>
        <merge key="input.x11_options.PressureMotionMinZ" type="string">10</merge>

        <merge key="input.x11_options.TopEdge" type="string">50</merge>
        <merge key="input.x11_options.BottomEdge" type="string">300</merge>
        <merge key="input.x11_options.LeftEdge" type="string">100</merge>
        <merge key="input.x11_options.RightEdge" type="string">1100</merge>

        <merge key="input.x11_options.MinSpeed" type="string">0.15</merge>
        <merge key="input.x11_options.MaxSpeed" type="string">0.90</merge>
        <merge key="input.x11_options.AccelFactor" type="string">0.10</merge>

        <merge key="input.x11_options.MaxTapMove" type="string">100</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">3</merge>
        <merge key="input.x11_options.TapButton3" type="string">2</merge>
        <merge key="input.x11_options.ClickFinger1" type="string">1</merge>
        <merge key="input.x11_options.ClickFinger2" type="string">3</merge>
        <merge key="input.x11_options.ClickFinger3" type="string">2</merge>

        <merge key="input.x11_options.TouchpadOff" type="string">2</merge>
        <merge key="input.x11_options.PalmDetect" type="string">1</merge>

      </match>
    </match>
  </device>
</deviceinfo>
There are several points of interest.
1) "PalmDetect" doesn't seem to detect my palm. Which leads to #s 2 and 3.

2) I had to turn off horizontal and vertical edge scrolling. Whenever edge scrolling is on, if my hand is on the keyboard home row and the mouse is at the screen edge, the multi-desktop effect starts rotating around like I'm solving a Rubik's cube really fast.

3) I had to turn off two-finger scrolling for the same reason.

3) I might be able to solve #3 if I continue to tweak the values for FingerLow, FingerHigh, and PressureMotionMinZ. But I'm tired of fighting, so I just turned it off. That's okay, I don't use mouse gestures much anyway.

4) I have values for 1, 2, and 3 finger tapping and clicking. But I also have TouchpadOff set to 2, which turns that off.

So basically my mouse just points now. That's it. But if I'm mostly mousing around, I can issue the command synclient TouchpadOff=0 at a command prompt, and tapping comes to life.

Haven't quite figured out how to set the mouse to use alt+click as a right click like in OSx, but I imagine it's doable.

Anyway, FYI. And thanks for all the suggestions, they definitely pointed me in the right direction.

Last edited by mrider; 11-01-2009 at 05:17 PM.
 
  


Reply

Tags
disable, macbook, tapping, touchpad, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] synaptics touchpad settings in xorg.conf not persisting upon reboot adityavpratap Slackware 20 05-17-2010 07:57 PM
How to set mouse sensitivity in xorg.conf, not window manager lasindi Slackware 8 03-19-2006 05:16 PM
xorgconfig set up xorg.conf wrong DraaX Slackware 8 02-16-2005 12:38 PM
can't get xorg.conf set correctly lnxmacusr Slackware 3 12-29-2004 06:40 PM
A Quick Xorg.conf set up mikz Slackware 1 10-25-2004 07:40 PM


All times are GMT -5. The time now is 05:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration