LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-26-2006, 05:44 PM   #1
billyseth
LQ Newbie
 
Registered: Oct 2006
Posts: 5

Rep: Reputation: 0
serial port not working properly


I cannot seem to figure out the problem with my serial port.
I am trying to get lirc working, and cannot seem to figure out how to get my serial port to handle everything correctly.

I am using /dev/ttyS0 and am sure that my receiver works, I am not positive on whether this is a serial port problem or not, but I think it is.

setserial -bg /dev/ttyS* returns:

/dev/ttyS0 at 0x03f8 (irq = 4) is a 16550A

but I forced that in serial.conf. I load lirc_serial successfully. Though when I run "mode2" the lirc testing program, I get no response, so this could be an lirc problem or a serial port problem, any help narrowing it down would be greatly appreciated. thanks.
 
Old 10-27-2006, 10:30 PM   #2
jcliburn
Member
 
Registered: Dec 2003
Location: Mississippi, USA
Distribution: Fedora
Posts: 435

Rep: Reputation: 33
If you have a null modem cable, hook up another computer's serial port and see if you can establish a serial console to your Linux machine. You'll need to modify your kernel boot parameters to something like this:

kernel /vmlinuz-2.6.19-rc3.20061026 ro root=/dev/VolGroup00/LogVol00 vga=794 console=ttyS0,38400 console=tty0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
serial port on the db1500 not working? ashlesha Linux - General 0 07-25-2006 01:40 PM
Using serial port card(PCMCIA) with IPAQ running Linux, can't find ttyS0 port d2army Linux - Laptop and Netbook 0 11-12-2005 09:07 PM
Verify Serial Port is Working spelltoronto Linux - Newbie 2 05-25-2005 04:58 PM
serial port not working. Gregorygoh Linux - Hardware 1 02-23-2005 01:08 AM
RedHat 9 PS/2 mouse on serial port: not working neylitalo Linux - Hardware 1 09-05-2004 05:33 PM


All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration