LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-06-2004, 10:52 PM   #1
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Rep: Reputation: 0
Scroll wheel doesn't work with mouse


I've tried the search feature, and while I've found a number of threads dealing with this, none have solved my problem. I'm running Debian (Woody), and the 2.4.22 kernel. I have a USB Logitech mouse with two buttons and a scroll wheel. The mouse is attached to my computer via a USB to PS2 adapter. The mouse works fine in Win2k. In Linux, I can use the middle button to click things but the scroll won't work.

I'm a Linux newbie, but here's what I've tried.
I set up my mouse via "dpkg-reconfigure --priority=low xserver-xfree86"
I selected /dev/psaux, emulate 3 buttons no, and enable scroll wheel.
This writes /etc/X11/XF86Config-4
The relevant parts (I think) are listed below:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Generic Mouse"
EndSection

This causes my mouse to behave very oddly. I've read this referred to in other threads as "crazy mouse". Basically the cursor moves to the bottom left hand corner of the screen and does odd things like left and right click without me having hit the buttons. Also, this sometimes causes my keyboard not to work except for Ctrl-Alt-Backspace

I've tried setting Protocol in the Configured Mouse section to all the possible options with the following results:
ImPS/2: crazy mouse
PS/2: works but no scroll
GlidePointPS/2: works, but no scroll
NetMousePS/2: crazy mouse
NetScrollPS/2: moving left also causes scroll up. moving right also causes scroll down. Scroll wheel does nothing
ThinkingMousePS/2: crazy mouse
MouseManPlusPS/2: works, but no scroll
ExplorerPS/2: crazy mouse

I've also tried using the mouse without the adapter, so it was plugged directly into a USB port. I then reran "dpkg-reconfigure --priority=low xserver-xfree86" and selected /dev/input/mice instead of /dev/psaux, but the scroll wheel still didn't work.

One other thing I've noticed is that most threads dealing with the no scroll issue mention changing settings in /etc/X11/XF86Config. This seems to have no effect on my computer. Only changing /etc/X11/XF86Config-4 does anything.

Any help is greatly appreciated!
 
Old 04-07-2004, 12:26 AM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
My 2 cents: I don't know if this will help, but I'd question declaring 2 mice within a single ServerLayout, and if you're using a USB-to-PS/2 adaptor, I'd be inclined to use the regular /dev/mouse rather than /dev/psaux. Here's what the relevant sections of my XF86Config looks like, although I'm on Slack rather than Debian, so it may be that Debian uses a different approach. Good luck -- J.W.

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection
 
Old 04-07-2004, 01:50 AM   #3
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks for the response, J.W. Unfortunately the changes you suggested resulted in X not even starting at all. I tried those settings as best I could. I don't have a /dev/mouse, so I used /dev/input/mice. I commented out the "Generic Mouse" and used your settings for my "Configured Mouse" with the mouse plugged in with the adapter and also without it. Here's what my /var/log/XFree86.0.log recorded both times:

(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(EE) xf86OpenSerial: Cannot open device /dev/input/mice
No such device.
(EE) Configured Mouse: cannot open input device
(EE) PreInit failed for input device "Configured Mouse"
(II) UnloadModule: "mouse"
(WW) No core pointer registered
No core pointer

Fatal server error:
failed to initialize core devices

Also, I forgot to mention earlier I have an optical mouse. I don't know if this matters or not.
 
Old 04-07-2004, 02:30 AM   #4
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
I just also tried /dev/input/mouse{0,1,2,3} and /dev/input/event{0,1,2,3} with the same results. The mouse works (but not the scroll wheel) when plugged into a USB port and "Device" is set to /dev/psaux. Why is this? I thought /dev/psaux was the PS/2 port.
 
Old 04-07-2004, 05:32 AM   #5
pipio
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian Sid
Posts: 12

Rep: Reputation: 0
Maybe this can help you.
 
Old 04-07-2004, 07:45 AM   #6
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Sometimes case is everything. I had the same trials as you on some distro installs. One thing that I don't think you've tried yet is: change "ImPs/2" to "IMPS/2"

I think the syntax changed for a certain revision of the X-server, but I'm not sure. Try it. Worked for me.
 
Old 04-07-2004, 04:14 PM   #7
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by pipio
Maybe this can help you.
Thanks for trying pipio, but the only difference I see between that and my setup is the line "Option" "Emulate3Buttons" "true". I don't think I need this because my mouse already has three buttons (including the scroll wheel).

Quote:
Originally posted by vectordrake
Sometimes case is everything. I had the same trials as you on some distro installs. One thing that I don't think you've tried yet is: change "ImPs/2" to "IMPS/2"

I think the syntax changed for a certain revision of the X-server, but I'm not sure. Try it. Worked for me.
I tried changing both instances of "ImPS/2" to "IMPS/2" but the mouse behaved the same either way.

Any other ideas? I'm using XFree86 4.1.0.1 if that makes a difference. I guess I'll try upgrading to 4.4.0.
 
Old 04-07-2004, 04:54 PM   #8
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Try
Code:
Option "Buttons" "5"
 
Old 04-07-2004, 05:04 PM   #9
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by vectordrake
Try
Code:
Option "Buttons" "5"
I tried it, but it didn't change anything.
 
Old 04-07-2004, 10:32 PM   #10
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
If I weren't bald, I'd be pulling out my hair. Got a big hammer? Or $20 for a new MS optical USB/PS-2? J/K
 
Old 04-08-2004, 01:19 AM   #11
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
Unhappy

Oh well. I've given up for now. After upgrading to Sarge, my computer will no longer boot into Linux. Time for a fresh install...
 
Old 04-08-2004, 01:47 AM   #12
bones996
Member
 
Registered: Sep 2003
Location: Pennsylvania
Distribution: Debian Squeeze
Posts: 106

Rep: Reputation: 15
My logitech optical mouse also has 3 buttons, but to use the scroll wheel on one distro or another (I forget which) I had to select emulate 3 buttons to get the scroll wheel to work right. Don't know why, but after I changed it the mouse worked fine.
 
Old 04-12-2004, 01:55 AM   #13
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Original Poster
Rep: Reputation: 0
Smile

In case this helps anyone else, I eventually got my scroll wheel working. I reinstalled Debian and got the system back the way it was before I tried to upgrade. I then tried adding the line, "Emulate3Buttons" "true", but this had no effect. I then skipped testing and upgraded right to Sid, the unstable version of Debian. I then compiled the newest kernel (2.6.5). My mouse now works great, even though it still has the Option "Protocol" "PS/2" in the "Configured mouse" of my XFConfig-4 file. It's finally working, so I'm a bit hesitant at the moment of playing with options lest I mess it up again.

Another thing is the message dmesg spits out. It gives the following lines that are quite different than before (my motherboard is a SIS by the way - re: line 2):
mice: PS/2 mouse device common for all mice
Failed to disable AUX port, but continuing anyway... Is this a SiS?
If AUX port is really absent please use the 'i8042.noaux' option.
serio: i8042 AUX port at 0x60,0x64 irq 12
input: ImPS/2 Logitech Wheel Mouse on isa0060/serio1



I guess it was something in the new kernel that's different by default, or maybe I just enabled the right setting this time. Either way, my mouse works, and I'm happy.
 
Old 04-12-2004, 02:48 AM   #14
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 50
check you have necessary stuff in your kernel first, the rest like setting up XFree manually is easy.
 
Old 04-12-2004, 07:23 AM   #15
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Yeah. There are quite a few things in the 2.6 kernel that are different. I'll find it hard to go back to a 2.4 because a lot of stuff like mouse support just works better (and the threading is so much better - its way faster)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I get my mouse-wheel to scroll? MurphyB2005 Slackware 8 04-22-2005 12:16 AM
Scroll wheel of mouse - How to make it work? Redhat 9 umeshz Red Hat 19 12-29-2004 05:54 AM
4d wheel mouse - scroll wheel no worky CamelofCamelot Linux - Hardware 1 10-28-2004 08:33 PM
Mouse - wheel does not scroll cevjr Linux - Hardware 5 09-05-2003 01:19 PM
Mouse Wheel Scroll Muddy Linux - General 6 06-11-2002 06:55 AM


All times are GMT -5. The time now is 05:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration