LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-22-2004, 09:07 AM   #1
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Rep: Reputation: 15
Screen goes black after installing new gforce fx5200


I have just installed a new gforce fx5200 video card on my Asus a7v8x-ms-uay motherboard and now when I start up my Red Hat 9, the screen goes black. All goes well and the everything is checked by linux as normal, and then just when the login screen normally comes up - blank !

Previously, without the new card things were ok - at least I could get into the gui etc. But I bought the new card because the on-board graphics stuff wasn't recognized by linux and graphics were horrible. No GL support etc.

I seems like the old settings are still active and the new card is not being recognized. But how do I change this if I can't get into the gui?

After I choose RH in Grub (running XP & RH dual boot) things go black. How can I at least get into a shell command from Grub to then perhaps run kudzu to scan for the new hardware? I think I may have disabled kudzu on boot-up on a previous occasion because it was interfering with the sound settings - so I'll have to actually tell linux to run it.

Please take it easy on me - I'm fairly new to it all.
 
Old 06-22-2004, 09:50 AM   #2
Booster
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo, Suse
Posts: 59

Rep: Reputation: 15
Sounds like your machine is using framebuffer for your console, assuming you're using LILO, when you get to the boot prompt, try this:
linux vga=normal
Where "linux" is the label for your linux install. That should force the kernel to display in "normal PC text". If you're using Grub as the bootloader, if memory servs correctly you highlight the entry you want to boot, then hit "E" (for Edit), and then add the vga=normal.
 
Old 06-22-2004, 04:04 PM   #3
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
Thanks for helping out Booster

I'm using Grub. Your suggestion didn't work. This is what I did:

When Grub comes up I can choose between Dos and RH9. I highlight RH9 and press e. I'm was then faced with the following choices:
root (hd0,1)
Kernel /vmlinuz-<kernel> ro root=LABEL=/ hdd=ide-scsi
initrd /initrd <kernel>.img

I tried each one, highlighting it then pressing e, then typing vga=normal at the end of the line, press Enter, press b for boot. But nothing - still black. I tried this 3 times editing each of the 3 lines in turn.

I also tried reinstalling RH by putting the installation cd in. But after the first screen asking what I want to do (install/update RH) I get the same result - black screen.

I bought the Nvidia card coz I read that it would work well with linux since nvidia supports linux.

Thanks again. Please keep trying
 
Old 06-23-2004, 08:39 AM   #4
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
I've made some progress (but I still need help)

I was able to change the runlevel by typing 'emergency' behind the kernel line (Kernel /vmlinuz-<kernel> ro root=LABEL=/ hdd=ide-scsi emergency) then Enter and b. I booted into the shell.

So now at least I am able to change stuff in linux, but what needs to be changed?

I ran kudzu, but it didn't seem to pick up the new video card - there was no mention of it.

What do I do from here? How do I get x started and have it dispaly on the screen?
 
Old 06-23-2004, 09:09 AM   #5
Booster
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo, Suse
Posts: 59

Rep: Reputation: 15
Cool, good to see you made a bit of progress.

Two things:

1. Do you need the initrd? (if you don't know, you likely don't). If not, try doing "e" in grub and deleting that line - worth a shot. It _really_ sounds like it's going to an invalid framebuffer mode for your card at boot, don't recall for sure, but I think adding "nofb" to your kernel boot line should disable it.

2. Did you install the nvidia kernel module? If not, you should be able to do so from a text console: lynx http://www.nvidia.com/linux should take you to the list, just go down until you highlight the one beside "Latest Version" under "Linux IA32", hit enter, the highlight the .run file and hit D, and save it, then quit lynx, and run "sh ./NVIDIA-Linux-(version#)", and it'll install.
You'll also need to edit your XF86Config, relevant areas from mine below:

Code:
Section "Module"

    Load        "dbe"

    # Load the glx module.
    Load        "glx"

    Load        "extmod"

    Load        "type1"
    Load        "freetype"
EndSection
Code:
Section "Device"
    Identifier  "NV AGP"
    VendorName  "nvidia"
    Driver   "nvidia"
    #Driver   "nv"
    # update this with the PCI id of your card.  Consult the output
    # of the 'lspci' command.  The BusID is usually optional when
    # only using one graphics card.
    BusID       "PCI:1:0:0"
Option "NoLogo" "1"
Option "CursorShadow" "1"
    Option "IgnoreDisplayDevices" "DFP, TV"
Option "NvAGP" "3"
Option "CursorShadowAlpha" "64"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
Option "DigitalVibrance" "3"
EndSection
Good luck.
 
Old 06-23-2004, 09:19 AM   #6
vrln
Member
 
Registered: Mar 2004
Location: Finland
Distribution: Gentoo
Posts: 235

Rep: Reputation: 30
So commandline mode works just fine? Itīs completely normal that X doesnīt work yet - itīs because itīs still trying to use your old cards settings that obviosly donīt work. The reason why everyone praises nvidia is because of their drivers that are one of the best. You need to go to www.nvidia.com and download the 32bit linux drivers. You can do this even without graphical mode just use links or lynx to to browse the web and download the drivers. You can also download the drivers with wget (just type wget url).

After this you will need to run the installer with sh nameofthenvidiainstaller.run - note that you need to have kernel source installer (the nvidia installer will need it). Now you need to edit your X config file. Mine is /etc/X11/XF86Config-4, not sure if itīs the same on redhat... Anyway, there is a line there where you need to write nvidia.

Iīm on a windows comp right now so I donīt know what the line is. Check the nvidia installer readme, it has very good instructions.

You can also come to irc with irssi and ask for help - it works in commandline mode.

edit: oops, someone already answered all this when I was writing this post

Last edited by vrln; 06-23-2004 at 09:20 AM.
 
Old 06-23-2004, 03:06 PM   #7
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
Thanks so much for you help Booster and vrln. I'll give all this a go and get back to you.
 
Old 06-24-2004, 08:31 AM   #8
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
I've just spent quite a few hours trying to solve what are probably the most basic problems. Frustration levels are rising rapidly

Here is what I've tried:

*Deleted the initrd line in Grub - this caused a "Kernel Panic"
*Added the 'nofb' to the kernel line - no change; still can't get X up.
*Was able to get lynx going (yeaiiiii!) but could not connect to the internet. I don't know how to activate my ethernet
connection to my adsl modem (this used to just be up and running when things were working on the old video card)
*Used windows to download the Nvidia driver and burned it to a CD, then went back to linux shell to try to install it off the
CD. But I was unable to mount the CDdrive. Tried all sorts of things that I read about on the net but without success

*Tried to edit XF86Config using VI (took me an hour to work out how to use the thing) but could not save changes (used the
:w! command). It tells me: "XF86Config E121: Can't open file for writing". perhaps I opened it the wrong way? simply went
to the etc/X11 directory and typed "vi XF86Config"

I'm stuck !

Is there a way of putting in the RH9 installation CD and starting from scratch? Last time I tried this the screen went black after the initial intro to installation.

Please help.
 
Old 06-24-2004, 04:17 PM   #9
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
Some more progress

It appears that when entering runlevel 'emergency' things don't work as normal.

I have finally figured out how to enter runlevel 3: by typing 'runlevel 3' at the end of the kernel line.
(Why haven't I tried this before ....

So now, using lynx, I can browse the net.

I'm assuming that I will also be able to edit the XF86Config file

Give me some time before going through the trouble of replying to my previous post. Perhaps things will start working for me now.

I'll be back and let you know how it goes
 
Old 06-25-2004, 07:10 AM   #10
oliwally
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Mandrake 10 Official
Posts: 38

Original Poster
Rep: Reputation: 15
Yea Baby ! Bingo ! Touchdown! Bonza-ripsnort-beauty!

Everything works just as it should now. Once in runlevel 3 all was sweet. CD drive worked too. Installed Nvidia as per instructions and el-presto, all was well.

Thanks again for your patient support.
 
Old 06-25-2004, 10:02 AM   #11
Booster
Member
 
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo, Suse
Posts: 59

Rep: Reputation: 15
Good to hear!

Sounds like you learned quite a bit on the way too!

Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black and White S-VIDEO output from GeForce FX5200 on Debian doctorwebbox Linux - Hardware 0 11-17-2005 11:56 AM
Installing RedHat 9: Black screen ! gotit Linux - Newbie 5 03-04-2005 03:48 AM
Black and White tvout nvidia FX5200 doctorwebbox Linux - Hardware 3 02-20-2005 10:57 PM
MSI GFORCE FX5200 128mb nvidia-Display Problem sunil1978 Linux - Hardware 5 12-20-2003 03:01 PM
Black screen installing Mandrake 9 clothocan Linux - Newbie 10 12-21-2002 11:19 PM


All times are GMT -5. The time now is 11:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration