LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 05-29-2008, 12:24 AM   #1
ENVee
LQ Newbie
 
Registered: Jul 2007
Posts: 18

Rep: Reputation: 0
SATA HDD not detected


I am trying to create a Linux Installer for LFS v6.3

Within the installer script , I try to detect all hard-disks attached to the PC

I know for sure that my test PC has a SATA hard disk attached. However , when I run fdisk -l , I only see the IDE drives.

I also loaded the following modules , but this still did not create the necessary /dev/sdxx nodes :
libata.ko
sata_promise.ko
sata_qstor.ko
sata_sil24.ko
sata_sil.ko
sata_sis.ko
sata_sx4.ko
sata_via.ko

Can someone please help me out ?

(actually , as I type , I am wondering if I need to load the ata_piix.ko module....will give that a shot as well , and keep you posted)

I also executed lspci , but the output did not produce any text which would indicate my SATA hard-disk controller. There were only numbers.

Is there some particular option that I need to pass to lspci to be more helpful ?
 
Old 05-29-2008, 12:48 AM   #2
ENVee
LQ Newbie
 
Registered: Jul 2007
Posts: 18

Original Poster
Rep: Reputation: 0
loaded ata_piix.ko

I insmod'ed ata_piix.ko

It produced output some output like the SATA disk number STXXXXX etc. etc.

But I still could not see the device node at /dev/sdaxx

Is there something I am missing here fundamentally ?

I think so , since I am only 10 months new to the device level programming world of Linux.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SATA HDD not detected by RHEL 3 tataiermail Linux - Hardware 3 03-28-2008 03:01 AM
SATA HDD not detected when installing slack 11.0 pimy Slackware 6 10-24-2006 10:25 PM
SATA HDD not detected duryodhan Slackware 3 10-16-2006 08:55 AM
sata hdd not detected during install nukeu666 Debian 16 12-25-2005 02:23 PM
SATA problem, hdd is detected but no dev is assigned cubus Slackware 1 03-18-2004 03:57 PM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration