LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 02-24-2004, 09:41 AM   #16
oaksword
LQ Newbie
 
Registered: Feb 2004
Location: Plymouth, UK
Distribution: Fedora 3 (DVD)
Posts: 6

Rep: Reputation: 0
I am not so sure.


You can have a try. I have not found a time and opportunity to upgrade yet. My system has too many things to backup and protect. It is too risky, especially from a newbie's point of view.
I made that conclusion because, I have 1 yr old China made 64M usb storage key. That works very well. Only the new one doesn't work. Even on my XP laptop, this device is classified as high speed usb. It doesn't work well with XP as well. So I won't surprise if the new hardware doesn't work on linux.
I am going to try it ASAP. After that I think I can have more thing to talk about it.
 
Old 02-26-2004, 03:25 PM   #17
zagnut
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Supermount is the villain...

The problem seems to be that the mini-Cruzer + USB-hotplug + supermount is a bad combination. If you have supermount compiled into the kernel, you simply cannot get this disk to mount. If you, however, use any kernel without the supermount patch applied, it seems to work flawlessly (though it has a FAT12 filesystem on it, I reformatted mine).

This is why the device is so aggravating to users of Mandrake, where the supermount patch is in the default kernel.
 
Old 02-27-2004, 05:19 PM   #18
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
Does anyone know how to disable supermount in SuSE???
 
Old 03-27-2004, 03:03 PM   #19
youre
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
For Fedora and Redhat 9, I ran the Hardware Browser and determined that the Sandisk was at /dev/sda1.

Therefore, create a directory to mount to:
mkdir /mnt/usb1

And add the following to your /etc/fstab:
/dev/sda1 /mnt/usb1 vfat users,uid=youre,gid=youre,rw,umask=000 0 0

Where "youre" is my linux user id. You could also use "500" which is the correspoding id from /etc/passwd and /etc/group.

Then run as root or sudoer:
mount -a

You should now be able to access the Sandisk drive at /mnt/usb1.

Please make sure to unmount the Sandisk when you're finished (run as root or sudoer):
umount /mnt/usb1

Enjoy!

Last edited by youre; 03-27-2004 at 04:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sandisk cruzer mini gallan Linux - Hardware 5 11-21-2006 08:55 AM
SanDisk Cruzer Mini Thumb Drive Problem kdogksu Linux - Hardware 1 12-26-2004 05:09 PM
Trouble with SanDisk Cruzer Mini dr_zayus69 Linux - Hardware 5 12-05-2004 09:28 PM
How to mount USB FlashDisk: SanDisk Cruzer Mini? acer_peri Linux - Hardware 5 09-29-2004 03:22 AM
SanDisk Cruzer mini 256 mb greendusk Linux - Hardware 16 01-25-2004 01:56 PM


All times are GMT -5. The time now is 05:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration