LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-11-2007, 01:17 AM   #31
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171

1. See if you have gtf on your system. If not it should be available from your packet manager.

2. In this example I will generate a modline for 1440 X 900 @ 60

[fred@127 ~]$ gtf 1440 900 60

# 1440x900 @ 60.00 Hz (GTF) hsync: 55.92 kHz; pclk: 106.47 MHz
Modeline "1440x900_60.00" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
3. Insert the generated modline in the section similar to this:

Section "Monitor"
#HorizSync 31.5 - 100.0
#VertRefresh 56.0 - 75.0
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
ModeLine "1440x900_75" 136.8 1440 1536 1688 1936 900 901 904 940 -hsync +vsync
ModeLine "1440x900_60" 106.5 1440 1520 1672 1904 900 901 904 932 -hsync +vsync
Option "DPMS"
EndSection


4. Add your resolutions similar to this:

SubSection "Display"
Depth 24
Modes "1440x900_75"
EndSubSection

5. Save xorg.conf

restart xserver
 
Old 03-11-2007, 10:06 AM   #32
SilverBear2006
Member
 
Registered: Oct 2006
Location: Great Lakes region, North America
Distribution: Mepis 7.0, Mepis 8.0, ArchLinux, Pardus 2008, Kubuntu 8.04, Ubuntu 8.10
Posts: 69

Rep: Reputation: 16
xorg.conf adjustment

Hi, ashesh.

In the xorg.conf you posted for us, it would seem to me that the modeline needs to go in this section:
Quote:
Section "Modes"
Identifier "Modes[0]"
EndSection
So it would look line this:
Quote:
Section "Modes"
Identifier "Modes[0]"
# 1152x864 @ 75.00 Hz (GTF) hsync: 67.65 kHz; pclk: 104.99 MHz
Modeline "1152x864_75.00" 104.99 1152 1224 1352 1552 864 865 868 902 -HSync +Vsync
EndSection
IMHO, it's a very good practice to include the comment line that the gtf utility generates, as it contains the settings data you need to compare to your monitor specs to make certain you're not going to fry it.

You already have the "Screen" section set to include "1152x864" so make this one change and you should be able to choose your display setting of 1152x864 from the GUI after you restart the xserver [Ctl-alt-backspace] on most Linux distros.

It will probably go right into your preferred res, as we are only giving it one preferred option.

If this doesn't do it, we'll all be standing by. But let us know, OK?

All the best,
SilverBear

Last edited by SilverBear2006; 03-11-2007 at 10:13 AM.
 
Old 03-11-2007, 10:25 AM   #33
SilverBear2006
Member
 
Registered: Oct 2006
Location: Great Lakes region, North America
Distribution: Mepis 7.0, Mepis 8.0, ArchLinux, Pardus 2008, Kubuntu 8.04, Ubuntu 8.10
Posts: 69

Rep: Reputation: 16
You probably know this already, but just in case:
you need to edit the /etc/X11/xorg.conf file as root, with a text editor, not a wordprocessor.
If you're not root, it won't let you save the file to the /etc directory, as all the files in there are owned by root.

To get to be root and into editing the file, here's what I would do, since I'm running KDE. At the command line prompt $:
kdesu kwrite /etc/X11/xorg.conf
you'll be prompted for your root password, and then kwrite will open the file as with superuser [root] privileges.

In gnome, instead of kdesu, you use gtksu and then whatever editor you have installed instead of kwrite.
 
Old 03-11-2007, 12:29 PM   #34
ashesh0326
Member
 
Registered: Jan 2007
Distribution: Suse 10.0, FC 6
Posts: 93

Original Poster
Rep: Reputation: 15
Well, I tried exactly what you told me to SilverBear2006, but no, it's still not working...
Thank you all for so much help...
What do we do next?
 
Old 03-11-2007, 02:24 PM   #35
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You could try generating a new xorg.conf from the command line. Before doing so, make sure you have a proper back-up of your current one because it will get overwritten in the process.

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak

When you're done change to runlevel 3:

su -
root password
init 3

then run this command:
/usr/bin/xorgcfg (or /usr/bin/xorgconfig - I think both will work)

Follow the instructions; I think they're clear and intuitive.

Don't worry if you don't get it right straightaway; you can always start over. If you can't get into Gnome/KDE anymore, you can simply boot into runlevel three by adding this to your boot line in Grub:

3

that's all, really.

If it doesn't work and you need to recover your old display, you place back your xorg.conf.bak:

cp /etc/X11/xorg.conf.bak /etc/X11/xorg.conf

I'm afraid this approach is pretty much the last option so I hope it helps.

Last edited by jay73; 03-11-2007 at 02:26 PM.
 
Old 03-11-2007, 10:12 PM   #36
SilverBear2006
Member
 
Registered: Oct 2006
Location: Great Lakes region, North America
Distribution: Mepis 7.0, Mepis 8.0, ArchLinux, Pardus 2008, Kubuntu 8.04, Ubuntu 8.10
Posts: 69

Rep: Reputation: 16
Try what Jay73 suggests.

Additional thought:
I used to use SuSE 10.0 but I don't have an install of it right now to check this out with.
I seem to remember that the installation disk had a lot of "configuration" and "repair-installation" options.

If you could use your SuSE install disk to reinstall an authentic SuSE xorg.conf [without affecting anything else], we might get somewhere with that. I have never worked with saX before, and I think that the xorg.conf file it left you with it has just muddied the picture.
 
Old 03-13-2007, 07:41 AM   #37
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Rep: Reputation: 33
Hello again,

I just read this article and while it is a bit dated is very similar to the symptons ashesh0326 is having...
Please read this and add your comments..

http://users.netwit.net.au/~pursang/intel.html

BTW ashesh, what is your motherboard chipset and your system memory? Edit I just read 915 chipset but how much system memory?
jolphil

Last edited by jolphil; 03-13-2007 at 07:43 AM.
 
Old 03-13-2007, 07:23 PM   #38
BorisMcHack
Member
 
Registered: May 2004
Location: uk
Distribution: debian sarge
Posts: 65

Rep: Reputation: 15
[ignore me]

Last edited by BorisMcHack; 03-13-2007 at 07:35 PM.
 
Old 03-14-2007, 12:46 AM   #39
ashesh0326
Member
 
Registered: Jan 2007
Distribution: Suse 10.0, FC 6
Posts: 93

Original Poster
Rep: Reputation: 15
Hi guys,
I'm sorry for my late response, I haven't been at home for the past few days.
BTW, jolphil, I have 512 MB of RAM... please let me know of any further details.
Thank you so much for the help people. I'll go through the link you've specified and let you know if it helped.
jay73: Well, thanks man. I tried what you said, but whenever I did, my system returned some 'server crash error message'. I'll be posting the details about that soon.

Thanks all.
 
Old 03-14-2007, 04:17 AM   #40
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Hi ashesh

You shouldn't be overly impressed with the whole "server crash" business, it sounds way worse than it is. Please do post more detail about the exact error message, that would be extremely useful. I wouldn't be surprised if it were simply a matter of not choosing the best available option during xorgcfg.

Note: if you followed my suggestions, you can always use your back-up if you want to avoid the server crash.
 
Old 03-19-2007, 09:35 AM   #41
ashesh0326
Member
 
Registered: Jan 2007
Distribution: Suse 10.0, FC 6
Posts: 93

Original Poster
Rep: Reputation: 15
Hi guys,
I'm sincerely very sorry for the delay in my response, I couldn't help the situation as I was out of town.

And well, Jay, I did try what you suggested, and I also got the server to run by typing xorgconfig instead of xorgcfg. Then, I put in all the details as meticulously as possible, and then rebooted.

The xorg.conf file was successfully written, but this time, after any number of reboots, my system refused to go to runlevel 5 (I tried typing init 5); in fact, everytime I rebooted, my system started up in runlevel 3.

Ultimately, I had to restore the backup and reboot, and this time, the system automatically loaded the GUI (runlevel 5).

I have one doubt. I checked on the intel site to see what video accelerator my motherboard has, and found it out to be GMA 900 graphics system. I tried to check in the working xorg.conf file to see what it was using, and it says 'i810'. I also selected the same card while making a new xorg.conf file through xorgconfig. Is that the problem?

If it is, then why is my old xorg.conf working? Any ideas?
 
Old 03-19-2007, 12:31 PM   #42
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Phew, I'm glad to hear from you after all this time. I was beginning to fear my well-meaning advice had caused your computer (and you too) to blow up...

Why the old xorg.conf should suddenly have begun to function properly, that's something of a mystery to me. The only two things I know is that, in my experience at least, autodetection of video cards is an uncertain thing; I've seen at least as many mistakes as successes. On top of that, Suse is one of the most pig-headed distributions I've ever seen when it comes to such things. The real problem, I think, is this sax2 utility, which seems to hide away a good deal of details (it's no coincidence many say that Suse comes pretty close to Windows) and those may well prevent you from making any corrections through xorg.conf. I've seen this on my own pc and the only thing that did help was using xorgconfig. That must be like some kind of sledgehammer blow to sax2; I've rarely seen it resist any longer after that. Still, I'm a bit surprised you couldn't get into runlevel 5. My guess is some minor mistake was made - and that is usually all it takes; in the end, this didn't allow you to boot into runlevel 5 but using xorgconfig alone was enough to unsettle any hidden sax 2 settings so that your xorg.conf could finally take full effect. And let's not forget that your old xorg.conf wasn't exactly your old xorg.conf anymore: I believe you had already done some manual editing on it; it seems these modifications only got through after trying xorgfonfig. This does seem likely to me, but again, I'm not too sure either.

As a last piece of advice, do make sure you have a copy of xorg.conf stored away in a safe place.

And oh yes, enjoy your Suse. It's been a lot of work but that's OK, I nearly killed myself trying to master Debian 3.1 some time ago; I utterly failed in certain respects but, who cares, it's given me so much confidence and insight that I could now wreck half my system and repair it in a matter of minutes. Who knows, with a little learning, I may some day be able to wreck all of it ...

Last edited by jay73; 03-19-2007 at 12:52 PM.
 
Old 03-22-2007, 09:01 AM   #43
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Rep: Reputation: 33
hello again,
I been thinking about your problem and keep coming back to the Integrated graphics system and how it relies on CPU power and system memory..
Quote:
I have one doubt. I checked on the intel site to see what video accelerator my motherboard has, and found it out to be GMA 900 graphics system. I tried to check in the working xorg.conf file to see what it was using, and it says 'i810'.
What I found might help to understand how important the entire system plays in the higher resolution/refresh rate
that is required..Sorry to keep coming back to the same line..
http://www.intel.com/design/graphics/gma900/

jolphil
 
Old 03-23-2007, 12:51 AM   #44
ashesh0326
Member
 
Registered: Jan 2007
Distribution: Suse 10.0, FC 6
Posts: 93

Original Poster
Rep: Reputation: 15
Thanks Jay73 and Jolphil.
Well, I pretty much believe it now that the real problem with my display now is what my system sees my graphics card as. I've tried my best with switching monitors, but somehow, sax wouldn't let me switch to anything more than 60 Hz on a 1280x1024 screen. And 60 Hz is all it thinks my 'i810' graphics card is capable of.
I've been through the link you've specified Jolphil, I'd been to it before, and yes, it provided me with some mighty good insight as to what my video card was capable of.
Here are two things I found interesting:
> 128 MB maximum video memory
> 2048x1536 at 85 Hz maximum resolution
I think this more or less proves that sax has got it wrong in my case. It still recognises my card as i810, and come to think of it, I think an i810 is capable of only 1280x1024@60Hz. Thats whats causing all the problems.
Next, I tried xorgconfig from the commandline (runlevel 3). Sadly, it didn't provide any option for a GMA900 card. So, I put in the values on my own (128 MB max mem and so forth); but still, my system refused to boot into runlevel 5. Sheesh...
Then I downloaded drivers for GMA 900, and something prevented even them from being installed.
To make things worse, one of my friends who happens to have exactly the same system configuration, installed and ran FC 6; and in his case, things went as smoothly as anything. He can easily run his system at 1152x864@75 Hz (he has the same monitor as me).
Sincerely, I'm beginning to think that Suse is not that cool after all. It really confuses me to see the Novell people aspire so hard to make something like windows, even when they know that windows is not the best OS (putting it mildly).
Thank you so much for your time guys.
Any ideas what to do next?
 
Old 03-23-2007, 07:41 AM   #45
jolphil
Member
 
Registered: May 2002
Location: central florida
Distribution: Linux Mint, ,Mageia,Ubuntu
Posts: 453

Rep: Reputation: 33
Hello,
Heres another bit of information I googled and while it's not for suse it still may shed some light..
http://www.teleost.org/docs/gma-900-linux.html
PS notice the video ram entry

Jolphil
Edit: another interesting read(download the .pdf)
downloadmirror.intel.com/df-support/8442/ENG/Graphics%20Release.pdf -

Last edited by jolphil; 03-23-2007 at 08:07 AM.
 
  


Reply

Tags
kdesu, modeline, monitor, rate, refresh, root, samsung, suse, syncmaster, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samsung SyncMaster 930B Cosmic Linux - Hardware 1 04-30-2006 03:01 AM
Samsung SyncMaster 914V nutbrownhares Linux - Hardware 2 03-19-2006 07:11 AM
Samsung SyncMaster 3 pcflight Linux - Hardware 1 08-27-2004 06:46 PM
Samsung Syncmaster 170t iotc247 Linux - Hardware 0 05-30-2004 09:38 PM
Samsung SynMaster 3 refresh rate? Racso Linux - General 1 06-30-2002 01:26 PM


All times are GMT -5. The time now is 02:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration