LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-01-2006, 04:02 AM   #1
ideasman
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Home brew
Posts: 25

Rep: Reputation: 15
saa7134 frame grabber, no sound


Hi, I have just purchased a videomate framegrabber and got the TV part working, but cant get any sound out of the card.

I have the details on my blog.
http://ideasman42.blogspot.com/

I can pipe the sound from 1 card to another with this command.
arecord -D hw:1,0 -r 32000 -c 2 -f S16_LE | aplay -

but this adds a 0.5sec delay thats really annoying and even with smaller buffers its better but noticeable,

EDIT, just upgraded to kernel 2.6.18, same problem.

Last edited by ideasman; 10-01-2006 at 05:53 AM.
 
Old 10-01-2006, 12:28 PM   #2
ideasman
LQ Newbie
 
Registered: Mar 2004
Location: Australia
Distribution: Home brew
Posts: 25

Original Poster
Rep: Reputation: 15
Okay, I still cant get sound but I can record TV nicely since the cards TV capture works.
so I can record and play back... at the same time to watch TV
At least it can be paused


Code:
export TIME=$(date +%Y-%m-%d-%H-%M)

mencoder tv:// -tv \
 driver=v4l:width=384:height=288:input=2:norm=PAL:chanlist=australia:channels=2-ABC,7-SAS7,9-NINE,10-TEN:forceaudio:amode=0:audiorate=32000:adevice=/dev/dsp1 \
 -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=1000:vhq -noautoexpand \
 -oac mp3lame -lameopts vbr=2:br=16:mode=3 \
 -endpos 24:00:00 \
 -o /storage/TV-$TIME.avi

Last edited by ideasman; 10-01-2006 at 10:02 PM.
 
  


Reply

Tags
capture, frame, grab, saa7134, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SAA7134 TV Card - No Sound ar2003lin Linux - Newbie 10 11-28-2008 01:27 AM
How to use a frame grabber ? jhome4u Linux - Software 1 11-21-2006 08:39 AM
video frame grabber? NetRAVEN5000 Linux - Software 6 05-05-2006 07:17 PM
Webcam Frame Grabber? linuxpyro Linux - Software 7 07-09-2005 04:36 PM
saa7134 + via82xxx sound ping_wing Linux - Hardware 5 04-29-2004 06:12 PM


All times are GMT -5. The time now is 05:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration