LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-17-2004, 01:59 PM   #1
saravkrish
Member
 
Registered: Mar 2004
Location: KY, USA
Distribution: Fedora Core 1
Posts: 190

Rep: Reputation: 30
rfcomm0 (BT) and udev problem in FC3


Hi,

I want to set up bluetooth connection with my T610. I had got it working in FC1 (using this thread) and I can get it working in FC3, but not the way I want it to. I'm using a Belkin bluetooth dongle.

This is what I did in FC1 to create a rfcomm0 device:
Code:
cd /dev
mknod --mode 660 /dev/rfcomm0 c 216 0
chown root:demigod rfcomm0
After any number of FC1 reboots, if I do ls -l /dev/rfcomm0, I get something like:

Code:
crw-rw----  1 root demigod .....  /dev/rfcomm0
But, when I create /dev/rfcomm0 in FC3 exactly as mentioned above, and then after a reboot I do ls -l /dev/rfcomm0, I get something like (The connection and everything else works with the phone when I access it as user sarav):
Code:
crw-------  1 sarav root .....  /dev/rfcomm0
It's bad enough for the permissions to change, but even the owner is changing to a non-root user!! I don't want that to happen. Also pressing a tab for auto completion when typing /dev/rf<tab> doesn't work. Looks like the rfcomm0 is created only when ls looks (or stats) for it.

How do I get it working like it did in FC1? I think this has something to do with udev. It will also be nice if someone can point me to a nice udev + new devices config HOWTO.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
comments on udev and fc3 Ryan_moure Fedora 0 01-07-2005 03:41 PM
Is udev FC3.6 ok? ShamitSoneji Fedora 1 12-16-2004 11:01 AM
BEWARE of udev-039-10.FC3.5 mickeyboa Fedora 2 12-07-2004 06:03 PM
Yeah!!! udev-039-10.FC3.4 fixed ALL!!! mickeyboa Fedora 1 12-07-2004 05:57 PM
FC3 ndiswrapper - not working after udev update? trey85stang Fedora 0 11-23-2004 09:21 PM


All times are GMT -5. The time now is 12:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration