LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-09-2006, 01:57 AM   #1
robinsingh
LQ Newbie
 
Registered: May 2006
Posts: 5

Rep: Reputation: 1
redhat enterprise linux 4 boots slow with 2 GB RAM , boots fast with 512MB


Machine Configuration:
I have assembled a new machine. Its Intel P4 3.0E Ghz HT enabled processor on ASUS P4P800-MX motherboard. I am using onboard graphics and sound. [Motherboard Spec]
----------------------------------------------------
Socket 478, Intel865GV, Hyperthreading ready, integrated intel graphics, dualchannel DDR400, 10/100Mbps LAN, Serial ATA
----------------------------------------------------
I have put in two 1 GB dual-channel RAM chips (OCZ technologies) in it.

Problem
I installed "Redhat Enterprise Linux 4 WS" on it (installation went super slow..took around 3 hours to complete). Now, it takes RHELv4 a whopping 18 MINUTES to boot up. WindowsXP pro (the other OS on this dual boot machine) boots up in less than 30 secs.

Solutions tried
1)
Since my ASUS motherboard is SMP-enabled and my processor is HT enabled, RHELv4 installed an SML kernel and a normal kernel. But I get the same (very poor) performance from RHELv4, no matter which one (of the two kernels) I use to boot it up.
In SMP-kernel case, I confirmed that cat /proc/cpuinfo shows
2 processors being recognized by RHELv4 (even then the bootup takes 18-20 mins.)

2)
I read online about RHEL issues with 1GB+ memory.
So, just to narrow down the issue, I took out these two 1 GB dual-channel RAM chips and put in a regular Kingston 512MB RAM chip
and RHELv4 started booting up in less than a minute. So now I know the problem is with using 1 GB + RAM.

3)
I confirmed (2) by putting back only one 1GB RAM dual-channel RAM chip, and it started super slow (took around 18-20 mins to bootup again). I also tried passing in mem=1024M kernel parameter, but that did not help either. Even though the cat /proc/meminfo shows 1024MB of RAM being recogized by RHELv4.


I did some search online and found some mixed opinions (which I havent tried yet..since I am not sure about them ,
just listing them here and asking for more suggestions..

a)
Should I recompile my kernel with highmem support -
Isn't highmem only suppposed to be used with 4 GB+ ram machines.?

b)Is this slow bootup being caused by the onboard Integrated Intel graphics ?

Any ideas which one of the above two or (any other alternatives) should i try... ? please help as I am running out of my options now.. Thanks in advance for any helpful tips..
 
Old 05-09-2006, 02:19 AM   #2
imagineers7
Member
 
Registered: Mar 2006
Distribution: BackTrack, RHEL, FC, CentOS, IPCop, Ubuntu, 64Studio, Elive, Dream Linux, Trix Box
Posts: 310

Rep: Reputation: 30
Post Recompile kernel

Robin,

Try recompiling kernel with highmem support also, assume this a chance and get source code of the latest possible stable kernel from:-
kernel.org latest stable kernel is
2.6.16.something


A simple solution:- install rhel server version or advanced server version

Last edited by imagineers7; 05-09-2006 at 02:20 AM.
 
Old 05-09-2006, 10:14 AM   #3
psiborg999
LQ Newbie
 
Registered: May 2006
Location: Chicago , IL
Distribution: SuSE 9.3 Pro, SuSE 10, Ubuntu, WinXP (sadly)
Posts: 6

Rep: Reputation: 0
Talking Its your ASUSTEK MOBO bios

I use an ASUSTEK P4P800 deluxe mobo with1 GIG of RAM and SuSE 9.3 pro.

If I leave the bios set for WinXP "enhanced", under the IDE section.... My systems takes about 18 minutes to boot. (just like yours).

Try changing the bios to "compatible" with no RAID support. It'll speed it up.... You won't see HT support, but there really isn't a big speed impact. You'll see the bootup time improve dramatically. (less than 80 seconds for me.)

Also if you're not filling all the MEM slots, the MOBO "downshifts" the bus speed, that might also be a factor.

I'd also suggest switching from REDHAT, try UNBUNTU or SuSE, so you can still access your NTFS drives, if you need to. But after trying the bios change, by all means, recompile the kernel for highmem support.

I hope that I've helped you, take care...... email me if you've got any more questions.

-PSIBORG999
 
Old 05-09-2006, 12:38 PM   #4
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
It happens to me when I unplug the rest of my RAM on WINDOWS but not as extreme as yours; only a slight differences.
DUAL channel LINEAR RAM requires IDENTICAL twin DDRram (purchased as a PAIR from the Reseller).On slowing performance;I think that the architecture phenomenon.

Reduce the performance of the MOBO/disk by setting the ENAHANCED configuration to COMPATIBLE.
There should be no more problemo...

REGARDS
 
Old 05-09-2006, 10:31 PM   #5
robinsingh
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 1
Thanks psiborg999 and Bobymc for your responses.

[My only hard disk is primary slave and CD rom is primary master..]
I made your suggested change (in first tab of the BIOS setup page.. that shows the drives listed etc.)
1) in IDE configuration : I changed from "enhanced" TO "compatible" mode
2) In the IDE port settings( subsection of IDE configuration..) , I selected primary P-ATA+S-ATA

and during the boot processor, right after,
Uncompressing Linux .. OK booting the kernel.

I got the following error..

ide1: I/O resource 0x170-0x177 not free
ide1: ports already in use ..skipping probe..


then the normal boot up starts..
Redhat Nash Version 4.2.1.6...

but I dont get any performance improvements at all..

So I tried the other Ide port setting-- P-ATA ports only
this time I did NOT get the message
ide1: I/O resource 0x170-0x177 not free
ide1: ports already in use ..skipping probe..

like last boot time..

but no performance gains at all in this case either... :-(
My machine still takes around 18-20 mins to bootup...
(tried both SMP and non-SMP kernel.)

This is not good..
I read your message again..
Quote:
Try changing the bios to "compatible" with no RAID support.
Is RAID support a separate option..if so, then where can i disable RAID support
( didnt notice any such options in BIOS besides IDE configuration...may be i missed it) Can you provide more details for this ..or any other setting that you would like me to change...


Any help would be much appreciated...

Last edited by robinsingh; 05-09-2006 at 10:34 PM.
 
1 members found this post helpful.
Old 05-09-2006, 10:41 PM   #6
robinsingh
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 1
Hi Bobymc,

Quote:
Originally Posted by Bobymc
1) It happens to me when I unplug the rest of my RAM on WINDOWS but not as extreme as yours; only a slight differences.
DUAL channel LINEAR RAM requires IDENTICAL twin DDRram (purchased as a PAIR from the Reseller).On slowing performance;I think that the architecture phenomenon.

2)
Reduce the performance of the MOBO/disk by setting the ENAHANCED configuration to COMPATIBLE.
There should be no more problemo...
I tried 2) , that didnt help (pls see my last post..)
For 1) , I am having two 1GB identical RAM sticks (OCZ technologies..purchased as a PAIR from the Reseller..)

I get the same poor performance whether I use one 1GB RAM stick
or both 1GB Ram ==2GB ram in my machine..

Although, my RHELv4 WS does recognize 2 GB ram ( or 1GB ram - whichever being used.) in cat /proc/meminfo .

It also corrrectly shows 2 processors in cat /proc/cpuinfo
( or 1 processor , depending upon whether I use SMP or non-SMP kernel to boot up..)

Any other thoughts about this issue.. any other options that I can try.. ?
 
Old 05-09-2006, 10:41 PM   #7
robinsingh
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 1
I started up my RHELv4 WS with non-SMP kernel (I get almost same results with SMP-kernel) , here's the breakdown of the time taken during bootup..

Code:
Uncompressing linux ...OK         -- 5 secs
Redhat Nash version 4.2.16 .. starting .. OK -- 5 secs.
INIT: version 2.85 booting...              -- 30 secs
Setting default font (latarcyrhab-sm16) -- 30 secs
Starting udev                   -- 70 secs
Intializing hardware....      -- 2 min
storage                           --10 secs
network                           --10 secs
audio                               -- 2 mins 30 sec

then the cursor kept blinking... 
for the next thing to show up  ---- 3 min 40 secs

then the progress bar (on graphical screen and "monitor" picture) 
shows up.. setting up local disks              -1 min  
     (** i just got one 80GB seagate 7200 rpm disk)
checking for new hardware                         -- 30 secs.
Rest all the services/daemons took  5-8 sec each to startup..
(around 15 of them..I just installed the default RHELv4 WS installation..) 

Starting HAL daemon                                 -- 70 secs
Then the login screen shows up in another   - 15 secs
I logged in as root , enter
the login (into Gnome) procedure takes       -- 70 secs
(components like window manager, printing, etc. 
took almost equal chunks to startup..)

After starting up, the icons show up on Desktop very slowly
(taking 10 secs) then the panels populate with icons 
(one by one... slowly) in another 10 secs.
It took 50 secs to start a Terminal Console..
It took 40 secs to start Mozilla firefox...

However, internet speed ( i have broadband connection) is fine.. I can browse to the sites etc. relatively faster (it took around 2-3 secs to fully load this justlinux.com site..)

Here's the output of
a) cat /proc/cpuinfo (since I booted using non-SMP kernel i see only one processor below.. If I use SMP-kernel , I see 2 processors below.. but the performance is still as bad..)

Code:
[root@localhost ~]# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 3.00GHz
stepping        : 1
cpu MHz         : 3001.653
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe pni monitor ds_cpl cid xtpr
bogomips        : 6005.60
b) cat /proc/meminfo (correctly identifies 2 GB of RAM in MemTotal, if I take out 1 GB ram stick, it will correctly show 1GB RAM in MemTotal)
Code:
[root@localhost ~]# cat /proc/meminfo
MemTotal:      2067192 kB
MemFree:       1691872 kB
Buffers:         18008 kB
Cached:         170660 kB
SwapCached:          0 kB
Active:         155972 kB
Inactive:       127900 kB
HighTotal:     1170624 kB
HighFree:       897600 kB
LowTotal:       896568 kB
LowFree:        794272 kB
SwapTotal:     4610644 kB
SwapFree:      4610644 kB
Dirty:             680 kB
Writeback:           0 kB
Mapped:         137188 kB
Slab:            20152 kB
Committed_AS:   320500 kB
PageTables:       2388 kB
VmallocTotal:   106488 kB
VmallocUsed:      5800 kB
VmallocChunk:   100340 kB
HugePages_Total:     0
HugePages_Free:      0
Hugepagesize:     4096 kB
Any idea , why things are so slow.. despite my processor and RAM being recognized correctly.. seems like I have to re-compile my kernel.. :-(
I am not a very advanced linux user (* just learning it now a days..) I guess I will have to resort to this option , if there's nothing else that can be suggested in this case..
Any other alternatives that I can try before re-compiling my kernel..????
Any helpful tips will be much appreciated..
robin
 
Old 05-09-2006, 10:51 PM   #8
robinsingh
LQ Newbie
 
Registered: May 2006
Posts: 5

Original Poster
Rep: Reputation: 1
Hi Imagineers7,
Thanks for your response..
Quote:
Originally Posted by imagineers7
Robin,
A simple solution:- install rhel server version or advanced server version
Before installing this RHELv4 Update3 Workstation version,
I had installed RHELv4 Update1 Enterprise Server version,
and I got the same poor performance ...

Does anybody know,
Is there any major difference in highMem support in kernels
from Update1 vs Update3 of RHELv4 Enterprise Server,
If Yes, then I can probably try downloading that and re-installing that again..otherwise as I said, I got the same poor performance with RHELv4 ES version. but update1 (that I downloaded a year ago.)



Any other suggestions/tips that I can try...before recompiling my kernel.. for highmem support ( my reluctance to do this is because of the mixed opinion I have gotten so far.. some people mention that highmem support is only required for 4 GB+ RAM .. some suggest its required for 1GB+ RAM )


==> I havent been able to find a good link that details the steps to recompile the kernel with highmem support ,do you know of any ?
=>Are these instructions linux-Distro independent ?
=> or do they have to be RHELv4 kernel specific ?
=> Can I just download the latest kernel from ftp.kernel.org
and use it in my RHELv4 , shouldnt there be some RHELv4 distro-specific latest kernel that I can download from Redhat site.. (or might have it in my Redhat CDs etc.


I have also posted the breakdown of events to show what part of my bootup process is taking how much time.. seems like its important to know this information to narrow down the problem..


Any help would be much appreciated..

Last edited by robinsingh; 05-09-2006 at 10:52 PM.
 
Old 05-10-2006, 07:33 AM   #9
psiborg999
LQ Newbie
 
Registered: May 2006
Location: Chicago , IL
Distribution: SuSE 9.3 Pro, SuSE 10, Ubuntu, WinXP (sadly)
Posts: 6

Rep: Reputation: 0
Unhappy Really Slow (glacial) Bootup

Hello Again.....

I'm sorry about not being able to help you out, but I've got a few more suggestions that might fix it.

1) Your CD-ROM Device is master device on IDE #1 and HD is the slave device.
This is NOT standard, it might not help, but try to change that ASAP.

2) I saw that you had P-ATA and S-ATA enabled. Try just enabling P-ATA.
When I have the S-ATA enabled on my ASUS MOBO, SuSE won't boot at all.
I didn't see that your BOOT HD was S-ATA, so this shouldn't be a problem....

3) Grab a LIVE CD Linux distro and boot from that; if you get a reasonable boot time,
then you might have to do a reinstall of your current HD residing distro.

Try #2 first, before you have to crawl under your desk! LOL

Let me know if this helps any....

Take care,

-PSIBORG999
 
Old 05-11-2006, 02:36 PM   #10
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
The last time I try to mixmatch=(exchange/swap the other BANK) the Twin Identical DDR, my HDD cannot be read anymore.
I have to reinstall.

Hello Robin;
Why not disabled the PnP OS to NO state.
Maybe we have a new improvement.

I use SUSE8 mandrake9 RedHat7.3 Fedora 1 & 4. Sun Microsys ;all of them have no bug on RAM.
Considerably as fast as XP.

All my BIOS state/config are in normal mode setting.
 
Old 05-11-2006, 02:46 PM   #11
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
On slowing performance;

Let's try to borrow one's AGP card and plug to the MOBO
N see what'll happen.

Sounds illogical but let the onboard AGP& rest for a while.
 
Old 05-11-2006, 09:22 PM   #12
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
Onboard AGP sucks CPU performance/tasking power.
 
Old 04-19-2008, 12:22 AM   #13
cooljai
Member
 
Registered: May 2007
Location: /dev/random
Distribution: CentOS, Fedora, RHEL, SuSE
Posts: 62

Rep: Reputation: 15
Hey Dear members,

I am facing the same issue... I am using CentOS 5.0 (2.6.18) since last month with P4 3.0 Ghz, Asus, 512 MB RAM and everything was fine. But just yesterday I installed another 512 MB stick to make RAM 1 GB. My system is now taking up too much time to boot up. It stuck in "Initialzing Udev....." for almost 80 seconds.

I have also tried most of remedies written above but no avail as yet.

Thanks for advance for any suggestions.
 
Old 08-18-2008, 07:24 PM   #14
Grimaldez
LQ Newbie
 
Registered: Mar 2003
Distribution: FC17
Posts: 5

Rep: Reputation: 0
Hi all,

same problem here with CentOS 5.1
maxtor 200GB p-ata primary master only.

Asus P4P800-MX that works fine with a single 512MB DDR chip,
slow boot and very poor performances with any configuration with more than 512 MB:
- 2x512 DDR PC3200 dual channel (alternate slots 1-3 or 2-4)
- 2x512 DDR PC3200 single channel (mixed slots 1-2, 2-3, 3-4, 1-4)
- 1x1024 DDR PC3200 in slot 1

now that i found this thread I'm going to give a try to the eide ctrl setup

best wishes
 
Old 08-26-2008, 11:34 PM   #15
Grimaldez
LQ Newbie
 
Registered: Mar 2003
Distribution: FC17
Posts: 5

Rep: Reputation: 0
No way, I give up.

I've been playing with advanced bios setup,
limiting the memory with the mem= kernel parameter,
booting with redhat 7.3 ,
expanding physical memory to 2x1GB dual chan,
straining the cached ram beyond the 512MB limits (up to 546) as reported bye free -m,
so I'm feeling that there's some BIOS's problem: the latest release was a beta and doesn't fix this behaviour.

So i'm turning this m/b to some windows box with 512 MB and let someone suffer on behalf of me.

bye
 
  


Reply

Tags
asus, bios, linux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat boots slow with network disconnected fusilier Linux - Networking 1 03-29-2006 07:47 AM
Computer Boots up too Slow Kamex Suse/Novell 3 07-11-2005 08:08 AM
dual boots................rather have rubber boots metal_monster Linux - Newbie 1 01-13-2004 12:24 PM
eth0 boots slow fstreed Linux - Networking 4 07-02-2003 03:32 PM
Linux Boots Slow!!! Westdog976 Linux - Newbie 6 06-11-2003 10:08 AM


All times are GMT -5. The time now is 05:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration