LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   rear speakers don't work (http://www.linuxquestions.org/questions/linux-hardware-18/rear-speakers-dont-work-246873/)

oDyman 10-24-2004 07:02 PM

rear speakers don't work
 
I have a Sound Blaster Live! 5.1 card and creative 5.1 speakers.
I tried every combination in alsamixer but the rear speakers just don't work. My distro is Slackware 10.0

320mb 10-24-2004 07:56 PM

emu-tools

it may be in the /extra directory in the Official CD set..........
or get it from sourceforge.net

Electro 10-24-2004 09:43 PM

In programs like XMMS, mplayer, vlc, xine, and many others. You will have to specify surround51 when using the ALSA plugin. Also the sound have to have 5.1 channels in order for 5.1 to work with out tweaking ~/.asoundrc or other ALSA files. If the sound only has 2 channels, you have to edit or create ~/.asoundrc to copy the front channels to the subwoofer, center, and rears. Also you will have to specify the entry that you added to ~/.asoundrc. ALSA has an example in their wiki documentation to setup simulated surround sound playing 2 channel audio files. All channels will be in full-range that a 5.1 channel sound card can handle (about 20 Hz to 20,000 Hz), so you will need to download some plugins that passes low frequencies to the subwoofer channel and add a delay to the rear speakers.

OSS can not output more than 2 channels.

In mplayer make sure you also specify "-channels 6" when using surround51 or else it will not output 6 channels (5.1 channels).

vinay_s_s 10-24-2004 11:00 PM

isnt there a slider by name "3d" or "surround" ??
unmute it and it controls the volume of rear speakers.

Lenard Spencer 10-26-2004 02:04 AM

Re: rear speakers don't work
 
Quote:

Originally posted by oDyman
I have a Sound Blaster Live! 5.1 card and creative 5.1 speakers.
I tried every combination in alsamixer but the rear speakers just don't work. My distro is Slackware 10.0

KMix has the settings you need to en/disable surround and center/LFE in the "advanced" section.

Hope this helps


All times are GMT -5. The time now is 09:23 PM.