LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Realtek Sound and Ubuntu Linux - No Sound (http://www.linuxquestions.org/questions/linux-hardware-18/realtek-sound-and-ubuntu-linux-no-sound-365634/)

meindl007 09-21-2005 12:50 PM

Realtek Sound and Ubuntu Linux - No Sound
 
Hello All:

My question today is in regards to my intagrated sound card (Realtek HD) on my Sony Vaio VGN-S470P using Ubuntu linux (Linux kaya3 2.6.10-5-386 #1 Thu Sep 8 06:18:41 UTC 2005 i686 GNU/Linux)

I HAVE NO SOUND AT ALL!!!

when I type in:
Code:

#aplay /usr/share/sounds/login.wav
ALSA lib pcm_dmix.c:868:(snd_pcm_dmix_open) unable to open slave

I also get the same error message when I type in
Code:

#esd
Here is what my dmesg reads:

Code:

0 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fe90000 (usable)
 BIOS-e820: 000000001fe90000 - 000000001fe9d000 (ACPI data)
 BIOS-e820: 000000001fe9d000 - 000000001ff00000 (ACPI NVS)
 BIOS-e820: 000000001ff00000 - 0000000020000000 (reserved)
 BIOS-e820: 00000000e0000000 - 00000000f0006000 (reserved)
 BIOS-e820: 00000000f0008000 - 00000000f000c000 (reserved)
 BIOS-e820: 00000000fed20000 - 00000000fed90000 (reserved)
 BIOS-e820: 00000000ff000000 - 0000000100000000 (reserved)
510MB LOWMEM available.
On node 0 totalpages: 130704
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 126608 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 PTLTD                                ) @ 0x000f6780
ACPI: RSDT (v001  Sony      V0 0x20050523 PTL  0x00000000) @ 0x1fe97449
ACPI: FADT (v002  Sony      V0 0x20050523 PTL  0x00000050) @ 0x1fe9ce78
ACPI: MADT (v001  Sony      V0 0x20050523 PTL  0x00000050) @ 0x1fe9cefc
ACPI: BOOT (v001  Sony      V0 0x20050523 PTL  0x00000001) @ 0x1fe9cfd8
ACPI: MCFG (v001  Sony      V0 0x20050523 PTL  0x0000005f) @ 0x1fe9cf9c
ACPI: SSDT (v001  Sony      V0 0x20050523 PTL  0x20030224) @ 0x1fe983aa
ACPI: SSDT (v001  Sony      V0 0x20050523 PTL  0x20030224) @ 0x1fe97d0e
ACPI: SSDT (v001  Sony      V0 0x20050523 PTL  0x20030224) @ 0x1fe978c9
ACPI: SSDT (v001  Sony      V0 0x20050523 PTL  0x20030224) @ 0x1fe976aa
ACPI: SSDT (v001  Sony      V0 0x20050523 PTL  0x20030224) @ 0x1fe97491
ACPI: DSDT (v001  Sony      V0 0x20050523 PTL  0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x1008
ACPI: Local APIC address 0xfee00000
ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
Processor #0 6:13 APIC version 20
ACPI: LAPIC (acpi_id[0x01] lapic_id[0x01] disabled)
ACPI: LAPIC_NMI (acpi_id[0x00] high edge lint[0x1])
ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
ACPI: IOAPIC (id[0x01] address[0xfec00000] gsi_base[0])
IOAPIC[0]: apic_id 1, version 32, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: IRQ0 used by override.
ACPI: IRQ2 used by override.
ACPI: IRQ9 used by override.
Enabling APIC mode:  Flat.  Using 1 I/O APICs
Using ACPI (MADT) for SMP configuration information
Built 1 zonelists
Kernel command line: root=/dev/sda3 ro quiet splash
mapped APIC to ffffd000 (fee00000)
mapped IOAPIC to ffffc000 (fec00000)
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 1730.162 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 510748k/522816k available (1436k kernel code, 11464k reserved, 754k data, 224k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 3416.06 BogoMIPS (lpj=1708032)
Security Framework v1.0.0 initialized
SELinux:  Disabled at boot.
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: afe9fbff 00100000 00000000 00000000 00000180 00000000
CPU: After vendor identify, caps: afe9fbff 00100000 00000000 00000000 00000180 00000000
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 2048K
CPU: After all inits, caps: afe9fbff 00100000 00000000 00000040 00000180 00000000
CPU: Intel(R) Pentium(R) M processor 1.73GHz stepping 08
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
ACPI: Looking for DSDT in initrd... not found!
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 pin1=2 pin2=-1
checking if image is initramfs...it isn't (bad gzip magic numbers); looks like an initrd
Freeing initrd memory: 4300k freed
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xfd911, last bus=7
PCI: Using MMCONFIG
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050211
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
PCI: Transparent bridge - 0000:00:1e.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PEGP._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PCIB._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs *10)
ACPI: PCI Interrupt Link [LNKB] (IRQs *10)
ACPI: PCI Interrupt Link [LNKC] (IRQs 10) *5
ACPI: PCI Interrupt Link [LNKD] (IRQs *10)
ACPI: PCI Interrupt Link [LNKE] (IRQs *10)
ACPI: PCI Interrupt Link [LNKF] (IRQs 10) *3
ACPI: PCI Interrupt Link [LNKG] (IRQs *10)
ACPI: PCI Interrupt Link [LNKH] (IRQs *10)
ACPI: Embedded Controller [EC0] (gpe 23)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 10 devices
PnPBIOS: Disabled by ACPI PNP
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically.  If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device().  As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior.  If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.
Simple Boot Flag at 0x36 set to 0x1
audit: initializing netlink socket (disabled)
audit(1127301050.569:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
input: AT Translated Set 2 keyboard on isa0060/serio0
EISA: Probing bus 0 at eisa0
Cannot allocate resource for EISA slot 1
Cannot allocate resource for EISA slot 2
EISA: Detected 0 cards.
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET: Registered protocol family 8
NET: Registered protocol family 20
Restarting tasks...<6> Strange, kswapd0 not stopped
 Strange, kseriod not stopped
 done
ACPI wakeup devices:
PWRB USB1 USB2 USB3 USB4 USB7 LANC  EC0
ACPI: (supports S0 S3 S4 S5)
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 4300KiB [1 disk] into ram disk... done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 224k freed
ACPI: CPU0 (power states: C1[C1] C2[C2])
ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI: Thermal Zone [ATF0] (63 C)
NET: Registered protocol family 1
SCSI subsystem initialized
libata version 1.10 loaded.
ata_piix version 1.03
ACPI: PCI interrupt 0000:00:1f.2[B] -> GSI 18 (level, low) -> IRQ 18
PCI: Setting latency timer of device 0000:00:1f.2 to 64
ata1: SATA max UDMA/133 cmd 0x18C0 ctl 0x18BA bmdma 0x18A0 irq 18
ata2: SATA max UDMA/133 cmd 0x18B0 ctl 0x1896 bmdma 0x18A8 irq 18
ata1: dev 0 cfg 49:0f00 82:746b 83:7f69 84:4023 85:f469 86:3f49 87:4023 88:203f
ata1: dev 0 ATA, max UDMA/100, 156301488 sectors: lba48
ata1: dev 0 configured for UDMA/100
scsi0 : ata_piix
ATA: abnormal status 0x7F on port 0x18B7
ata2: disabling port
scsi1 : ata_piix
elevator: using anticipatory as default io scheduler
  Vendor: ATA      Model: HTS541080G9SA00  Rev: MB4O
  Type:  Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 156301488 512-byte hdwr sectors (80026 MB)
SCSI device sda: drive cache: write back
 /dev/scsi/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 > p3
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Stopping tasks: ==|
Freeing memory... done (411 pages freed)
Restarting tasks... done
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
Adding 626492k swap on /dev/sda6.  Priority:-1 extents:1
Adding 827308k swap on /dev/sda7.  Priority:-2 extents:1
EXT3 FS on sda3, internal journal
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Probing IDE interface ide0...
hda: MATSHITAUJ-832D, ATAPI CD/DVD-ROM drive
Probing IDE interface ide1...
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache
Uniform CD-ROM driver Revision: 3.20
lp: driver loaded but no devices found
mice: PS/2 mouse device common for all mice
input: PS/2 Generic Mouse on isa0060/serio1
ieee1394: Initialized config rom entry `ip1394'
ts: Compaq touchscreen protocol output
sbp2: $Rev: 1219 $ Ben Collins <bcollins@debian.org>
Capability LSM initialized
device-mapper: 4.3.0-ioctl (2004-09-30) initialised: dm-devel@redhat.com
md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27
cdrom: open failed.
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 915GM Chipset.
agpgart: Maximum main memory to use for agp memory: 438M
agpgart: AGP aperture is 256M @ 0x0
cpci_hotplug: CompactPCI Hot Plug Core version: 0.2
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Evaluate _OSC Set fails. Status = 0x0005
pciehp: add_host_bridge: status 5
pciehp: Fails to gain control of native hot-plug
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
ACPI: PCI interrupt 0000:00:1d.0[A] -> GSI 17 (level, low) -> IRQ 17
uhci_hcd 0000:00:1d.0: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1
PCI: Setting latency timer of device 0000:00:1d.0 to 64
uhci_hcd 0000:00:1d.0: irq 17, io base 0x1800
uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.1[B] -> GSI 19 (level, low) -> IRQ 19
uhci_hcd 0000:00:1d.1: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2
PCI: Setting latency timer of device 0000:00:1d.1 to 64
uhci_hcd 0000:00:1d.1: irq 19, io base 0x1820
uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.2[C] -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:1d.2: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3
PCI: Setting latency timer of device 0000:00:1d.2 to 64
uhci_hcd 0000:00:1d.2: irq 21, io base 0x1840
uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.3[A] -> GSI 17 (level, low) -> IRQ 17
uhci_hcd 0000:00:1d.3: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4
PCI: Setting latency timer of device 0000:00:1d.3 to 64
uhci_hcd 0000:00:1d.3: irq 17, io base 0x1860
uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 4
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
ACPI: PCI interrupt 0000:00:1d.7[D] -> GSI 23 (level, low) -> IRQ 23
ehci_hcd 0000:00:1d.7: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
PCI: Setting latency timer of device 0000:00:1d.7 to 64
ehci_hcd 0000:00:1d.7: irq 23, pci mem 0x80004000
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 5
PCI: cache line size of 32 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: USB 2.0 initialized, EHCI 1.00, driver 26 Oct 2004
hub 5-0:1.0: USB hub found
hub 5-0:1.0: 8 ports detected
hw_random hardware driver 1.0.0 loaded
ICH6: IDE controller at PCI slot 0000:00:1f.1
ACPI: PCI interrupt 0000:00:1f.1[B] -> GSI 18 (level, low) -> IRQ 18
ICH6: chipset revision 3
ICH6: not 100% native mode: will probe irqs later
ICH6: port 0x01f0 already claimed by ide0
ICH6: neither IDE port enabled (BIOS)
Linux Kernel Card Services
  options:  [pci] [cardbus] [pm]
ACPI: PCI interrupt 0000:06:05.0[A] -> GSI 21 (level, low) -> IRQ 21
Yenta: CardBus bridge found at 0000:06:05.0 [104d:818f]
Yenta: ISA IRQ mask 0x0cf8, PCI irq 21
Socket status: 30000820
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI interrupt 0000:06:05.2[C] -> GSI 20 (level, low) -> IRQ 20
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[20]  MMIO=[b0004000-b00047ff]  Max Packet=[2048]
e100: Intel(R) PRO/100 Network Driver, 3.2.3-k2-NAPI
e100: Copyright(c) 1999-2004 Intel Corporation
ACPI: PCI interrupt 0000:06:08.0[A] -> GSI 20 (level, low) -> IRQ 20
e100: eth0: e100_probe: addr 0xb0006000, irq 20, MAC addr 00:01:4A:83:F5:7B
ieee80211_crypt: registered algorithm 'NULL'
ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.19
ipw2200: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:06:0b.0[A] -> GSI 22 (level, low) -> IRQ 22
ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.12.14 (AR5210, AR5211, AR5212)
wlan: 0.8.4.5 (EXPERIMENTAL)
ath_rate_onoe: 1.0
ath_pci: 0.9.4.12 (EXPERIMENTAL)
PCI: Enabling device 0000:07:00.0 (0000 -> 0002)
ACPI: PCI interrupt 0000:07:00.0[A] -> GSI 21 (level, low) -> IRQ 21
e100: eth0: e100_watchdog: link up, 100Mbps, half-duplex
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: mac 5.9 phy 4.3 radio 4.6
ath0: 802.11 address: 00:09:5b:ed:8e:c9
ath0: Use hw queue 0 for WME_AC_BE traffic
ath0: Use hw queue 1 for WME_AC_BK traffic
ath0: Use hw queue 2 for WME_AC_VI traffic
ath0: Use hw queue 3 for WME_AC_VO traffic
ath0: Atheros 5212: mem=0x20800000, irq=21
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[0800460300e8da26]
NET: Registered protocol family 10
Disabled Privacy Extensions on device c02f0500(lo)
IPv6 over IPv4 tunneling driver
ACPI: AC Adapter [ACAD] (on-line)
ACPI: Battery Slot [BAT1] (battery present)
ACPI: Lid Switch [LID0]
ACPI: Power Button (CM) [PWRB]
ibm_acpi: ec object not found
ACPI Sony Notebook Control Driver v0.1 successfully installed
ACPI: Video Device [NGFX] (multi-head: yes  rom: no  post: no)
ACPI: Video Device [GFX0] (multi-head: yes  rom: yes  post: no)
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.
eth0: no IPv6 routers present

I dont even see my sound card / driver listed

Peacedog 09-21-2005 02:29 PM

Hi meindl007, welcome to lq. Could we see the output from the following please.

lspci -v

lsmod

good luck.

meindl007 09-21-2005 02:36 PM

lspci -v gives me the following:

Code:

0000:00:00.0 Host bridge: Intel Corp. Mobile Memory Controller Hub (rev 03)
        Subsystem: Sony Corporation: Unknown device 81b7
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] #09 [2109]

0000:00:01.0 PCI bridge: Intel Corp. Mobile Memory Controller Hub PCI Express Port (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        Memory behind bridge: 90000000-afffffff
        Prefetchable memory behind bridge: c0000000-cfffffff
        Capabilities: [88] #0d [0000]
        Capabilities: [80] Power Management version 2
        Capabilities: [90] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [a0] #10 [0141]

0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
        Subsystem: Sony Corporation: Unknown device 81cc
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at 80000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] #10 [0091]

0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at 1800 [size=32]

0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 19
        I/O ports at 1820 [size=32]

0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 21
        I/O ports at 1840 [size=32]

0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at 1860 [size=32]

0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03) (prog-if 20 [EHCI])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 23
        Memory at 80004000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [50] Power Management version 2
        Capabilities: [58] #0a [20a0]

0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3) (prog-if 01 [Subtractive decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=06, subordinate=07, sec-latency=32
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: b0000000-b00fffff
        Capabilities: [50] #0d [0000]

0000:00:1f.0 ISA bridge: Intel Corp. 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0

0000:00:1f.1 IDE interface: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: bus master, medium devsel, latency 0, IRQ 18
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at <unassigned>
        I/O ports at 1880 [size=16]

0000:00:1f.2 IDE interface: Intel Corp. 82801FBM (ICH6M) SATA Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Sony Corporation: Unknown device 81ba
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 18
        I/O ports at 18c0 [size=8]
        I/O ports at 18b8 [size=4]
        I/O ports at 18b0 [size=8]
        I/O ports at 1894 [size=4]
        I/O ports at 18a0 [size=16]
        Memory at 80004400 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [70] Power Management version 2

0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
        Subsystem: Sony Corporation: Unknown device 81b9
        Flags: medium devsel
        I/O ports at 18e0 [size=32]

0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0167 (rev a1) (prog-if 00 [VGA])
        Subsystem: Sony Corporation: Unknown device 81c9
        Flags: bus master, fast devsel, latency 0, IRQ 10
        Memory at a0000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at 90000000 (64-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [78] #10 [0001]

0000:06:05.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller
        Subsystem: Sony Corporation: Unknown device 818f
        Flags: bus master, medium devsel, latency 168, IRQ 21
        Memory at 20000000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=06, secondary=07, subordinate=0a, sec-latency=176
        Memory window 0: 20400000-207ff000 (prefetchable)
        Memory window 1: 20800000-20bff000
        I/O window 0: 00004000-000040ff
        I/O window 1: 00004400-000044ff
        16-bit legacy interface ports at 0001

0000:06:05.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller (prog-if 10 [OHCI])
        Subsystem: Sony Corporation: Unknown device 818f
        Flags: bus master, medium devsel, latency 32, IRQ 20
        Memory at b0004000 (32-bit, non-prefetchable) [size=2K]
        Memory at b0000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2

0000:06:05.3 Unknown mass storage controller: Texas Instruments PCI7420/PCI7620 Dual Socket CardBus and Smart Card Cont. w/ 1394a-2000 OHCI Two-Port  PHY/Link-Layer Cont. an
        Subsystem: Sony Corporation: Unknown device 8190
        Flags: bus master, medium devsel, latency 57, IRQ 10
        Memory at b0005000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [44] Power Management version 2

0000:06:08.0 Ethernet controller: Intel Corp.: Unknown device 1068 (rev 03)
        Subsystem: Sony Corporation: Unknown device 81d0
        Flags: bus master, medium devsel, latency 66, IRQ 20
        Memory at b0006000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2000 [size=64]
        Capabilities: [dc] Power Management version 2

0000:06:0b.0 Network controller: Intel Corp. PRO/Wireless 2200BG (rev 05)
        Subsystem: Intel Corp.: Unknown device 2751
        Flags: bus master, medium devsel, latency 32, IRQ 22
        Memory at b0007000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2

0000:07:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
        Subsystem: Netgear: Unknown device 4b00
        Flags: bus master, medium devsel, latency 168, IRQ 21
        Memory at 20800000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2


lsmod gives me:
Code:

Module                  Size  Used by
isofs                  33848  0
udf                    77060  0
speedstep_centrino      7892  1
proc_intf              4100  0
freq_table              4100  1 speedstep_centrino
cpufreq_userspace      4572  1
cpufreq_ondemand        6172  0
cpufreq_powersave      1920  0
video                  16260  0
sony_acpi              6280  0
pcc_acpi              11264  0
button                  6800  0
battery                10244  0
container              4608  0
ac                      4996  0
ipv6                  229376  9
ath_pci                55584  0
ath_rate_onoe          8840  1 ath_pci
wlan                  106588  3 ath_pci,ath_rate_onoe
ath_hal              133328  2 ath_pci
ipw2200                66156  0
firmware_class          9728  1 ipw2200
ieee80211              21252  1 ipw2200
ieee80211_crypt        5832  1 ieee80211
e100                  32384  0
mii                    4736  1 e100
ohci1394              31876  0
yenta_socket          19584  1
pcmcia_core            53568  1 yenta_socket
i2c_i801                8076  0
i2c_core              21264  1 i2c_i801
piix                    9988  1
hw_random              5524  0
ehci_hcd              29444  0
uhci_hcd              30224  0
usbcore              107384  3 ehci_hcd,uhci_hcd
shpchp                86116  0
pci_hotplug            30512  1 shpchp
intel_agp              20636  1
agpgart                31784  1 intel_agp
rtc                    12216  0
md                    43856  0
dm_mod                53116  1
capability              5000  0
commoncap              7808  1 capability
sbp2                  22408  0
tsdev                  7488  0
evdev                  9088  0
ieee1394              100408  2 ohci1394,sbp2
psmouse                19336  0
mousedev              11160  1
parport_pc            34372  0
lp                    10792  0
parport                33480  2 parport_pc,lp
ide_generic            1664  0
ide_disk              18176  0
ide_cd                38532  0
ide_core              118988  4 piix,ide_generic,ide_disk,ide_cd
ext3                  120968  1
jbd                    54168  1 ext3
ahci                  10500  0
sr_mod                16036  0
cdrom                  36508  2 ide_cd,sr_mod
sd_mod                16784  4
ata_piix                8836  8
libata                44548  2 ahci,ata_piix
scsi_mod              119936  5 sbp2,ahci,sr_mod,sd_mod,libata
unix                  26164  772
thermal                13576  0
processor              22708  2 speedstep_centrino,thermal
fan                    4612  0
fbcon                  34048  0
font                    8448  1 fbcon
bitblit                5120  1 fbcon
vesafb                  6948  0
cfbcopyarea            3968  1 vesafb
cfbimgblt              3072  1 vesafb
cfbfillrect            3584  1 vesafb


Thank you for your help!

Peacedog 09-21-2005 02:53 PM

Your welcome. Looks like the module isn't loaded. Try this.

modprobe snd_intel8x0m

Then try a mixer and post any results.

good luck.

meindl007 09-21-2005 03:15 PM

I did that, and it reported no error messages.

I then ran gstreamer-properties and set the output to use ALSA and then clicked test and got the error message:

"Failed to construct test pipline for 'ALSA - Advanced Linux Sound Architecture"

I then tried gnome vol monitor, and when I open, I get the error message:
"cannot connect to sound daemon. Please run 'esd' at the command prompt."

Peacedog 09-21-2005 03:27 PM

Did you do this?

"Please run 'esd' at the command prompt."

Have you tried any other mixers?

good luck.

meindl007 09-21-2005 03:28 PM

esd command gives me:

ALSA lib pcm_dmix.c:868:(snd_pcm_dmix_open) unable to open slave

Have not tried any other mixer - can you suggest one?

Peacedog 09-21-2005 03:38 PM

Try alsamixer, or gnome-alsamixer.

good luck.

meindl007 09-21-2005 03:41 PM

zero@kaya3:~$ sudo alsamixer
Password:

alsamixer: function snd_ctl_open failed for default: No such device

Peacedog 09-21-2005 03:47 PM

Could we have another look at lsmod please?

good luck.

meindl007 09-21-2005 03:49 PM

lsmod gives:

Module Size Used by
snd_intel8x0m 17476 0
snd_ac97_codec 64608 1 snd_intel8x0m
snd_pcm_oss 47652 0
snd_mixer_oss 16768 1 snd_pcm_oss
snd_pcm 84872 3 snd_intel8x0m,snd_ac97_codec,snd_pcm_oss
snd_timer 23300 1 snd_pcm
snd 50276 6 snd_intel8x0m,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 9824 1 snd
snd_page_alloc 9604 2 snd_intel8x0m,snd_pcm
isofs 33848 0
udf 77060 0
speedstep_centrino 7892 1
proc_intf 4100 0
freq_table 4100 1 speedstep_centrino
cpufreq_userspace 4572 1
cpufreq_ondemand 6172 0
cpufreq_powersave 1920 0
video 16260 0
sony_acpi 6280 0
pcc_acpi 11264 0
button 6800 0
battery 10244 0
container 4608 0
ac 4996 0
ipv6 229376 9
ath_pci 55584 0
ath_rate_onoe 8840 1 ath_pci
wlan 106588 3 ath_pci,ath_rate_onoe
ath_hal 133328 2 ath_pci
ipw2200 66156 0
firmware_class 9728 1 ipw2200
ieee80211 21252 1 ipw2200
ieee80211_crypt 5832 1 ieee80211
e100 32384 0
mii 4736 1 e100
ohci1394 31876 0
yenta_socket 19584 1
pcmcia_core 53568 1 yenta_socket
i2c_i801 8076 0
i2c_core 21264 1 i2c_i801
piix 9988 1
hw_random 5524 0
ehci_hcd 29444 0
uhci_hcd 30224 0
usbcore 107384 3 ehci_hcd,uhci_hcd
shpchp 86116 0
pci_hotplug 30512 1 shpchp
intel_agp 20636 1
agpgart 31784 1 intel_agp
rtc 12216 0
md 43856 0
dm_mod 53116 1
capability 5000 0
commoncap 7808 1 capability
sbp2 22408 0
tsdev 7488 0
evdev 9088 0
ieee1394 100408 2 ohci1394,sbp2
psmouse 19336 0
mousedev 11160 1
parport_pc 34372 0
lp 10792 0
parport 33480 2 parport_pc,lp
ide_generic 1664 0
ide_disk 18176 0
ide_cd 38532 0
ide_core 118988 4 piix,ide_generic,ide_disk,ide_cd
ext3 120968 1
jbd 54168 1 ext3
ahci 10500 0
sr_mod 16036 0
cdrom 36508 2 ide_cd,sr_mod
sd_mod 16784 4
ata_piix 8836 8
libata 44548 2 ahci,ata_piix
scsi_mod 119936 5 sbp2,ahci,sr_mod,sd_mod,libata
unix 26164 772
thermal 13576 0
processor 22708 2 speedstep_centrino,thermal
fan 4612 0
fbcon 34048 0
font 8448 1 fbcon
bitblit 5120 1 fbcon
vesafb 6948 0
cfbcopyarea 3968 1 vesafb
cfbimgblt 3072 1 vesafb
cfbfillrect 3584 1 vesafb

Peacedog 09-21-2005 03:55 PM

Try this add "snd-intel8x0m" to the list of devices in /etc/hotplug/blacklist, then try.

modprobe snd-intel8x0

Then try the mixer again.

good luck.

meindl007 09-21-2005 03:58 PM

This was already listed in /etc/hotplug/blacklist

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
snd_intel8x0m

Peacedog 09-21-2005 04:03 PM

Ok rmmod the snd_intel8x0m module and modprobe the snd_intel8x0.

rmmod snd_intel8x0m

modprobe snd_intel8x0

good luck.

meindl007 09-21-2005 04:05 PM

I got this as well while running gstreamer-properties

zero@kaya3:~$ gstreamer-properties
- using device default
- using device default
ALSA lib pcm_dmix.c:868:(snd_pcm_dmix_open) unable to open slave
arts_init error: loading the aRts backend "/usr/lib/libartscbackend.la" failed


All times are GMT -5. The time now is 04:47 PM.