LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-04-2008, 08:22 PM   #1
muxsu
LQ Newbie
 
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
Wink Realtek RTL8187B Wireless install on Slackware 12.1 using ndiswrapper


Realtek RTL8187B Wireless Network card install on Slackware 12.1 using ndiswrapper

I got some of these install instructions from http://alien.slackbook.org/dokuwiki/...re:ndiswrapper and the README files that come with ndiswrapper.

Download ndiswrapper 1.53 from http://downloads.sourceforge.net/ndi...5&big_mirror=0 or you can also go to the homepage: http://ndiswrapper.sourceforge.net/joomla/

Unzip the file:
tar –zxvf ndiswrapper-<version>.tar.gz

enter the directory:
cd ndiswrapper-<version>

Build ndiswrapper:
Make uninstall
Make
Make install

Find the address of your network card using:
lsusb
Look for something like Bus 001 Device 002: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
My address is 0dba:8189

Download the Realtek RTL8187B wireless card drivers (description: Window Driver (support Win98/WinME/Win2K/WinXP/Vista),vista driver ver.6.1089,xp/2000 driver 5.1097) from their website: http://www.realtek.com.tw/downloads/...Downloads=true

Unzip drivers:
unzip RTL8187B_drive_only.zip

Enter the driver directory:
cd /RTL8187B/WinXP/

Find net8187b.inf file and edit it (I used pico)

Look for:
;;****************************************************************************
;; IDs for 98SE/ME/2K/XP
;;****************************************************************************
[Realtek]
%RTL8187B.DeviceDesc% = RTL8187B.ndi, USB\VID_0BDA&PID_8187&REV_0200

***ADD THIS LINE TO THE FILE WITH YOUR ADDRESS***

%RTL8187B.DeviceDesc% = RTL8187B.ndi, USB\VID_0BDA&PID_8189&REV_0200


Install the drivers:
ndiswrapper –i RTL8187B<your directory>.inf

See if the install is a valid install by listing the installed drivers:
ndiswrapper –l

This should echo something like:

net8187b : driver installed
device (0BDA:8189) present

If it doesn’t say this, it will just say driver installed and you need to start doing some research as to why it won’t work.. (btw, it took me about 5 hours until I figured it all out) You may have the wrong device address. Try using lsusb again.

If it does work, load the module:
modprobe ndiswrapper

The module doesn’t load automatically on each boot.. To load it on boot edit /etc/rc.d/rc.modules and add /sbin/modprobe ndiswrapper to the file.

I wanted my network interface to be know as wlan0 so I edited /etc/modprobe.conf and added alias wlan0 ndiswrapper to the file.

If you make it this far you can reboot or restart rc.inet1 (/etc/rc.d/rc.inet1 wlan0_start)

Now you need to edit your network configuration files. I am not sure what you will be using but I am using a dynamic ip connecting to a keyless router. Go here for help: http://alien.slackbook.org/dokuwiki/..._configuration

Start by editing /etc/rc.d/rc.wireless.conf and /etc/rc.d/rc.inet1.conf

In /etc/rc.d/rc.inet1.conf I disabled eth0 through eth3 by adding #

THIS WAS THE DEFAULT:
# Config information for eth0
IPADDR[0]=””
NETMASK[0]=””
USE_DHCP[0]=”yes”
DHCP_HOSTNAME[0]=””

THIS IS WHAT I CHANGED IT TO:
# Config information for eth0
#IPADDR[0]=””
#NETMASK[0]=””
#USE_DHCP[0]=”yes”
#DHCP_HOSTNAME[0]=””
*Do this for eth0-eth3

Then I scrolled down and changed the information for wlan0 to this:
DEFAULT:
#IFNAME[4]=”WLAN0
#IFADDR[4]=””
#NETMASK[4]=””
#USEDHCP[4]=”yes”
#DHCP_HOSTNAME[4]=”SOMETHING.ORG”


#WLAN_WPADRIVER[4]=”ndiswrapper”


#HWADDR[4]=”<YOUR HWADDR HERE>”
*Your HWADDR is your MAC address. You can find it with ifconfig wlan0. Look for the 12 digit hex address. It will look something like Hwaddr 00:e0:b8:6f:12:ff

THIS IS MY CHANGE:
IFNAME[4]=”wlan0”
IFADDR[4]=””
NETMASK[4]=””
USEDHCP[4]=”yes”
DHCP_HOSTNAME[4]=”natal.rr.com”


WLAN_WPADRIVER[4]=”ndiswrapper”


HWADDR[4]=” 00:e0:b8:6f:12:ff”

Save changes and reboot, or you can run /etc/rc.d/rc.inet1 wlan0_start

That’s it, of course it’s usually never that easy :P but, hopefully this will help you out some. Like I said, you need to read all the REAME, INSTALL files, and search keywords in GOOGLE. Work at it for weeks it you have to, I had to and it made getting it to work sweeter!

Last edited by muxsu; 06-04-2008 at 08:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring a rtl8187b wireless card on a Toshiba Satellite A215-s5802 in Ubuntu 7.10 post_erasmus Linux - Wireless Networking 11 04-30-2009 08:11 PM
realtek rtl8187b wireless problems deft Linux - Wireless Networking 11 07-02-2008 08:05 AM
Realtek RTL8187B wont show in hardy jessica_lilly Ubuntu 3 03-22-2008 07:30 PM
Mandiva Wireless problem with Realtek RTL8187B jessica_lilly Mandriva 1 03-04-2008 05:00 AM
wireless - ndiswrapper - slackware paul_mat Linux - Wireless Networking 13 04-02-2005 10:44 AM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration