LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-27-2007, 10:25 AM   #16
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30

Unfortunately, there is rarely a "straight forward" solution. The problem is getting the information from the vendors. I'll see what I can dig up, but it will be a little bit before I can do anything as I'm going to the Linux Fest Northwest show for the weekend.
 
Old 04-27-2007, 10:39 AM   #17
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Unfortunately there is no "straight forward" solution. CMedia doesn't list any datasheets for this product that I have found. If you could point me to where I can find your system's documentation, I might be able to get something from the manual and available drivers. At this time, I don't have enough info to work with.
 
Old 04-27-2007, 11:28 AM   #18
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Firefox appears to have gone nuts on me. I didn't know it had already posted twice. Didn't show up until this post.

Oh well.

Last edited by GrueMaster; 04-27-2007 at 11:30 AM.
 
Old 05-04-2007, 11:45 PM   #19
rishi_sanju
LQ Newbie
 
Registered: May 2007
Posts: 2

Rep: Reputation: 0
I have Realtek ALC882M High-Definition Audio, which does seem to be detected and so hear no sound. Tried test sounds but no avail. Also raised a bug at:
https://bugzilla.redhat.com/bugzilla....cgi?id=239122

Any help is appreciated.

[root@localhost ~]# lspci -s 0:1b -vn
00:1b.0 0403: 8086:27d8 (rev 01)
Subsystem: 1043:81a0
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at ddbf8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Unknown type IRQ 0

[root@localhost ~]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.14rc1 (Tue Jan 09 09:56:17 2007 UTC).
[root@localhost ~]# cat /proc/asound/card0/codec*
Codec: Realtek ALC882
Address: 0
Vendor Id: 0x10ec0882
Subsystem Id: 0x10430000
Revision Id: 0x100101
Default PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
Node 0x02 [Audio Output] wcaps 0x11: Stereo
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x03 [Audio Output] wcaps 0x11: Stereo
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x04 [Audio Output] wcaps 0x11: Stereo
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x05 [Audio Output] wcaps 0x11: Stereo
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x06 [Audio Output] wcaps 0x211: Stereo Digital
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0x1e]: 16 20 24 32
formats [0x1]: PCM
Node 0x07 [Audio Input] wcaps 0x10011b: Stereo Amp-In
Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x00 0x00]
PCM:
rates [0x160]: 44100 48000 96000
bits [0x6]: 16 20
formats [0x1]: PCM
Connection: 1
0x24
Node 0x08 [Audio Input] wcaps 0x10011b: Stereo Amp-In
Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x00 0x00]
PCM:
rates [0x160]: 44100 48000 96000
bits [0x6]: 16 20
formats [0x1]: PCM
Connection: 1
0x23
Node 0x09 [Audio Input] wcaps 0x10011b: Stereo Amp-In
Amp-In caps: ofs=0x08, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x00 0x00]
PCM:
rates [0x160]: 44100 48000 96000
bits [0x6]: 16 20
formats [0x1]: PCM
Connection: 1
0x22
Node 0x0a [Audio Input] wcaps 0x100391: Stereo Digital
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0x1e]: 16 20 24 32
formats [0x1]: PCM
Connection: 1
0x1f
Node 0x0b [Audio Mixer] wcaps 0x20010b: Stereo Amp-In
Amp-In caps: ofs=0x17, nsteps=0x1f, stepsize=0x05, mute=1
Amp-In vals: [0x80 0x80] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x17 0x17] [0x97 0x97] [0x97 0x97] [0x97 0x97] [0x97 0x97] [0x97 0x97]
Connection: 10
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17
Node 0x0c [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x17 0x17]
Connection: 2
0x02 0x0b
Node 0x0d [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x03 0x0b
Node 0x0e [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x04 0x0b
Node 0x0f [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x00 0x00]
Connection: 2
0x05 0x0b
Node 0x10 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x11 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x12 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x13 [Vendor Defined Widget] wcaps 0xf00000: Mono
Node 0x14 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083f: IN OUT HP Detect
Pin Default 0x01014c10: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Green
Pin-ctls: 0x40: OUT
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x15 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083f: IN OUT HP Detect
Pin Default 0x01012c12: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Grey
Pin-ctls: 0x40: OUT
Connection: 5
0x0c 0x0d* 0x0e 0x0f 0x26
Node 0x16 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083f: IN OUT HP Detect
Pin Default 0x01016c11: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Orange
Pin-ctls: 0x40: OUT
Connection: 5
0x0c 0x0d 0x0e* 0x0f 0x26
Node 0x17 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x083f: IN OUT HP Detect
Pin Default 0x01011c14: [Jack] Line Out at Ext Rear
Conn = 1/8, Color = Black
Pin-ctls: 0x40: OUT
Connection: 5
0x0c 0x0d 0x0e 0x0f* 0x26
Node 0x18 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08173f: IN OUT HP Detect
Pin Default 0x01a19c30: [Jack] Mic at Ext Rear
Conn = 1/8, Color = Pink
Pin-ctls: 0x24: IN
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x19 [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08173f: IN OUT HP Detect
Pin Default 0x02a19940: [Jack] Mic at Ext Front
Conn = 1/8, Color = Pink
Pin-ctls: 0x24: IN
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1a [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x80 0x80]
Pincap 0x08173f: IN OUT HP Detect
Pin Default 0x01813c31: [Jack] Line In at Ext Rear
Conn = 1/8, Color = Blue
Pin-ctls: 0x20: IN
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1b [Pin Complex] wcaps 0x40018f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x03, stepsize=0x27, mute=0
Amp-In vals: [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-Out vals: [0x00 0x00]
Pincap 0x08173f: IN OUT HP Detect
Pin Default 0x02214920: [Jack] HP Out at Ext Front
Conn = 1/8, Color = Green
Pin-ctls: 0xc0: OUT HP
Connection: 5
0x0c* 0x0d 0x0e 0x0f 0x26
Node 0x1c [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x0820: IN
Pin Default 0x99331132: [Fixed] CD at Int ATAPI
Conn = ATAPI, Color = Black
Pin-ctls: 0x00:
Node 0x1d [Pin Complex] wcaps 0x400000: Mono
Pincap 0x0820: IN
Pin Default 0x411111f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Black
Pin-ctls: 0x00:
Node 0x1e [Pin Complex] wcaps 0x400300: Mono Digital
Pincap 0x0810: OUT
Pin Default 0x014b711e: [Jack] SPDIF Out at Ext Rear
Conn = Comb, Color = Yellow
Pin-ctls: 0x00:
Connection: 1
0x06
Node 0x1f [Pin Complex] wcaps 0x400200: Mono Digital
Pincap 0x0820: IN
Pin Default 0x411161f0: [N/A] Speaker at Ext Rear
Conn = 1/8, Color = Orange
Pin-ctls: 0x00:
Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
Node 0x21 [Volume Knob Widget] wcaps 0x600080: Mono
Node 0x22 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Amp-Out caps: N/A
Amp-Out vals: [0x00 0x00]
Connection: 11
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b
Node 0x23 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Amp-Out caps: N/A
Amp-Out vals: [0x00 0x00]
Connection: 11
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b
Node 0x24 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80] [0x80 0x80]
Amp-Out caps: N/A
Amp-Out vals: [0x00 0x00]
Connection: 11
0x18 0x19 0x1a 0x1b 0x1c 0x1d 0x14 0x15 0x16 0x17 0x0b
Node 0x25 [Audio Output] wcaps 0x11: Stereo
PCM:
rates [0x560]: 44100 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Node 0x26 [Audio Mixer] wcaps 0x20010f: Stereo Amp-In Amp-Out
Amp-In caps: ofs=0x00, nsteps=0x00, stepsize=0x00, mute=1
Amp-In vals: [0x00 0x00] [0x00 0x00]
Amp-Out caps: ofs=0x1f, nsteps=0x1f, stepsize=0x05, mute=0
Amp-Out vals: [0x1f 0x1f]
Connection: 2
0x25 0x0b
[root@localhost ~]#
 
Old 05-14-2007, 08:47 AM   #20
techdesk100
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Ok I finally fixed the sound problem for my clevo d900t with Fedora Core 6 and looked what the minimal changes were to make it work

When you install for example GNOME Desktop Environment it also installs alsa-lib. Optionally you can install alsa-tools alsa-utils alsa-oss, but you cannot install alsa-drivers. The fix was compiling alsa-drivers and changing /etc/modprobe.conf. That was all to it.

This is probably the reason why some people say that after upgrading to another kernel sound does not work. Because you have to recompile alsa-drivers with the correct kernel-devel.
  • install alsa-lib if you did not do it already
    Code:
    smart install alsa-lib
  • download from alsa-project alsa-driver-1.0.14rc4.tar.bz2
  • extract alsa-driver-1.0.14rc4.tar.bz2 (needs bzip2 installed)
    Code:
    tar xvf alsa-driver-1.0.14rc4.tar.bz2
    Code:
    cd alsa-driver-1.0.14rc4
  • you need at least the following
    Code:
    smart install gcc kernel-devel make
  • configure it (I enabled also debugging)
    Code:
    ./configure --with-debug=full --with-cards=hda-intel
    Code:
    make;make install
    Code:
    ./snddevices
  • the setting for /etc/modprobe.conf can be found here
    so change /etc/modprobe.conf
    before
    Code:
    alias eth0 r8169
    alias scsi_hostadapter sata_promise
    alias snd-card-0 snd-hda-intel
    options snd-card-0 index=0
    options snd-hda-intel index=0
    remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
    after
    Code:
    alias eth0 r8169
    alias scsi_hostadapter sata_promise
    
    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-hda-intel
    
    # module options should go here
    
    # OSS/Free portion
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    	
    # card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
  • ok now you have to enable sound which is default muted.
    I did this by using System->Preferences->Volume Controle and enabling sound
    You can test it by using System->Preferences->Sound and setting "Sound Playback' to "Autodetect". Now you can test it.
    You could instead download from the alsa website alsa-utils which contains alsa-mixer or install it using smart/yum

for extra information
Did work without ~/.asoundrc
Code:
lsmod | grep snd
snd_hda_intel         247448  2 
snd_seq_oss            35968  0 
snd_seq_midi_event     11264  1 snd_seq_oss
snd_seq                56304  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device         12300  2 snd_seq_oss,snd_seq
snd_pcm_oss            51328  0 
snd_mixer_oss          20480  1 snd_pcm_oss
snd_pcm                83972  2 snd_hda_intel,snd_pcm_oss
snd_timer              26628  2 snd_seq,snd_pcm
snd                    61708  13 snd_hda_intel,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11681  1 snd
snd_page_alloc         13769  2 snd_hda_intel,snd_pcm
Code:
lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
Code:
dmesg | grep hda
hda_codec: Unknown model for ALC880, trying auto-probe from BIOS...
hda_codec: Cannot set up configuration from BIOS.  Using 3-stack mode...
hda_intel: azx_get_response timeout, switching to polling mode...
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda_codec: Unknown model for ALC880, trying auto-probe from BIOS...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2270: autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2274:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2278:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2286:    inputs: mic=0x0, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
hda_codec: Cannot set up configuration from BIOS.  Using 3-stack mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:558: hda_intel: azx_get_response timeout, switching to polling mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:564: hda_intel: azx_get_response timeout, switching to single_cmd mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:573: hda_codec: cannot malloc
this is for minimal system
you could add extra options
model= - force the model name
position_fix= - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)
single_cmd= - Use single immediate commands to communicate with
codecs (for debugging only)

Extra links
http://alsa.opensrc.org/Quick_Install
http://alsa.opensrc.org/AlsaTips
http://alsa.opensrc.org/Proc_asound_documentation
ALSA FAQ

If you have done a minimal alsa install you will get the problem that the sound is muted every time you try to start it up. Looking in the ALSA FAQ showed that I needed alsact and alsamixer which are in the alsa utils.

if you look in /etc/init.d/alsasound
Code:
function stop() {
  #
  # store driver settings
  #
  if [ -x $alsactl ]; then
    $alsactl -f $asoundcfg store
  else
To do this do not download the newest alsa-utils but use the one which is the same version as in the alsa-lib.
Otherwise you will get the error
Code:
checking for libasound headers version >= 1.0.12... not present.
configure: error: Sufficiently new version of libasound not found.
So to install it
Code:
smart install alsa-utils
With one of the newer kernels I could not get sound with my previous solution.
I had to comment the following part in /etc/modprobe.d/modprobe.conf.dist

#install sound-slot-* /sbin/modprobe snd-card-${MODPROBE_MODULE##sound[_-]slot[_-]}
#install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss

Last edited by techdesk100; 08-01-2007 at 02:44 PM.
 
Old 05-16-2007, 05:21 PM   #21
rishi_sanju
LQ Newbie
 
Registered: May 2007
Posts: 2

Rep: Reputation: 0
Yeap, before seeing this mail, tried similar way and it worked. Now the volume is so low, by putting max on system control and amplifier I can barely hear. I am yet to try /etc/modprobe.conf modification. But is there any other way to increase the volume ?
Thanks and appreciate your help.

Quote:
Originally Posted by techdesk100
Ok I finally fixed the sound problem for my clevo d900t with Fedora Core 6 and looked what the minimal changes were to make it work

When you install for example GNOME Desktop Environment it also installs alsa-lib. Optionally you can install alsa-tools alsa-utils alsa-oss, but you cannot install alsa-drivers. The fix was compiling alsa-drivers and changing /etc/modprobe.conf. That was all to it.

This is probably the reason why some people say that after upgrading to another kernel sound does not work. Because you have to recompile alsa-drivers with the correct kernel-devel.
  • install alsa-lib if you did not do it already
    Code:
    smart install alsa-lib
  • download from alsa-project alsa-driver-1.0.14rc4.tar.bz2
  • extract alsa-driver-1.0.14rc4.tar.bz2 (needs bzip2 installed)
    Code:
    tar xvf alsa-driver-1.0.14rc4.tar.bz2
    Code:
    cd alsa-driver-1.0.14rc4
  • you need at least the following
    Code:
    smart install gcc kernel-devel make
  • configure it (I enabled also debugging)
    Code:
    ./configure --with-debug=full --with-cards=hda-intel
    Code:
    make;make install
    Code:
    ./snddevices
  • the setting for /etc/modprobe.conf can be found here
    so change /etc/modprobe.conf
    before
    Code:
    alias eth0 r8169
    alias scsi_hostadapter sata_promise
    alias snd-card-0 snd-hda-intel
    options snd-card-0 index=0
    options snd-hda-intel index=0
    remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
    after
    Code:
    alias eth0 r8169
    alias scsi_hostadapter sata_promise
    
    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-hda-intel
    
    # module options should go here
    
    # OSS/Free portion
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    	
    # card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
  • ok now you have to enable sound which is default muted.
    I did this by using System->Preferences->Volume Controle and enabling sound
    You can test it by using System->Preferences->Sound and setting "Sound Playback' to "Autodetect". Now you can test it.
    You could instead download from the alsa website alsa-utils which contains alsa-mixer or install it using smart/yum

for extra information
Did work without ~/.asoundrc
Code:
lsmod | grep snd
snd_hda_intel         247448  2 
snd_seq_oss            35968  0 
snd_seq_midi_event     11264  1 snd_seq_oss
snd_seq                56304  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device         12300  2 snd_seq_oss,snd_seq
snd_pcm_oss            51328  0 
snd_mixer_oss          20480  1 snd_pcm_oss
snd_pcm                83972  2 snd_hda_intel,snd_pcm_oss
snd_timer              26628  2 snd_seq,snd_pcm
snd                    61708  13 snd_hda_intel,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              11681  1 snd
snd_page_alloc         13769  2 snd_hda_intel,snd_pcm
Code:
lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
Code:
dmesg | grep hda
hda_codec: Unknown model for ALC880, trying auto-probe from BIOS...
hda_codec: Cannot set up configuration from BIOS.  Using 3-stack mode...
hda_intel: azx_get_response timeout, switching to polling mode...
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda_codec: Unknown model for ALC880, trying auto-probe from BIOS...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2270: autoconfig: line_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2274:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2278:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:2286:    inputs: mic=0x0, fmic=0x0, line=0x0, fline=0x0, cd=0x0, aux=0x0
hda_codec: Cannot set up configuration from BIOS.  Using 3-stack mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:558: hda_intel: azx_get_response timeout, switching to polling mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/../../alsa-kernel/pci/hda/hda_intel.c:564: hda_intel: azx_get_response timeout, switching to single_cmd mode...
ALSA /Files/alsa-driver-1.0.14rc4/pci/hda/hda_codec.c:573: hda_codec: cannot malloc
this is for minimal system
you could add extra options
model= - force the model name
position_fix= - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)
single_cmd= - Use single immediate commands to communicate with
codecs (for debugging only)

Extra links
http://alsa.opensrc.org/Quick_Install
http://alsa.opensrc.org/AlsaTips
http://alsa.opensrc.org/Proc_asound_documentation
 
Old 05-17-2007, 11:02 AM   #22
techdesk100
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
I had also the same problem and it is annoying to enable the sound over and over.
I added the solution and the reason why it happened to my previous reply.
Code:
smart install alsa-utils
You could also install alsamixergui
Code:
smart install alsa-utils
and setup the sound volume with alsamixergui

I needed PCM and front
When you use the sound from GNOME you shouldn't forget to choose in volume control file => change devices to setup both ALSA mixer as the OSS mixer. Because the OSS mixer is connected to the sound slider and even if that's on you could still have low volume set in the ALSA mixer.

Last edited by techdesk100; 05-18-2007 at 12:35 PM.
 
Old 07-05-2007, 03:29 PM   #23
Twinkel
LQ Newbie
 
Registered: Feb 2005
Posts: 28

Rep: Reputation: 15
hda_intel: azx_get_response timeout

If
Code:
dmesg | grep azx_
reports a line of the form:
hda_intel: azx_get_response timeout
you might try adding "probe_mask=1" as an option to the snd_hda_intel module. Others have had success with "probe_mask=8" or "model=3stack". The output of
Code:
aplay -l
may help to diagnose the issue, too.
 
Old 08-15-2007, 11:37 AM   #24
denijane
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 1
Similiar problem

Hello,
i'm using Sabayon, though I hope that won't stop you from helping me.

I have normal sound, but when I wanted to use skype I discovered I have no mic. Not only in skype, i don't have mic at all.
I tried various wikis and trics, but the only thing I managed to get from krec is high level noises and nothing even close to my voice.
I read this thread and I think my problem might be that alsa gets wrong configuration of jacks for my laptop-Gigabyte, intel inside.
I tried to manually to edit it with
rmmod snd-hda-intel;modprobe snd-hda-intel model=ref

but I get:
----------------
ERROR: Module snd_hda_intel is in use
WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel
'
-----------
when I stop alsa, I get:
------------
ERROR: Module snd_hda_intel does not exist in /proc/modules
WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel'

This line is:
### update-modules: start processing /etc/modprobe.d/alsa-base
snd-hda-intel model=wcaps
----------------
But even if I change the "wcaps" to "3stack" manually I still get:
---------------
Loading ALSA modules ...
WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel'
* Loading: snd-card-0 ...
WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel' [ ok ]
* Loading: snd-seq-oss ...
WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel' [ ok ]
* Restoring Mixer Levels ...
XXX write TLV...
XXX write TLV...
------------

Any ideas? I spent the week on this problem and I'm getting really desperate.
As I said I have normal sound, can listen and watch and so on. I just can't make my mic record my voice (and thus, no voice-conversations)...
Anybody

P.S. I hope I don't break any rule bringing up a topic from may, but I'm utterly miserable...Sorry

Last edited by denijane; 08-15-2007 at 11:39 AM.
 
Old 08-15-2007, 12:49 PM   #25
Twinkel
LQ Newbie
 
Registered: Feb 2005
Posts: 28

Rep: Reputation: 15
I had this issue as well... at first. Hopefully, my fix will help you too.

If you use KDE, bring up the mixer window (kmix). There should be three tabs at the top. On the "Input" tab, there are some sliders labelled "Capture". Make sure the "red LED" (checkbox) at the bottom of one/some is/are on, and the slider is up to a reasonable level (probably all the way up, probably want to make sure that at least the first (leftmost) one is up). Also, on the "Switches" tab, there should be some combo boxes labelled "Input Source". I've had to make sure that these are set to "Mic", though you might try "Front Mic" as well, depending on your available options.

It's quite confusing... *way* too many knobs/switches/buttons to make sure you get right, but once you do, it should work without any need for module configuration (so long as you already have sound).
 
Old 08-15-2007, 01:58 PM   #26
denijane
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 1
Thanks Twinkel, but that was one of the first things I did. I admit I was confused too But everything there is on and to the max and has been in probably all possible permutations of the switches

I checked most of the files connected with sound and googled them and they look kind of ok.
Only this error I already posted is kind of odd, cuz it won't read that line and I get it, it's there the configuration of the jacks resides. Maybe

I so want to fix this,but I'm out of ideas...

and btw on my kmix 3d tab, i have only line in, iec958 and int mic, which is surprising me too.
 
Old 08-15-2007, 09:10 PM   #27
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Couple of things I see here. Don't take this personally, I see these mistakes all the time.

First, the modprobe.conf line should read "options snd-hda-intel model=<model>" (no quotes, replace <model> with a model from the ALC885 list in the ALSA-Configuration.txt). This will fix the "WARNING: /etc/modprobe.conf line 229: ignoring bad line starting with 'snd-hda-intel'" issue.

Second, your command "rmmod snd-hda-intel;modprobe snd-hda-intel model=ref" is formatted wrong. You should type "rmmod snd-hda-intel && modprobe snd-hda-intel model=ref" with the && instead of a ; to trap errors, like the "ERROR: Module snd_hda_intel is in use" error you are seeing without generating more errors.

Third, If "rmmod snd-hda-intel" fails (as above), make sure you close all apps that are accessing the sound card. Type (as root) "lsof /dev/snd/*" to find out which applications are loaded. Kill each one accordingly.

Last, for better support, run this script and post the link it generates. I can then use this information to direct you towards a possibly newer driver, or make a patch for your driver.

Also, you should post a new help thread instead of piggybacking on an old one. More visiblity to the people that can help.

Tobin
 
Old 08-16-2007, 04:46 AM   #28
denijane
LQ Newbie
 
Registered: Aug 2007
Posts: 10

Rep: Reputation: 1
Hey Tobin, thanks for the reply.
I was apologizing exactly for bumping up an old thread, cuz in some forums this is not welcomed, but I thought this thread is the closest to my question. If you think I should, I can repost my question in a new thread.

Now, I did what you said, it really fixed the "Warning" message, but still I can't use "rmmod snd-hda-intel && modprobe snd-hda-intel model=ref", says " Module snd_hda_intel does not exist in /proc/modules" and indeed, I can't find it in "/proc/modules"when I kill all the sound-related processes.

Down is the result from the script (cool one,btw):
I hope this give you some ideas for help. Thanks again for the answer! I appreciate it.
---------------------
!!################################
!!ALSA Information Script v 0.4.30
!!################################

!!Script ran on: чт авг 16 12:40:00 UTC 2007


!!Linux Distribution
!!------------------

Gentoo Base System release 1.12.10 Sabayon Linux x86 3.4 Sabayon Linux x86 3.4


!!Kernel Information
!!------------------

Kernel release: 2.6.21-sabayon-r2
Operating System: GNU/Linux
Architecture: i686
Processor: Genuine Intel(R) CPU T2250 @ 1.73GHz
SMP Enabled: Yes


!!ALSA Version
!!------------

Driver version: 1.0.14rc3
Library version: 1.0.14a
Utilities version: 1.0.14


!!Loaded ALSA modules
!!-------------------



!!Soundcards recognised by ALSA
!!-----------------------------

0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xdc440000 irq 21


!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
05:01.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)


!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 02)
Subsystem: 152d:0753


!!HDA-Intel Codec information
!!---------------------------

Codec: Conexant CX20549 (Venice)
Address: 0
Vendor Id: 0x14f15045
Subsystem Id: 0x152d0753
Revision Id: 0x100100
Default PCM:
rates [0x140]: 48000 96000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Default Amp-In caps: N/A
Default Amp-Out caps: N/A
Node 0x10 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0x21 0x21]
Pincap 0x0810014: OUT EAPD Detect
Pin Default 0x951701f0: [Fixed] Speaker at Int Top
Conn = Analog, Color = Unknown
Pin-ctls: 0x40: OUT
Power: 0x0
Connection: 2
0x19* 0x17
Node 0x11 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0x21 0x21]
Pincap 0x08113c: IN OUT HP Detect
Pin Default 0x02813011: [Jack] Line In at Ext Front
Conn = 1/8, Color = Blue
Pin-ctls: 0xc0: OUT HP
Power: 0x0
Connection: 2
0x19* 0x17
Node 0x12 [Pin Complex] wcaps 0x40058d: Stereo Amp-Out
Amp-Out caps: ofs=0x2b, nsteps=0x2b, stepsize=0x05, mute=1
Amp-Out vals: [0xab 0xab]
Pincap 0x08113c: IN OUT HP Detect
Pin Default 0x02a19010: [Jack] Mic at Ext Front
Conn = 1/8, Color = Pink
Pin-ctls: 0x20: IN
Power: 0x0
Connection: 2
0x19* 0x17
Node 0x13 [Pin Complex] wcaps 0x400301: Stereo Digital
Pincap 0x0810: OUT
Pin Default 0x22454130: [Jack] SPDIF Out at Sep Front
Conn = Optical, Color = Green
Pin-ctls: 0x00:
Connection: 1
0x18
Node 0x14 [Pin Complex] wcaps 0x400081: Stereo
Pincap 0x081124: IN Detect
Pin Default 0x95a7011e: [Fixed] Mic at Int Top
Conn = Analog, Color = Unknown
Pin-ctls: 0x20: IN
Node 0x15 [Pin Complex] wcaps 0x400001: Stereo
Pincap 0x0820: IN
Pin Default 0x400001f0: [N/A] Line Out at Ext N/A
Conn = Unknown, Color = Unknown
Pin-ctls: 0x00:
Node 0x16 [Beep Generator Widget] wcaps 0x70000c: Mono Amp-Out
Amp-Out caps: ofs=0x07, nsteps=0x07, stepsize=0x0b, mute=1
Amp-Out vals: [0x06]
Node 0x17 [Audio Mixer] wcaps 0x20050b: Stereo Amp-In
Amp-In caps: ofs=0x14, nsteps=0x2b, stepsize=0x05, mute=1
Amp-In vals: [0x94 0x94] [0x2b 0x2b] [0x2b 0x2b] [0x94 0x94] [0x94 0x94]
Power: 0x0
Connection: 5
0x19 0x14 0x12 0x11 0x15
Node 0x18 [Audio Output] wcaps 0x211: Stereo Digital
PCM:
rates [0x40]: 48000
bits [0x6]: 16 20
formats [0x5]: PCM AC3
Node 0x19 [Audio Output] wcaps 0xc11: Stereo
PCM:
rates [0x540]: 48000 96000 192000
bits [0xe]: 16 20 24
formats [0x1]: PCM
Power: 0x0
Node 0x1a [Audio Input] wcaps 0x100d0b: Stereo Amp-In
Amp-In caps: ofs=0x00, nsteps=0x17, stepsize=0x05, mute=1
Amp-In vals: [0x17 0x17] [0x00 0x00] [0x00 0x00] [0x00 0x00] [0x00 0x00]
Power: 0x0
Connection: 5
0x17* 0x14 0x12 0x11 0x15
Node 0x1b [Vendor Defined Widget] wcaps 0xf00000: Mono


!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root audio 116, 6 16 авг 12,35 /dev/snd/controlC0
crw-rw---- 1 root audio 116, 5 16 авг 12,35 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 4 16 авг 12,35 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 3 16 авг 12,35 /dev/snd/pcmC0D1p
crw-rw---- 1 root audio 116, 7 16 авг 12,35 /dev/snd/seq
crw-rw---- 1 root audio 116, 2 16 авг 11,14 /dev/snd/timer


!!Aplay output
!!------------

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0


!!Amixer output
!!-------------

!!-------Mixer controls for card 0 [Intel]

Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 43
Mono:
Front Left: Playback 33 [77%] [on]
Front Right: Playback 33 [77%] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'LineIn',0
Capabilities: cswitch cswitch-joined cswitch-exclusive
Capture exclusive group: 0
Capture channels: Mono
Mono: Capture [off]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 23
Front Left: Capture 23 [100%] [34.50dB] [on]
Front Right: Capture 23 [100%] [34.50dB] [on]
Simple mixer control 'Digital',0
Capabilities: cvolume
Capture channels: Front Left - Front Right
Limits: Capture 0 - 120
Front Left: Capture 64 [53%] [2.00dB]
Front Right: Capture 64 [53%] [2.00dB]
Simple mixer control 'Ext Mic',0
Capabilities: volume pswitch
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 43
Front Left: 43 [100%] [34.50dB] Playback [on]
Front Right: 43 [100%] [34.50dB] Playback [on]
Simple mixer control 'Int Mic',0
Capabilities: volume pswitch
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 43
Front Left: 43 [100%] [34.50dB] Playback [on]
Front Right: 43 [100%] [34.50dB] Playback [on]
Simple mixer control 'IntMic',0
Capabilities: cswitch cswitch-joined cswitch-exclusive
Capture exclusive group: 0
Capture channels: Mono
Mono: Capture [on]


!!All Loaded Modules
!!------------------

Module
snd_seq_dummy
snd_seq_oss
snd_seq_midi_event
snd_seq
snd_seq_device
snd_hda_intel
snd_hda_codec
ieee80211_crypt_wep
i915
drm
vboxdrv
pcmcia
tifm_7xx1
tifm_core
yenta_socket
rsrc_nonstatic
intelfb
i2c_algo_bit
iTCO_wdt
iTCO_vendor_support
sdhci
mmc_core
intel_agp
ipw3945
sky2
i2c_i801
i2c_core
pcspkr
joydev
ieee80211
ieee80211_crypt
tg3
e1000
sl811_hcd
ohci_hcd
uhci_hcd
ehci_hcd

Last edited by denijane; 08-16-2007 at 05:10 AM.
 
Old 08-16-2007, 09:09 AM   #29
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
Quote:
!!ALSA Version
!!------------

Driver version: 1.0.14rc3
This tells me that you need to update your driver. You can get a new version from http://alsa-project.org

Quote:
!!Advanced information - PCI Vendor/Device/Susbsystem ID's
!!--------------------------------------------------------

00:1b.0 0403: 8086:27d8 (rev 02)
Subsystem: 152d:0753
.
.
.
Codec: Conexant CX20549 (Venice)
Address: 0
Vendor Id: 0x14f15045
These tell me which driver code to look at. And I can tell that your system is not in the driver yet. The model options you should try is "laptop" or "fujitsu". If either of those modules will work, I can easily add your system. Otherwise, I'll need to work on this over the weekend.

I'm off to work now. I'll look at this more later tonight.
 
Old 08-16-2007, 10:25 AM   #30
GregLee
Member
 
Registered: Feb 2004
Location: Waimanalo, HI
Distribution: Slackware 10, Fedora 6
Posts: 308

Rep: Reputation: 30
Have you folks all used alsamixer to unmute channels and turn up the volume?
 
  


Reply

Tags
alsa, fc, fc6, fedora, fedora 6, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No Sound MCP51 High Definition Audio on SuSE10.1 SPCSTEWART Linux - Hardware 2 11-11-2006 05:08 AM
Realtek AC97 Audio + Fedora Core 3 furtivefelon Linux - Laptop and Netbook 4 01-05-2006 12:06 PM
no sound in slackware 10.2 with cmedia high definition audio device pete1000 Slackware 2 09-30-2005 01:06 AM
No sound on Intel High Def Audio on Fedora Core 3 ck1125 Linux - Hardware 2 06-06-2005 08:45 PM
Intel HD (High Definition) Audio Codec (915G Chipset) on SuSE 9.2 cbj4074 Suse/Novell 15 05-08-2005 07:10 AM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration