LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-29-2003, 12:06 PM   #1
StressedLemming
LQ Newbie
 
Registered: Oct 2003
Posts: 26

Rep: Reputation: 15
RealTek ethernet card in RH9


Hi there, does anyone have any ideas how I can get Red Hat 9.0 to recognise a RealTek Ethernet card with chipset rtl8009? If it were mine I'd trash the damn thing and buy a new one but unfortunately I have a project to set up a linux cluster at university and I have to use the hardware they provide.

Thanks,
Ross
 
Old 10-29-2003, 02:38 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
I think the 8009 is a NE2000 clone so try using that driver (ne2k-pci is the name in 2.4.22, it might be different for an older kernel).

Håkan
 
Old 10-29-2003, 06:22 PM   #3
StressedLemming
LQ Newbie
 
Registered: Oct 2003
Posts: 26

Original Poster
Rep: Reputation: 15
I tried this but I kept getting errors saying that io=0x300 and IRQ=10 were not valid arguments or something, even though I checked these setting with a dos utility. Odd. The card does say NE2000 on it though so I assume it is compatible. Do I need to set up an ISA to PCI bridge somehow in order for the pci driver to work?

Thanks,
Ross
 
Old 10-29-2003, 07:44 PM   #4
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
Oh, I assumed you had the PCI version. Try the "ne" driver for ISA NE2000 cards.

Håkan
 
Old 10-30-2003, 03:17 AM   #5
adz
Senior Member
 
Registered: Jun 2003
Location: Sydney
Distribution: Debian, FreeBSD
Posts: 1,713

Rep: Reputation: 53
And don't specify io and irq settings for pci devices. They'll be detected automatically.
 
Old 10-30-2003, 04:43 PM   #6
StressedLemming
LQ Newbie
 
Registered: Oct 2003
Posts: 26

Original Poster
Rep: Reputation: 15
Thanks for your input. Unfortunately I didn't have any success with the rtl8009 cards but I've managed to get hold of some rtl8029AS cards that are proving slightly more compatible.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 9.0 doesn't detect Ethernet card on nVidia shipset 2, on-board card Realtek 8201 devilpim Linux - Newbie 3 05-27-2006 12:08 AM
Realtek Ethernet Card Interrupt Conflict on FC4 and ATI Integrated Sound and Video pluk2001 Linux - Newbie 3 10-08-2005 09:25 PM
Ethernet Card Realtek 8139 not working on MDK 10.1 community [MDK]NooB Mandriva 3 05-10-2005 02:54 PM
VIA sound card and Realtek ethernet card teamstatic84 Linux - Hardware 4 12-31-2003 08:18 AM
RedHat Linux8.0 giving problem with RealTek 8139 Ethernet card delipsingh Linux - Networking 10 09-01-2003 02:18 AM


All times are GMT -5. The time now is 03:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration