Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 06-01-2008, 09:14 PM   #1
LQ Newbie
Registered: Jun 2008
Posts: 2

Rep: Reputation: 0
Realtek ALC883 Microphone is not being detected.


I have a Realtek ALC883 Sound card, and the microphone is not working. output is:

The output works fine, the input doesn't work (the mic).

On Sound Recorder there are no devices in "Record from input".
On OSS Mixer there is no "Recording" Tab, I just have "Playback".

Here's a screen shot of both applications:

gnome-sound-properties returns an error when I click "Test" on Sound Capture when ALSA is selected:
sound-properties-Message: Error running pipeline 'gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat': Could not open resource for writing. [gstalsasrc.c(600): gst_alsasrc_open (): /pipeline0/gconfaudiosrc0/bin1/alsasrc0:
I think the following user had the same problem as I:
And this one:

And the first one opted for buying a new mic, and the second one on doing a fresh install on every boot.. so well.

Is there any other solution?

I have alsa-driver-1.0.16 sources but I dont know with which --with-card option I should ./configure it, since I've read that there's (or was) a bug with them at the time of selecting the card when ./configuring it with =all.

Any help will be appreciated.

Old 06-02-2008, 12:50 AM   #2
Registered: Aug 2003
Location: Arkansas
Distribution: Slackware 12.2
Posts: 104

Rep: Reputation: 15
According to this thread:

The user got it working with:
snd-hda-intel model=6stack-dig
I have not tried recording with my machine but had other sound issues with a related card (same family but the ALC861VD).

Long and short I found the fix for my issue as a result of changes that were made to the kernel (but seem to be undocumented in the current ALSA documentation since the specific model= I needed (lenovo) was not listed as being an option for my chip). I am running Alsa 1.0.15 (the default for slack).

I say that to let you know if the thread does not fix it, you may just want to keep trying different models= lines until you hit upon one that works.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 08:25 PM
Configuring Realtek ALC883 onboard audio? cdrom600 Linux - Hardware 5 03-12-2010 08:10 AM
Kmix - microphone - Nvidia MCP51 High Definition audio - realtek ALC883 farfrael Linux - Hardware 5 03-04-2008 12:09 AM
KMix problem with Realtek ALC883 sound ccin1492 Linux - Hardware 12 12-11-2007 05:20 PM
realtek alc883 record sound wont work vo1pwf Linux - Hardware 7 11-18-2007 07:03 PM

All times are GMT -5. The time now is 06:05 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration