LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-20-2011, 11:37 AM   #1
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Rep: Reputation: 19
Realtek ALC861 no microphone


Hello everybody,

I am running Debian Squeeze on my Amilo Li 1718 having a Realtek ALC816 sound card using alsa drivers (version 1.0.21).
When I plug-in any microphone in the front jack I cannot record any sound or get any voip to use it. I have tried to google this issue and also tried to run alsa-info.sh (of which you can see the output here) without any result (maybe because I am not good enough in reading the output ).
More strangely I found out that in alsa mixer the microphone does not even shop up...
http://dl.dropbox.com/u/56661804/alsa.png


someone has any guess??

Last edited by VDP76; 02-05-2012 at 12:11 PM.
 
Old 11-20-2011, 06:55 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hi VDP76, Welcome to LQ. It looks like you have capture devices available from the output and the picture. Did you try selecting the recording tab from the alsa mixer GUI that you saved a screen cap of?

Good luck. ;-)
 
Old 11-21-2011, 03:55 PM   #3
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
Hi Peacedog,
sure I tried to select that tab...It has only "Capture" and "Digital"...as I said before, no sign of Microphone... o.O
 
Old 11-21-2011, 03:57 PM   #4
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
Hi Peacedog,
sure I tried to select that tab...It has only "Capture" and "Digital"...as I said before, no sign of Microphone... o.O
 
Old 11-21-2011, 09:05 PM   #5
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Capture should be your mic or at least one of them. Try playing with those capture and digital settings, changing the levels and such. You should be able to get some sound recorded/captured.

Good luck. ;-)
 
Old 11-23-2011, 04:07 PM   #6
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
Playing with "Capture" and "Digital" levels hasn't produced any results. As I wrote before, I am afraid that for some reason the "Microphone" level is missing for my alsa mixer.
In fact I actually have a "Microphone" level setting, but is for the built-in mic in my web-cam. So far I always used this mic but now I wanted to solve this issue.

Any more suggestion would be appreciated...
 
Old 11-23-2011, 08:02 PM   #7
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Please post the result of the following.

Code:
$ arecord -l
Good luck. ;-)
 
Old 11-24-2011, 12:07 PM   #8
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
here it is the output...

Code:
mattia@mattia-laptop:~$ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC861-VD Analog [ALC861-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 6: Si3054 Modem [Si3054 Modem]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: U0x46d0x802 [USB Device 0x46d:0x802], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
mattia@mattia-laptop:~$
semms pretty ok, isn't it!?
 
Old 11-24-2011, 01:02 PM   #9
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Yes, it's showing the internal mic as card 0/0, your modem as card 0/6 and your usb mic as card 1/0. Please post the result of the following.

Code:
$ cat /etc/modprobe.d/alsa-base
Good luck. ;-)
 
Old 11-25-2011, 10:39 AM   #10
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
I have no alsa-base file but I have alsa-base.conf instead, here it is:

Code:
mattia@mattia-laptop:~$ cat /etc/modprobe.d/alsa-base
cat: /etc/modprobe.d/alsa-base: No such file or directory
mattia@mattia-laptop:~$ cat /etc/modprobe.d/alsa-base.conf 
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
mattia@mattia-laptop:~$
can this help??? ;-)
 
Old 11-26-2011, 07:22 AM   #11
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Try editing the file and adding this line to the end of it.

Code:
options snd-hda-intel position_fix=1 model=lenovo
To edit try the following.

Code:
$ sudo gedit /etc/modprobe.d/alsa-base.conf
After the edit, reboot and see if things are working properly.

Good luck. ;-)
 
1 members found this post helpful.
Old 11-26-2011, 08:46 AM   #12
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
hi

your subject is wrong...you have a ALC861-VD not 816.

2) not sure why model=lenovo should be the first option for your make?

so here is the text for your consideration

ALC861VD/660VD
==============
3stack 3-jack
3stack-dig 3-jack with SPDIF OUT
6stack-dig 6-jack with SPDIF OUT
3stack-660 3-jack (for ALC660VD)
3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
lenovo Lenovo 3000 C200
dallas Dallas laptops
hp HP TX1000
asus-v1s ASUS V1Sn
auto auto-config reading BIOS (default)


as you don't say you use hdmi...or optical I suggest you change to model=3stack-660

3) FYI 3 stack means you have 3 coloured input or outputs.

your ms specs are

Audio
Azalia codec, 1 built-in high quality speaker, microphone in
combined with stereo line-in, headphone out shared with
line-out, sound volume controlled by Hot Keys


so that seems about right....headphone uses the line out but now it is better to use alsamixer to setup line out as mic in

an overview is here

http://techpatterns.com/forums/about1813.html

but I did not write it for portables so here is a before and after to give you the idea.

http://ompldr.org/vYmdtag/alc861.jpg

now I have 2 mics so forgive me for some creative guessing.

open a terminal and run alsamixer

the left hand image for you....is the OUTPUT and will hopefully say "line OUT" (not in) or micophone
use arrow right to get to it and the press up or down arrow to change to mic ok?

the right hand image is obtained by pressing the TAB key to get to capture devices
Your input source must now say mic (hopefully)

then look at the volumes and raise and test as per my first link

if you have distortion turn off MUX (lower)

good luck
 
1 members found this post helpful.
Old 11-26-2011, 08:49 AM   #13
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
oops I meant mic image will say line in

good luck
 
Old 11-30-2011, 01:34 PM   #14
VDP76
Member
 
Registered: Apr 2010
Location: Bayreuth, Germany
Distribution: CrunchBang Linux (#!)
Posts: 111

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by Peacedog View Post
Try editing the file and adding this line to the end of it.

Code:
options snd-hda-intel position_fix=1 model=lenovo
To edit try the following.

Code:
$ sudo gedit /etc/modprobe.d/alsa-base.conf
Quote:
Originally Posted by aus9 View Post
2) not sure why model=lenovo should be the first option for your make?

so here is the text for your consideration

ALC861VD/660VD
==============
3stack 3-jack
3stack-dig 3-jack with SPDIF OUT
6stack-dig 6-jack with SPDIF OUT
3stack-660 3-jack (for ALC660VD)
3stack-660-digout 3-jack with SPDIF OUT (for ALC660VD)
lenovo Lenovo 3000 C200
dallas Dallas laptops
hp HP TX1000
asus-v1s ASUS V1Sn
auto auto-config reading BIOS (default)


as you don't say you use hdmi...or optical I suggest you change to model=3stack-660
I'm glad to tell you this solution worked out...
Now my alsamixer shows "Microphone" and "Mic Boost" and I'm able to use a headset instead of the webcam built-in microphone..
Just FYI, strangely, in addition the mixer also shows "Front Mic" and "Front Mic Boost" which work as well as the others...

Anyway, thank you very much for the help you gave me!

Last edited by VDP76; 11-30-2011 at 01:35 PM.
 
  


Reply

Tags
alsa, debian, microphone, realtek


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 07:25 PM
ALSA: Realtek ALC883 Microphone Not Working pandamine Linux - Hardware 1 03-26-2012 07:15 PM
[SOLVED] Problem with Microphone: Realtek ALC883 Glyph13 Linux - Hardware 3 07-13-2009 09:35 AM
Realtek ALC883 Microphone is not being detected. sirdarckcat Linux - Hardware 1 06-01-2008 11:50 PM
HDA Intel/Realtek microphone/line in very quiet format C: Linux - Hardware 1 02-20-2007 01:50 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration