LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-27-2004, 06:51 PM   #1
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Rep: Reputation: 0
Reading from RAID 0 SATA NTFS Drive


I've seen this posted a lot with no solution, but hopefully someone has figured it out and can help.

I am running SUSE 9.1 on an IDE HD and I have 2 120GB SATA drives running in a RAID 0 configuration running Windows XP. I have a ton of MP3s on this array and would like to access them when I boot to Linux. I've checked the usual sources and could mount it fine were they separate drives, but FDISK sees them as 2 corrupt NTFS drives. It is an Intel RAID controller on an ASUS P4P800-E with the Intel ICHR5 Chipset.

Disk /dev/hda: 20.4 GB, 20411080704 bytes
16 heads, 63 sectors/track, 39549 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 2081 1048792+ 82 Linux swap
/dev/hda2 2082 39549 18883872 83 Linux

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/sda doesn't contain a valid partition table

Disk /dev/sdb: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 29185 234428481 7 HPFS/NTFS
linux: # mount /dev/sda /mnt/h -t ntfs
mount: wrong fs type, bad option, bad superblock on /dev/sda,
or too many mounted file systems

I've checked YAST and the ASUS site but cannot find a driver for it.

Thanks in advance
 
Old 08-27-2004, 07:12 PM   #2
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
i should mention, i've tried dmraid

ERROR: Failed to find sysfs mount point
carrying on with /dev/
ERROR: unsupported sector size 2048 on /dev/hdc.
ERROR: failed seeking device "/dev/sdb"
ERROR: failed seeking device "/dev/sdb"
ERROR: isw: failed reading first sector of ISW superblock for /dev/sdb
ERROR: failed seeking device "/dev/sdb"
ERROR: failed seeking device "/dev/sdb"
ERROR: failed seeking device "/dev/sdb"
ERROR: failed seeking device "/dev/sda"
ERROR: failed seeking device "/dev/sda"
ERROR: isw: failed reading first sector of ISW superblock for /dev/sda
ERROR: failed seeking device "/dev/sda"
ERROR: failed seeking device "/dev/sda"
ERROR: failed seeking device "/dev/sda"
ERROR: failed seeking device "/dev/hda"
ERROR: failed seeking device "/dev/hda"
ERROR: isw: failed reading first sector of ISW superblock for /dev/hda
ERROR: failed seeking device "/dev/hda"
ERROR: failed seeking device "/dev/hda"
ERROR: failed seeking device "/dev/hda"
No Software RAID disks
 
Old 08-28-2004, 04:14 PM   #3
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
does anyone know another source that might know the answer to this?
 
Old 08-29-2004, 02:34 AM   #4
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
If you set up software RAID in Windows forget it being used in Linux. Also you may have destroyed the RAID array by using Linux software RAID. If you are going from Windows to Linux, use the drives seperatly. You do not need bandwidth for MP3. INTEL SATA controllers set as RAID will not work in LINUX. Also they do not even work in Linux at all unless you get the modules (drivers) from INTEL site. You can check if there is /dev/md. If it exist try using fdisk to list partitions on it.

If you set software RAID in Windows. It can only be used in Windows.

If you set software RAID in Linux. It can only be used in Linux.

If you used a hardware RAID controller. It will work in both Windows and Linux.

I hope you backed up your files on the RAID array because there is very high chance that your RAID array will not work in Windows.
 
Old 08-29-2004, 10:08 AM   #5
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
windows/the raid array works fine, i never reset the raid array, i just tried to detect it (fdisk -l) and list the volumes present on the system

the intel raid controller has it's own BIOS where I created the RAID 0 array, it's not a software RAID array

I think linux doesn't have a driver to communicate with the Chipset's RAID controller, the Intel site pointed me to a driver that may work, but it's only for 2.4 kernels, that site pointed me to the dmraid one that works with 2.6 kernels, and it only works with intel software arrays

i have about 10 items listed as unknown in SUSE's hardware browser, most having to do with the motherboard, and intel's site and asus's site have no Linux drivers for the chipset/motherboard, which i think is rather lazy of them (other than the NIC and sound card), I just wondered if anyone knew how to get it to work.

Thanks for the reply Electro.

Last edited by fizgigtiznalkie; 08-29-2004 at 10:09 AM.
 
Old 08-29-2004, 04:18 PM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Quote:
the intel raid controller has it's own BIOS where I created the RAID 0 array, it's not a software RAID array
Yes, its software RAID. Software RAID is simpler and cheaper to make than hardware RAID.

Its not motherboard manufacture's fault. Its the chipset manufacture's fault. I do know that Highpoint is the only one that has open source modules (drivers) for their SATA controllers.

The software to control the chipset is already compiled in the Linux kernel so SUSE or other Linux distribution will not know this. I have a bunch of unknowns in the hardware list in Mandrake. My computer runs fine and fast.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount ntfs SATA Raid Youbou Linux - Hardware 1 02-23-2005 07:04 AM
Mount SATA drive (not RAID) EcceVery Debian 3 08-31-2004 06:47 PM
reading ntfs files from external hard drive seedsgrow Linux - Hardware 1 05-01-2004 01:59 AM
Reading Files off of an NTFS drive wasabi Mandriva 21 09-09-2003 12:20 AM
Reading NTFS 2nd Hard Drive shwabob Linux - Hardware 1 06-09-2003 06:10 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration