Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 12-06-2005, 11:18 AM   #1
Roberto Colmegna
LQ Newbie
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
RAID 1 rebuild


I have a RAID1-question. I have a RAID1 builded in
this way:

md1 : active raid1 hdc7[1] hda7[0]
2048192 blocks [2/2] [UU]

md0 : active raid1 hdc1[1] hda1[0]
30716160 blocks [2/2] [UU]

md0 is "/" and md1 is the "/tmp part.

I tested a one-disk failure: I have turned-on
my PC with only hdA and I obtain a RAID degraded
system ... this OK.

The strange think appear when I reattach hdC an I
restart my system. I had this situation:

md1 : active raid1 hdc7[1] hda7[0]
2048192 blocks [2/1] [U_]

md0 : active raid1 hdc1[1] hda1[0]
30716160 blocks [2/1] [_U]

... WAIT a moment ... but how is this possibile?
md1 have the safe part. on hdC while md0 have
the safe part. on hdA?!?!? ... but safe data
are on hdA only!!!!

How can I force raid-engine to use ONLY hdA to
rebuild RAID1 on hdC?

Roberto Colmegna
Old 12-07-2005, 08:58 PM   #2
Registered: Sep 2005
Posts: 128

Rep: Reputation: 15
Yeah I dunno how you got that to happen, but you can't really force it to do otherwise. Maybe MD1 being your /tmp it was so unused when the drive got reconnected it actually looked like the newer copy.

Despite what you posted above maybe your reading it backwards? On mine for example, despite the drives being listed as hde, hdg for both raids I still get this from looking at /proc/mdstat

md1 : active raid1 hde5[0] hdg5[1]
1999744 blocks [2/2] [UU]

md0 : active raid1 hdg2[1] hde2[0]
76150720 blocks [2/2] [UU]

the hde, and hdg are reversed for each raid and I don't really know why.

Last edited by KnightHawk; 12-07-2005 at 09:00 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to rebuild a damaged raid 1 array? mrpc_cambodia Linux - General 1 04-12-2005 09:22 AM
Perc3Di SCSI RAID + Adaptec 2810SA RAID = Fatal Grub Error? LinuxOnTheEdge Linux - General 2 03-19-2005 03:35 PM
rebuild kernel 2.6 boot fail on soft RAID fs Ducko Fedora 4 10-05-2004 09:40 PM
Rebuild Software RAID 1 thadco Linux - Newbie 1 06-03-2004 05:06 AM
does linux support the sata raid and ide raid in k7n2 delta ilsr? spyghost Linux - Hardware 10 04-16-2004 06:27 AM

All times are GMT -5. The time now is 01:34 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration