LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-14-2003, 09:10 PM   #1
JingYen
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Rep: Reputation: 0
Angry Radeon 9500 w/ATI's drivers for XF86 4.3.0


I've searched through numerous previous posts regarding the binary drivers that ATI have released for XFree86 4.3.0, and I have semi-successfully installed them with my Slackware distro. I have 2d working well without any errors in my /var/log/messages

The problem now is that 3d isn't working. fglrxinfo reports:

display: :0.0 screen: 0
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

I'm aware that the library needed is libGL.so.1.2 but I'm not sure what I need to do make XFree use these libraries for 3d. running ldd glxgears yields:

libGL.so.1 => /usr/lib/libGL.so.1 (0x40026000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x400a5000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x400b3000)
libpthread.so.0 => /lib/libpthread.so.0 (0x4017a000)
libm.so.6 => /lib/libm.so.6 (0x401cb000)
libc.so.6 => /lib/libc.so.6 (0x401ee000)
libdl.so.2 => /lib/libdl.so.2 (0x40324000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

which has no reference to libGL.so.1.2

Is it as simple as updating my symbolic link to the correct library?

I've read reports of success with the previous download from the german site, but the only one who mentioned success with the ones directly from ATI's site was Zoombie. He is using the same version of Slackware as I, but he made no mention of the symptoms I describe. Any help or pointers anyone can provide would be greatly appreciated.

Thanks in advance!
 
Old 09-15-2003, 09:48 AM   #2
JingYen
LQ Newbie
 
Registered: Sep 2003
Posts: 8

Original Poster
Rep: Reputation: 0
bump ^
 
Old 09-19-2003, 11:50 PM   #3
shaungc
LQ Newbie
 
Registered: Sep 2003
Location: MN, USA
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
I have the same problem, and have not resolved it. I do have some information to share with you though. The libGL.so.1 => /usr/X11R6/lib/libGL.so.1 (0x40016000) entry from the ldd refers to a symbolic link. Check it out.

scarter]$ ls -l /usr/X11R6/lib/libGL.so.1
lrwxrwxrwx 1 root root 27 Sep 12 22:46 /usr/X11R6/lib/libGL.so.1 -> /usr/X11R6/lib/libGL.so.1.2

So this file is exactly what the ATI doc says is good to have. But I also get

fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4

I'll keep you updated on what I find out.

Shaun
 
Old 09-21-2003, 02:59 PM   #4
shaungc
LQ Newbie
 
Registered: Sep 2003
Location: MN, USA
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Resolved:

changed line 5847 in the agpgart_be.c file in /lib/modules/fglrx/build_mod to read

via_kt400_setup

Since I have a KT400 chipset. Rebuilt the module manually and inserted

install fglrx /sbin/insmod fglrx

into /etc/modules.conf (RH10Beta)

now fglrxinfo shows

scarter]# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon 9600 Athlon (3DNow!)
OpenGL version string: 1.3 (X4.3.0-3.2.5)

and 3D works fine. Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 8500, 9200, 9700 freeze Mandrake 10 with ATI's drivers make Linux - Hardware 17 08-06-2004 04:51 AM
Can't install ATI's drivers for my Radeon 9000 enigma Z Linux - Software 58 10-16-2003 11:37 AM
Problems w/ Radeon 9200 & ati's binary drivers zen_guerrilla Linux - Hardware 4 10-11-2003 01:44 PM
ATI's new Radeon drivers (8500) xeinsane Linux - Hardware 3 09-28-2003 04:48 PM
Radeon 9500 with Ati drivers Mr happy Linux - Hardware 39 09-08-2003 06:38 PM


All times are GMT -5. The time now is 03:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration