LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   R.A.T. 7 Mouse - Doesn't work properly at first, but restarting X makes it work (http://www.linuxquestions.org/questions/linux-hardware-18/r-a-t-7-mouse-doesnt-work-properly-at-first-but-restarting-x-makes-it-work-923040/)

spudgunner 01-10-2012 07:07 AM

R.A.T. 7 Mouse - Doesn't work properly at first, but restarting X makes it work
 
So I picked up a Cyborg R.A.T. 7 mouse a while back and have always had problems with it working in Linux. I first noticed it in Slackware, where when I first start X, the mouse will only be useful in the first windows that I open and won't work anywhere else. a Ctrl-Alt-Backspace to restart X makes it act like a normal mouse, so I didn't working about it too much. However, I later installed Sabayon as an experiment and noticed the exact same behaviour. How can I fix X (or Linux is general, although the problem seems more closely related to X) so that this mouse works without me having to restart X?

onebuck 01-10-2012 08:58 AM

Member response
 
Hi,

Do you have 'gpm' running? if so;
Quote:

excerpt from '/etc/rc.d/rc.gpm';

# There is another way to run GPM, where it acts as a repeater outputting a
# virtual MouseSystems mouse on /dev/gpmdata. This is useful for feeding
# gpm's data to X, especially if you've got a busmouse (in that situation X
# and gpm may not coexist without using a repeater). To try running a GPM
# repeater for X, change the gpm command line to look like this:
# /usr/sbin/gpm -R msc -m /dev/mouse -t imps2
# Then, make sure that the mouse configuration in your XF86Config file refers
# to the repeater device (/dev/gpmdata) and a MouseSystems mouse type. If you
# edit the file directly, you'll want the lines to look like this (minus the
# comment marks '#' shown here, of course):
#Section "Pointer"
# Protocol "MouseSystems"
# Device "/dev/gpmdata"
GPM & 'X' conflicts can occur if the 'rc.gpm' is not configured properly. I had issues with some early Logitech mice. As to your mouse, I would do a search for configs.

spudgunner 01-11-2012 07:23 AM

I will check that when I get home tonight.

spudgunner 01-13-2012 10:48 PM

So apparently Sabayon won't boot after the most recent update. But I appreciate the help, it should lead me in the right direction and is further ahead than I was before.


All times are GMT -5. The time now is 04:41 AM.