LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-19-2009, 10:15 AM   #1
Dan_471
LQ Newbie
 
Registered: May 2004
Distribution: Slackware 4.0
Posts: 11

Rep: Reputation: 0
Puppy, Ubuntu freeze during boot after adding an nvidia geforce mx440 pci card


Puppy and Ubuntu boot just fine using the onboard video "card" on the motherboard (Windows 7 boots with only 640 X 480 graphics). When I edit the bios so that the nvidia PCI card is detected and used, Puppy hangs during boot, just after "loading kernel modules". The final error message is "kernel panic - not syncing - attemped to kill init" . Ubuntu also hangs during boot, Windows loads fine and will use hi-res displays.

It would be great if I could use the nvidia card for everything.
suggestions? Thanks

Dell Optiplex GX270 desktop
nvidia geforce 4 mx440 pci card
grub bootloader
puppy 4.0
edubuntu 7.0
 
Old 03-04-2009, 12:54 AM   #2
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 961

Rep: Reputation: 51
Quote:
Originally Posted by Dan_471 View Post
Puppy and Ubuntu boot just fine using the onboard video "card" on the motherboard (Windows 7 boots with only 640 X 480 graphics). When I edit the bios so that the nvidia PCI card is detected and used, Puppy hangs during boot, just after "loading kernel modules".
My guess is that the kernel module for the onboard graphics chip is being used during boot and it's specifically for the onboard graphics chip. As soon as that module loads and the system tries to use it to drive the MX440 it's time to hit the big red switch.

What you could do is for now, remove the MX440, rejigger your BIOS settings to re-enable the onboard chip, and make sure you can reboot the system.

Once you're back to where you used to be, go into the system's video settings control panel and see what driver is being used. If it's a driver targetted for your onboard chip -- like some ATI-specific graphics hardware -- I'd override that and select some generic VGA or VESA driver and save the new settings into the Xorg.conf file. Make sure you test the new configuration before getting out of the configurator.

Then you can probably re-install the MX440, adjust your BIOS settings to disable the onboard graphics chip, and reboot. If all goes well, the MX440 will be getting used with the generic VGA or VESA driver.

If this works, you'll likely want to go to nVidia's web site and download a kernel module for the MX440. That card's old enough that you're going to have to get one of the "legacy" drivers. I have one of those cards (the AGP variant) in one of the systems here and it's works well on a fairly recent Linux release (OpenSUSE 11.0) running in a 1GHz PIII motherboard. It even handles some games okay with the nVidia driver 3D acceleration. I can post the exact driver version if you want though it's not too tough to read through the release notes to see what chipsets are support for the different driver versions. Be sure and grab a copy of the driver installation instructions. They're really not difficult to follow. Your distribution may even have a means of downloading the drivers using the standard software management tool (YaST, yum, whatever...).

Good luck...

--
RT
 
Old 03-04-2009, 01:36 AM   #3
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 961

Rep: Reputation: 51
Ack! I knew I should have double checked that before posting. (Guess I was sleepier than I thought.)

I was going to reply again once I checked to see what to change in SaX2 and, as it turns out, the card setting is not alterable. I'd bet the same is true for Slackware and, probably, Ubuntu as well.

Ignore my previous post's statement about changing the driver to something generic like VGA. You'll still need to remove the MX440 for now just so you have a working system on which we can get the nVidia card properly recognized.

It looks like you'll need to force the change by moving or renaming the current X configuration file -- under /etc/X11 on my system (YMMV) -- "xorg.conf" so that X won't be trying to load the onboard chip's driver.

Now... the best way to do this, IMHO, is to configure your system to boot up into level "3" so that the X Windows system won't start automatically. This involves changing a line in /etc/inittab. As a Slackware user, I'm guessing you know about this. (If not, give a holler.) Trying to change the low-level graphics configuration while actually running in a graphical environment is tough. Once you've got the system booting to level "3" and you have a command line login like you'd normally see if you press Ctrl-Alt-F1 (or -F2, etc.), you should be able to shutdown, re-install the MX440, and boot back up into level "3".

A question: what is the name of the X Windows configuration program on Slack? It might be something like "xorg -configure" but it's been a while since I've ran Slackware. (I know it doesn't require creating and editing your own X config files and risk toasting your monitor any more.)

Once we can get the system configured to boot into level "3" using the MX440, you should be able to login as root and run the X configuration to create a new "xorg.conf" file. Test it by issuing
Code:
startx 2>&1 | tee startx.log
If it doesn't work, you'll capture the error messages in the log file and can examine them, post them here, etc. (Well, actually, there'll be a LOT of messages in the file but, if all goes well, none of them should be error messages.) Once X is working, you can reconfigure /etc/inittab to have the system boot directly into level "5".


Cheers... (And sorry about the mis-information in my first post.)

--
Rick
 
Old 03-06-2009, 05:20 AM   #4
Dan_471
LQ Newbie
 
Registered: May 2004
Distribution: Slackware 4.0
Posts: 11

Original Poster
Rep: Reputation: 0
Hi rnturn,

My days have turned busy all the sudden, but when I get a chance I want to try your ideas. Thanks for the suggestions!
 
  


Reply

Tags
boot, freezes, geforce, nvidia


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound Puppy Linux 4.0 Asus m2npv-vm amd 64 nvidia geforce 6150 Bob Niemann Linux - Newbie 3 12-14-2008 06:06 PM
Trying to find where to download drivers for ASUS 6200 Nvidia Geforce card for ubuntu Slyth99 Ubuntu 1 09-29-2006 12:06 AM
help editing xf86config for nvidia geforce mx440 after installing nvidia driver linguist Linux - Newbie 11 06-13-2006 07:31 AM
Nvidia Geforce MX440-SE, Driving ME NUTS frog-newbie Linux - Hardware 2 09-07-2003 08:19 PM
system with Geforce mx440 and SCSI hangs at boot dudesinmexico Linux - Hardware 0 01-14-2003 11:39 PM


All times are GMT -5. The time now is 11:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration