LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 08-16-2004, 11:55 PM   #1
andy753421
Member
 
Registered: Apr 2004
Distribution: Gentoo
Posts: 65

Rep: Reputation: 15
problems with usb drives


i have a usb drive pluged into my computer and i have this line in the fstab

Code:
/dev/sda1   /mnt/usb   auto   defaults,users,noauto   0 0
now the first time i try mounting it it workes fine, but when i unmount it, remove the usb drive, and then put it back in and try mounting it again it gives me this error

Code:
/dev/sda1: Input/output error
mount: I could not determine the filesystem type, and none was specified
does anyone know why it would do that?
 
Old 08-17-2004, 03:30 AM   #2
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
Re: problems with usb drives

Quote:
Originally posted by andy753421
[B]i have a usb drive pluged into my computer and i have this line in the fstab

Code:
/dev/sda1   /mnt/usb   auto   defaults,users,noauto   0 0
Instead of mounting as filesystem auto try using vfat:
Code:
/dev/sda1   /mnt/usb   vfat   defaults,users,noauto   0 0
 
Old 08-17-2004, 10:52 AM   #3
andy753421
Member
 
Registered: Apr 2004
Distribution: Gentoo
Posts: 65

Original Poster
Rep: Reputation: 15
that gives me the error

Code:
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       or too many mounted file systems
when i type ps -A i have these two things in there that i though should have been truned off because i dont think they would be used anymore...

Code:
 1039 ?        00:00:00 usb-storage-0
 1040 ?        00:00:00 scsi_eh_1
 
Old 08-17-2004, 08:59 PM   #4
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
Run this command as root before and after you mount & unmount the drive for the first time:
Code:
file -Ls /dev/sda1
This should give you affermative output and tell you the type of drive it is.
 
Old 08-17-2004, 11:22 PM   #5
andy753421
Member
 
Registered: Apr 2004
Distribution: Gentoo
Posts: 65

Original Poster
Rep: Reputation: 15
hmm. i dont know, its working now, i rebooted and maybe that fixed it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems auto-mounting usb drives in kernel 2.6.13.3 dizzi Slackware 8 10-29-2005 02:41 PM
Any problems with USB-port PCMCIA cards and USB Floppy Drives? DreameR-X Linux - Laptop and Netbook 9 05-14-2005 02:37 PM
Problems Mounting USB drives plainkeyman Linux - General 5 10-08-2004 09:56 AM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
USB Drives and Sharing Problems mudelf Linux - Hardware 4 11-13-2003 02:58 AM


All times are GMT -5. The time now is 07:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration