LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-10-2004, 02:54 PM   #1
DarkUser247
LQ Newbie
 
Registered: Jan 2004
Location: Ballynahinch N'Ireland
Posts: 7

Rep: Reputation: 0
Exclamation Problems With Booting Windows XP Home and Mandrake 9.2 across 2 Hard disks


I have installed a few computers with Linux and they have all worked Brilliantly.

So I wanted to install it onto a friends computer which had Win XP Home on NTFS across 2 Hard drives and a third which needed Setup. So I ran the Mandrake 9.2 installation CDs
and went through the install (Worked without a glitch) I partitioned his third hard drive with the eee-old Fat32 and the usual 3 Linux Partitions ie:- JFS for "/",Swap and another JFS for the "/home". All went well untill I tried to boot win xp again and of course it didn't LILO was looking on HDC (The third Fat32 Drive Which had just been formated.) so as root I edited the /etc/lilo.conf and edit the HDA and the map to HDC1 and changed it to HDA and HDA1 which was the windows boot drive rebooted and then ran the lilo update program it worked fine but when I tried to boot windows i was left with a black screen with a blinking cursor, NO HARD DRIVE ACTIVITY and NO WINDOWS.

I checked in linux on the drives and all of the files in the Windows directory where there and all of the Docs where fine.

I think I may have maped wrongly but need some Expert advice...



AND THAT IS WHY I AM HERE!!!!

If any one could help it woul be apreciated. Thanks!

Last edited by DarkUser247; 02-10-2004 at 02:56 PM.
 
Old 02-10-2004, 04:33 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Given that the computer has XP with NTFS, I would try to restore the original MBR ( with fixmbr from XP repair console ) and then google for NT Linux Boot Howto. Basically, this involves writing LILO loader to your root partition, or the mbr area of the other disk, using the dd command to copy the first 256 bytes of this partition to a file on floppy, copying this file to C:\ and editing BOOT.INI.
This may all sound complicated, but it isn't. Basically, the NT loader program
will boot windows, or pass control to the Linux Loader.
I have XP/Mandrake9.2 with the XP residing on a RAID drive, and this is how I did it.
 
Old 02-10-2004, 04:50 PM   #3
DarkUser247
LQ Newbie
 
Registered: Jan 2004
Location: Ballynahinch N'Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
Right Ok I will try that thanks and have found the info on Google. One question though can i use a XP Pro Disk to fix the MBR of an XP Home Machine?
 
Old 02-10-2004, 05:58 PM   #4
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
More easily than a home disk. Just boot into it and select the recovery console. type fixmbr It'll ask which Windows installation to fix. You say that one and hit enter
Reboot. Windows...
 
Old 02-11-2004, 02:24 PM   #5
DarkUser247
LQ Newbie
 
Registered: Jan 2004
Location: Ballynahinch N'Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
Problems!!! I looked through the documentation I got through the search and follwed the instructions and got windows to start booting...

OR SO I THOUGH UNTILL BLUE SCREEN OF DEATH AND RE-START!

XP will start to boot or ask for the default of, safemode, safemode with networking or last none good registry(Which i have tryed them all) Windows simply doesn't work. I HATE WINDOWS XP!

COULD YOU HELP PLEASE!
 
Old 02-11-2004, 08:28 PM   #6
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by DarkUser247
Problems!!! I looked through the documentation I got through the search and follwed the instructions and got windows to start booting...

OR SO I THOUGH UNTILL BLUE SCREEN OF DEATH AND RE-START!

XP will start to boot or ask for the default of, safemode, safemode with networking or last none good registry(Which i have tryed them all) Windows simply doesn't work. I HATE WINDOWS XP!

COULD YOU HELP PLEASE!
Your best solution:

But seriously. Choose to boot with safe mode and do a chkdsk from a command prompt and see if that fixes things. If safe mode lets you, right click on "My Computer" and select properties and find the checkbox that deals with how Windows handles errors. Uncheck the "reboot on error" so that you can find the blue screen message. You can write it down and google the problem. You may want to try to rebuild the registry with the scanreg command (I forget the switch, though - cos I don't care much any more - if my winxp dies, its gone for good - just waiting for a reason to install Gentoo...and space will be the reason.heh heh)
 
Old 02-17-2004, 03:19 PM   #7
DarkUser247
LQ Newbie
 
Registered: Jan 2004
Location: Ballynahinch N'Ireland
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks Lads Got the problem sorted!

Followed instructions and got the machine sorted.

The guy I was doing it for is quite impressed by linux (OF COURSE!)

Sorry for the late reply!

Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Multi-booting with SuSE 9.2, Windows x64 and XP on two hard disks... nemofreak Linux - General 4 06-19-2005 09:41 PM
Dual Booting Windows XP and Mandrake 10.0/10.1 Problems Blade44 Mandriva 7 01-26-2005 08:47 AM
Installation Disks not recognized as official disks when booting with floppy coal-fire-ice Mandriva 13 12-09-2004 04:29 PM
dual boot xp and mandrake 10.0 on two different hard disks bmxpunk Mandriva 9 04-25-2004 09:04 AM
Problems with dual booting RedHat 8.0 and WinXP (both off separate hard disks) DaveS Linux - General 3 03-10-2003 06:43 AM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration