LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-24-2004, 06:35 PM   #1
akay
LQ Newbie
 
Registered: Nov 2004
Posts: 20

Rep: Reputation: 0
problems mounting a cdrom in redhat (from rockscluster.org OS install) >>> bad superblock


I am trying to mount a cd after newly installing a redhat operating system (redhat 3.2.3-42). This operating system comes from a cluster queing system called rocks. I wrote a cd with files that I wished to run on this machine. I checked the cd and it's fine (all contents are there and work). When I try to mount I use:

mount -t iso9660 /dev/hdc /mnt/cdrom

hdc is designated as the cdrom in my case

I get the following error:

mount: wrong fs type, bad option, bad superblock or too many mounted file systems (could this be the IDE device where in fact you use ide-scsi so that sr0 or sda or so is needed)

I've tried several things to solve this

1. I editted the /etc/fstab file so that the line for the cdrom reads
/dev/hdc /mnt/cdrom iso9660 noauto,user,ro,exec 00

2. I edited the /etc/rc.d/rc.local file so that the last line reads:
/sbin/modprobe ide-scsi

3. I checked that the driver was a "master" and that it is connected to the secondary IDE bus port on the mother board

Any other advice from anyone would be greatly appreciated!!
 
Old 11-24-2004, 06:45 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
You shouldn't specify /dev/hdc to mount fron a cd/dvd..

Let it decide which method it's going to use..

Try mount /mnt/cdrom
This uses the settings from /etc/fstab..

Next is to change /etc/fstab to read..
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro,exec 00
and try again

And finally, do cdrecord -scanbus and see if the scsi system can find the drive
and then try mounting with..
mount /dev/sr0 /mnt/cdrom
or..
mount /dev/sda /mnt/cdrom
 
Old 11-24-2004, 07:00 PM   #3
akay
LQ Newbie
 
Registered: Nov 2004
Posts: 20

Original Poster
Rep: Reputation: 0
Thanks for the reply. I tried all of the suggestions. when I did /mnt/cdrom I get the same error. I changed the fstab file like you suggested with no luck. Then I did a cdrecord -scanbus and the drive was found( this is the same drive from which I did the OS install). Finally, srO and sda do not exist.

Any other suggestions?

Thanks again.
 
Old 11-24-2004, 07:18 PM   #4
akay
LQ Newbie
 
Registered: Nov 2004
Posts: 20

Original Poster
Rep: Reputation: 0
Another thing that I tried was to edit the fstab file so that the cdrom was mounted automatically upon reboot. During the boot process it said something like /mnt/cdrom can't boot superblock. Does this give any clues?
 
Old 11-25-2004, 07:04 AM   #5
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Ok.. if cdrecord can find the drive it can also read the disk contents..

So do..
cdrecord -atip dev=0,0,0 and
cdrecord -toc dev=0,0,0

See man cdrecord for descriptions.
This will prove the cd is readable or not in your drive.

If it's readable, you will need to find the /dev/s~~ name so you can talk to it.
Usually, (at least in a LILO config) you can add append = "/dev/hdc=ide-scsi" to the boot parameters to make sure the scsi drivers are loaded before booting continues.
I'm not sure how GRUB handles it..

Last edited by peter_robb; 11-25-2004 at 07:06 AM.
 
Old 11-25-2004, 05:32 PM   #6
battousai9439
Member
 
Registered: Jul 2004
Distribution: Ubuntu 10.04
Posts: 32

Rep: Reputation: 15
I'd doubt that this is the problem, but...

Whenever i get this error, I realized that I forgot to put a disk in the drive!
 
Old 12-01-2004, 01:04 PM   #7
akay
LQ Newbie
 
Registered: Nov 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I used both cdrecord commands and they both seem to say that the drive is fine. The cd mounts in other cdroms. I tried the append command but still got the same error.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 12:37 PM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy) SpItoS Mandriva 14 11-12-2004 03:27 PM
"...bad superblock" error when mounting cdrom Trinity22 Linux - Hardware 4 09-19-2004 08:59 PM
wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file sy TheCyberDude Linux - Software 1 02-11-2002 01:44 PM


All times are GMT -5. The time now is 03:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration