LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-08-2004, 09:56 PM   #1
Young Padawan
LQ Newbie
 
Registered: Nov 2004
Distribution: Mandrake 10.1 Community w/ WinXP dual boot
Posts: 14

Rep: Reputation: 0
Problems installing drivers for ATI 9600XT


Hello everybody, I just am starting with Mandrake 10.1 and am trying to get my video drivers up and running, I am using the generic drivers but as I plan on using this system primarily for games I want to install the proprietary drivers. I have followed the instructions in TheRepublican's HOWTO (cant give the url, the forum wants me to have at least 5 posts but it is here on Linuxquestions.org, sry) here but when i run sh check.sh I get the following

Quote:
[root@localhost Desktop]# sh check.sh
=====================================================================
ATI Technologies
=====================================================================
Your possibly not running this script from the console
or maybe you simply dont have the console ownership.
Unable to determine XFree86 Version. Stopping now.

[root@localhost Desktop]#
I am running this from the console BTW

However I assue that since I have a rather new distro that I am going to be using XFree86 version 4.3.0

Anyway. I continued on this assumption and continued to install. I followed all the prompts without a problem but when I rebooted I could not log in to KDE. I dont know enough to change the driver from the console so I just reinstalled and am on the default drivers again.

I would like to set up 2 monitors but as yet have not set up one Any advice?
 
Old 11-09-2004, 09:05 AM   #2
Mystypiy
Member
 
Registered: Sep 2004
Location: Richmond, Virginia
Distribution: Suse 9.1 Pro
Posts: 53

Rep: Reputation: 15
Actually that version of Mandrake uses xorg and not xfree86, so that is why you are having a problem.
 
Old 11-09-2004, 03:15 PM   #3
Young Padawan
LQ Newbie
 
Registered: Nov 2004
Distribution: Mandrake 10.1 Community w/ WinXP dual boot
Posts: 14

Original Poster
Rep: Reputation: 0
Ahhhh, I have no idea what the difference is but I think I'll take your word for it. THX

So if it isnt using XFree then I should just stick with the generic driver? ATI only provides support for XFree on their website. Is there another driver floating around I should try out? The card is actually built by Asus, I just looked at thier site and they have no mention of Linux drivers that I could find. Their USA server is down so I was looking at a forgein site but if they dont have it in the Canadian mirror then I wouldnt think there is one on the USA mirror either.
What driver should I use for gaming then?
 
Old 11-10-2004, 08:25 AM   #4
Mystypiy
Member
 
Registered: Sep 2004
Location: Richmond, Virginia
Distribution: Suse 9.1 Pro
Posts: 53

Rep: Reputation: 15
You might want to check this thread: http://www.linuxquestions.org/questi...hreadid=240256

This thread is also helpful:
http://www.linuxforums.org/forum/top...8-0-asc-0.html

It seems that the xfree86 4.4 drivers work with xorg version 4.4. Just make sure you have the version that matches up with your version of xorg.

Hope this helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Correct installing procedure, but no 3d Accel with ATI 9600XT Darthdan Fedora 2 02-01-2005 01:44 PM
Questions / Problems installing ATI 9600xt dimgr Debian 1 07-27-2004 08:38 AM
More problems installing ATI drivers.. adamc91115 Linux - Hardware 6 05-09-2004 01:39 PM
problems with ati drivers (NOT installing) rymdninja Linux - Software 1 04-27-2004 06:52 AM
Has anyone able to install ATI Radeon 9600XT drivers on RedHat 9? DriveMeCrazy Red Hat 3 03-25-2004 10:55 AM


All times are GMT -5. The time now is 07:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration