LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-10-2007, 09:34 PM   #1
Miki0
LQ Newbie
 
Registered: May 2007
Posts: 5

Rep: Reputation: 0
Problems installing ATI RADEON drivers


Hi everybody I am new to this forum and to Linux to
fey days I got open suse 10.2 and I want to install the drivers for the
VGA ATI RADEON X850 XT PE
I downloaded this file form ATI At-driver-installer-8.36.5-x86.x86_64.run
when I start the file should give me a .rpm file which should be the driver
inserted it gives me this in the terminal

Created directory fglrx-install.y24539
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.36.5....................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: X.Org 7.1.x 64-bit


and everything goes fine until this message pops up

You need to run this installer as the
super-user


so I have no idea what to do and I didn`t sow anywhere login as administrator(root)
I know I am doing something wrong so Please any suggestions are welcomed
 
Old 05-10-2007, 09:40 PM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
when you launch the terminal, you need to type this first:
su -

It will then request your root password.

That's it; now you are super user.
 
Old 05-13-2007, 12:07 PM   #3
Miki0
LQ Newbie
 
Registered: May 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the replay jay73 i have just tried this and after i type su -
it give`s me password: but I can`t right anything from the keyboard
 
Old 05-13-2007, 02:57 PM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You mean you don't get to see the password as you type it? That's normal behaviour, Linux will hide it from you. Just type it in and press enter; if you entered it correclty, the terminal will pop up a new prompt, if not it will tell you that you that the password is wrong.
 
Old 05-14-2007, 04:09 PM   #5
Miki0
LQ Newbie
 
Registered: May 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for the help dude i finally got it installed but still I have pour 3D acceleration I guess I`ll wait for better drivers, you know it is my first time doing this on Linux it is a lot different than windows mach more difficult dhow but i guess all the beginnings are like that anyways thanks for the Help

great forum
 
Old 05-14-2007, 04:13 PM   #6
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Maybe there is a solution for the poor 3D.

Run this in a terminal:

glxinfo | grep direct

and check whether direct rendering is enabled or not.
 
Old 05-14-2007, 04:23 PM   #7
wendea
Member
 
Registered: Mar 2007
Distribution: Fedora
Posts: 81

Rep: Reputation: 15
ati usually dont work that great for linux. At least ive noticed that with my different ati cards.
 
Old 05-14-2007, 04:26 PM   #8
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I know, I'm using ATI myself - but beginners often run the card without enabling direct rendering - that does make a huge difference.
 
Old 05-15-2007, 05:36 AM   #9
Miki0
LQ Newbie
 
Registered: May 2007
Posts: 5

Original Poster
Rep: Reputation: 0
I am sorry for replying this slow guys but I will defiantly reply, Thanks for the tip jay 73 I sure would like to true the command you gave me but this is what happened to me after enabling desktop 3D effects, I see the loading screen where all the desktop personal settings load: themes,backgrounds,bla, bla, and after this the screen goes blank but the funny thing is that the computer is actually responding and I know this because when i press(not hold) the power but on the computer it automatically shuts down, I have trued to run Linux in fail safe mode no result it can`t even start in this mode so if u can shed Sim light on how to load my
last good configuration or something that will help me to run the system on low resolution so I can shut down this 3D effect it is going to be of great help, or I will reinstall the system but that is last resort,

P S wendea u are right man but I just wonted to see how it looks that`s all I guess Linux is more for work and if I get this fixed i wont bother with the 3D support to much
 
Old 05-15-2007, 08:16 AM   #10
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Hit ctrl + alt + backspace when the screen goes blank.
Log in as "root" when you get a command line and submit your root password when requested.
You will have to disable whatever caused the crashes. Did you enable beryl, compiz, emerald? The safest option would be to try and uninstall all of them by running these commands:
yum -y remove beryl
yum -y remove emerald
yum -y remove compiz
If it says that one or more of those are not installed, then they aren't - leave it at that and get on with the rest.
When you're done, type in:
startx
If that didn't solve it, it could get pretty complicated, I'm afraid.

Anyway, here' a hint : do not even try to run 3D with the fglrx driver installed! Fglrx doesn't support 3d; if you do want all those nice effects, you first have to configure XGL (or use the open source radeon driver - but it's less powerful than fglrx and for all I know it may not (and probably does not) support ATI850). Here's an article which explains how to set up XGL:
http://nicofo.tuxfamily.org/dotclear...eryl-on-fedora

Last edited by jay73; 05-15-2007 at 08:17 AM.
 
Old 05-15-2007, 02:55 PM   #11
Miki0
LQ Newbie
 
Registered: May 2007
Posts: 5

Original Poster
Rep: Reputation: 0
and I am back where I was OK the ctrl+alt+backspace didn`t work so I reinstall the whole thing only now I used KDE I downloaded the File from ati (ati-driver-installer-8.36.5-x86.x86_64.run) and now I cant even get to the .rpm part when I try to start the file it gives me this

The file file:///home/Mikio/Desktop/ati-driver-installer-8.36.5-x86.x86_64.run is a binary, saving it will result in a corrupt file.
 
Old 05-15-2007, 09:53 PM   #12
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That can happen when you try to run the file by clicking on it; you should use the terminal instead. I think you'll need to search google for the proper way to install the ATI; I got out of Suse way too long ago to remember all the fine details .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ATI Mobility Radeon 7500 Drivers The_Awesome Linux - Hardware 1 07-09-2006 01:47 PM
installing ATI radeon drivers Niflheim Linux - Newbie 3 03-18-2006 08:38 AM
Trouble installing ATI Radeon 9600 Drivers in Mandrake RAMMS+EIN Linux - Hardware 2 05-27-2005 04:58 PM
Problems after installing ATI radeon drivers in Mandrake 10 Cetrocet Mandriva 8 05-21-2004 05:32 PM
Installing ATI Radeon video drivers on Redhat Advanced Server Darrell22 Linux - Hardware 0 01-25-2004 01:59 PM


All times are GMT -5. The time now is 02:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration