LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-25-2005, 02:54 PM   #1
sn_piranha
LQ Newbie
 
Registered: Jul 2004
Location: Constanta, Romania
Distribution: Slackware 10.0
Posts: 26

Rep: Reputation: 15
Problems installing Ati Radeon 9200 proprietary driver in Slack 10


When I try to rpm -Uh --force fglrx_6_8_0-8.8.25-1.i386.rpm the driver I get the following:

error: Failed dependencies:
/bin/sh is needed by fglrx_6_8_0-8.8.25-1
libX11.so.6 is needed by fglrx_6_8_0-8.8.25-1
libXext.so.6 is needed by fglrx_6_8_0-8.8.25-1
libc.so.6 is needed by fglrx_6_8_0-8.8.25-1
libc.so.6(GLIBC_2.0) is needed by fglrx_6_8_0-8.8.25-1
libc.so.6(GLIBC_2.1) is needed by fglrx_6_8_0-8.8.25-1
libc.so.6(GLIBC_2.1.3) is needed by fglrx_6_8_0-8.8.25-1
libdl.so.2 is needed by fglrx_6_8_0-8.8.25-1
libdl.so.2(GLIBC_2.0) is needed by fglrx_6_8_0-8.8.25-1
libdl.so.2(GLIBC_2.1) is needed by fglrx_6_8_0-8.8.25-1
libm.so.6 is needed by fglrx_6_8_0-8.8.25-1
libm.so.6(GLIBC_2.0) is needed by fglrx_6_8_0-8.8.25-1
libpthread.so.0 is needed by fglrx_6_8_0-8.8.25-1
libpthread.so.0(GLIBC_2.0) is needed by fglrx_6_8_0-8.8.25-1
librt.so.1 is needed by fglrx_6_8_0-8.8.25-1
librt.so.1(GLIBC_2.2) is needed by fglrx_6_8_0-8.8.25-1
libstdc++.so.5 is needed by fglrx_6_8_0-8.8.25-1
libstdc++.so.5(CXXABI_1.2) is needed by fglrx_6_8_0-8.8.25-1
libstdc++.so.5(GLIBCPP_3.2) is needed by fglrx_6_8_0-8.8.25-1

I have all the stuff required installed (it is a full slack installation).
Thanks in advance.
 
Old 01-25-2005, 06:54 PM   #2
ilubtofart
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 27

Rep: Reputation: 15
as root,
rpm2tgz fglrx_6_8_0-8.8.25-1.i386.rpm
installpkg fglrx_6_8_0-8.8.25-1.i386.tgz
cd /lib/modules/fglrx/build_mod
sh make.sh
cd ..
sh make_install.sh

then run fglrxconfig as user.
 
Old 01-26-2005, 06:37 AM   #3
sn_piranha
LQ Newbie
 
Registered: Jul 2004
Location: Constanta, Romania
Distribution: Slackware 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
I'm writing this from links, so I guess it doesn't work . I followed all the steps described in a tutorial on this forum, but the result was a X server that wouldn't start. The warning I get is:
(WW) fglrx: no matching Device section for instance (BusID PCI:1:0:1) found.
Symbol ...bla bla
I must have done something wrong ...
 
Old 01-27-2005, 11:44 AM   #4
ilubtofart
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 27

Rep: Reputation: 15
do you have xorg 6.8?
if not, then get xorg 6.8 :]
if yes, then make sure you run fglrxconfig and move it into /etc/X11/ , backup you xorg.conf then rename XF86Config-4 as xorg.conf, well i dont know why it made a XF86Config-4 if i downloaded it for xorg6.8 but hey, it's ATi =/.
 
Old 02-12-2005, 03:46 PM   #5
iyobe
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Rep: Reputation: 0
i've installed fglrx and run fglrxconfig. after finishing the configuration, it wrote XF86Config-4 file in etc/X11 then like you said i changed the file name to xorg.conf. after renameing the file i tried to start x window but the outcome was black screen . what did i do wrong ? i've got the xorg ati installation form www.ati.com and configured it but stile the result didn't work.
ps
Iyobe
 
Old 02-12-2005, 03:59 PM   #6
sn_piranha
LQ Newbie
 
Registered: Jul 2004
Location: Constanta, Romania
Distribution: Slackware 10.0
Posts: 26

Original Poster
Rep: Reputation: 15
Ati's Linux drivers are crap!
I've just installed Slackware 10.1, with xorg 6.8 and all that stuff.
The driver works for glxgears and some gl screensavers but not for any games (doom3 for example).
Also when I try to restart X the computer freezes (come on people, lets get serious A LINUX system shouldn't do that!!! that's wizouze's buisiness!)
PS: when I start Doom3 the computer freezes in a couple of secs.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ati Radeon 9200 SE (xorg 6.8.0) driver (HELP please!) apinta10 Slackware 22 10-11-2005 03:22 AM
ATI Radeon blurry distored in X (proprietary driver) titan100 Linux - Hardware 1 08-26-2005 09:20 AM
ATI radeon 9000 mobile. proprietary driver help. claybub Linux - Hardware 1 02-04-2005 07:00 PM
Radeon 9200 proprietary driver w/ RH 9.0 jk21 Linux - Newbie 7 09-03-2004 09:16 PM
ATI Radeon 9200 on Debian, driver problems mrnicke Linux - Hardware 6 03-19-2004 12:46 PM


All times are GMT -5. The time now is 02:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration