LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Problem With Video Driver CW1MFX-B Vaio (http://www.linuxquestions.org/questions/linux-hardware-18/problem-with-video-driver-cw1mfx-b-vaio-828940/)

pedram 08-28-2010 01:16 AM

Problem With Video Driver CW1MFX-B Vaio
 
Hello Every Body!
I am new to this site and to Linux too!
I have a problem with my notebook Sony Vaio CX1MFX-B.

I have already install RHEL on my notebook, but there is a problem with my video card, it is NVIDIA GeForce GT 230M. i have downloaded it's driver from NVIDIA website :
http://www.nvidia.com/object/linux-d...44-driver.html

After i install it (logined as root) :
init 3
./NVIDIA-Linux-x86_64-256.44.run
init 5

my monitor displays 6 in one! i will attach you the picture of my display as soon as possible.
Thank you in advanced.

pedram 08-28-2010 02:38 AM

And this is the picture of what i see on my screen :

http://i36.tinypic.com/343rqzp.jpg

mrmnemo 08-28-2010 02:48 AM

hi,

can you post the output of the following command ( just copy and paste in your terminal) :
Code:

cat <(uname -a; lspci -vv | grep nV; lsmod | grep 'nv|nV|nouveau')
The above command will show the following things
  1. the kernel version
  2. if you do indeed have a nvidia card and installed and itvendor number
  3. what nvidia driver is loaded currently

mrmnemo 08-28-2010 03:06 AM

After looking at your screen image you may need to press "ctrl+alt+f2" and log in to be able to get much use out of your box. at least you will be able to run those commands. You will also be able to get rid of the nvidia driver so you can get a functioning desktop back.

pedram 08-29-2010 02:22 AM

thank you for your response,
Ok, i have done it and here is what it said :

"Linux localhost.localdomain 2.6.9-89.ELsmp#1 SMP Mon Apr 20 10:33:05 EDT 2009 x86-64 x86_64 x86_64 GNU/Linux
01:00.0 VGA Compatible controller:nVidia Corporation:Unknown device 0a2a (reva2)(prog-if 00 [VGA Controller])
01:00.1 Audio Device:nVidia Corporation:Unknown device 0be2 (reva1)"

And i have attached you two other pictures, may be they can help you diagnosis my problem. it is really critical!

http://i37.tinypic.com/nnsk1g.jpg
http://i34.tinypic.com/mcwxhv.jpg

mrmnemo 08-29-2010 12:54 PM

ok,

so I guess you ran the commands from a prompt WITH OUT X correct. Either way, run the following:
press the keys CTRL+ALT+F2
  1. press the keys CTRL+ALT+F2
  2. run the same command you installed the driver with but append --uninstall to the end.
I will check later today to see if you got that part done. After you get it removed, check into to setting up the repos to use the package maintainers version. I would think that a fedora package would work with rhel.

pedram 08-30-2010 01:11 PM

I dont undestand this :
"check into to setting up the repos to use the package maintainers version. I would think that a fedora package would work with rhel"

But i have removed it, what should i do next?

mrmnemo 08-30-2010 02:08 PM

Hi,

You need to add some "repos", or locations that provide NONFREE stuff for your disto; in your case, go and check this site out. AFTER you get rpmfusion installed run the following command:
Code:

su -c 'yum install kmod-nvidia'
Let me know how it goes.

pedram 08-30-2010 03:08 PM

Ok ,Tanks, I will do it and i will inform you Tomorrow ;)

pedram 08-30-2010 03:21 PM

It didn't installed, Here is the error :

http://i34.tinypic.com/5yxmae.png

Where an I download the packages?

mrmnemo 08-30-2010 05:42 PM

click here

THEN

click here

THEN

run
Code:

su -c 'yum install kmod-nvidia'

pedram 08-31-2010 12:47 AM

Ok, I can install The .rpms
but the instruction you write above didn't work!
again i have a picture for you! :D
http://i35.tinypic.com/nmgv2x.png

mrmnemo 08-31-2010 11:21 PM

First:

What didnt work? The yum command or the links to set up the repos?

please post results of
Code:

locate yum && locate rpm && cat /proc/version
I have no idea why yum didnt work.

However, you can alays try
Code:

rpm -ivh kmod-nvidia
so, rather than post pics, could you just post the FULL output of the commands. It will go a long way in my trying to help you.8))

pedram 09-02-2010 01:34 AM

I can download the .rpms and i have installed them, but my yum command did not work and i dont know why. OK man, thank you a lot for helping me ;). i will do it and tell you the results.

John VV 09-02-2010 02:40 AM

i take it this is a not paid for rhel5 ?
if so yum will not work ( it can be hacked) until YOU PAY FOR RED HAT
rhel is NOT FREE

please pay for a licens and access to the rhn
then you can install the non free repos for the nvidia driver

If you do not intend to pay for it
please install the comunity supported version CentOS

also be warned rhel /cent are meant to run on servers and do not work well on laptops, there were NEVER designed for that .


All times are GMT -5. The time now is 08:11 AM.