LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-15-2013, 05:13 AM   #1
HajdukJanko
Member
 
Registered: Sep 2009
Distribution: openSuSE 12.2 LXDE
Posts: 47

Rep: Reputation: 0
Problem with printer installation (Canon LBP-800)


Hello there!

I'm trying to install Canon LBP-800 printer and there are some troubles. I've downloaded driver and start installation.

After make output is like this:
Code:
gcc  -O2 -s -Wall \
errcapt.c bmcapt.c lbp800.c \
-l cups -o bin/Release/lbp800
gcc  -O2 -s -Wall \
errcapt.c pport.c timcapt.c llcapt.c pkcapt.c hlcapt.c parcapt.c \
-l cups -o bin/Release/parcapt
But after make install, there are some errors:
Code:
gcc  -O2 -s -Wall \
errcapt.c bmcapt.c lbp800.c \
-l cups -o bin/Release/lbp800
gcc  -O2 -s -Wall \
errcapt.c pport.c timcapt.c llcapt.c pkcapt.c hlcapt.c parcapt.c \
-l cups -o bin/Release/parcapt
install -s -m a=rx bin/Release/lbp800 /usr/bin
install -m a=rx lbp800-print /usr/bin
install -m a=r ppd/Canon-LBP-800.ppd /usr/share/ppd/custom
install: cannot create regular file ‘/usr/share/ppd/custom’: No such file or directory
make: *** [install] Error 1
I'm using OpenSuSE 12.2 and krpmbuilder, checkinstall and cups are installed.

Can anyone tell me what to do?
Thanks anyway!

Last edited by HajdukJanko; 05-15-2013 at 04:08 PM.
 
Old 05-15-2013, 01:32 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,799

Rep: Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704Reputation: 1704
you need to be root to make a folder in " /usr/share/ppd/custom"

as a normal user you run "./configure" -- if needed
as a normal user you run "make" as a normal user
BUT
you run " make install" as root

ALSO be advised
OpenSUSE12.1 is now "End of Life" as of today
SEE: "OpenSUSE lifetime"
http://en.opensuse.org/Lifetime

time to install OpenSUSE 12.3
 
Old 05-15-2013, 04:10 PM   #3
HajdukJanko
Member
 
Registered: Sep 2009
Distribution: openSuSE 12.2 LXDE
Posts: 47

Original Poster
Rep: Reputation: 0
I've done exactly as you said and got this problem.

P.S.
And I checked I am running OpenSuSE 12.2
Thanks for advice anyway!

Last edited by HajdukJanko; 05-15-2013 at 04:14 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Canon LBP-800 on Linux (OpenSuSE 11.2) HajdukJanko Linux - Hardware 19 04-23-2014 12:24 PM
Installation of Printer Canon LBP 2900B mksundaram Linux - Newbie 3 11-08-2011 11:22 AM
Canon LBP 800 compatible w/ Linux or not? exit3219 Linux - Hardware 7 06-16-2005 06:14 AM
Using a printer (Canon LBP-800) Lead Expression Linux - Newbie 3 01-15-2005 02:20 PM
Canon LBP-800, will not work AT ALL! hass Linux - Software 1 10-23-2001 10:15 AM


All times are GMT -5. The time now is 08:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration