LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Problem with NVidia (http://www.linuxquestions.org/questions/linux-hardware-18/problem-with-nvidia-830774/)

dakochan 09-07-2010 08:32 AM

Problem with NVidia
 
Hi,

I'm using Sony Vaio VPCCW26FG (CW Series). It's graphic card is NVidia GeForce GT 330M. I use Ubuntu 10.04 32-bit as my operating system, dual boot with windows 7.
Recently I installed new driver from NVidia 256.53, but looks like this driver is not so stable on my notebook.
Sometimes the NVidia driver is successfully loaded, but sometimes its failed to load. (note: in windows 7 the graphic card has no problem)

This is the last few lines of log message from Xorg.0.log:

Quote:

(**) Sep 06 22:25:38 NVIDIA(0): Enabling RENDER acceleration
(II) Sep 06 22:25:38 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Sep 06 22:25:38 NVIDIA(0): enabled.
(EE) Sep 06 22:25:39 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.
(EE) Sep 06 22:25:39 NVIDIA(0): Please check your system's kernel log for additional error
(EE) Sep 06 22:25:39 NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
(EE) Sep 06 22:25:39 NVIDIA(0): README for additional information.
(EE) Sep 06 22:25:39 NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

ddxSigGiveUp: Closing log
If I use lspci I get:
Quote:

$ lspci | grep nVidia
01:00.0 VGA compatible controller: nVidia Corporation Device 0a2b (rev a2)
01:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)
I don't know what is the problem. Please help...

Regards,
DakoChan

kilgoretrout 09-07-2010 11:27 AM

Is there anything in /var/log/kern.log that would shed some light on what's going on? I've seen others reporting problems with this driver as well so I suspect it's just an upstream issue with nvidia or some interaction with the driver and the kernel you are using. You probably want to downgrade to 256.44; that seems to fix things for most people encountering problems with the new driver.

tredegar 09-07-2010 11:27 AM

I had to blacklist the nouveau driver, then install the NVIDIA driver.

To blacklist it add the following to /etc/modprobe.d/blacklist.conf
Code:

blacklist nouveau
Then reboot, and re-install the NVIDIA driver.

dakochan 09-08-2010 09:47 AM

Quote:

Originally Posted by kilgoretrout (Post 4090460)
Is there anything in /var/log/kern.log that would shed some light on what's going on? I've seen others reporting problems with this driver as well so I suspect it's just an upstream issue with nvidia or some interaction with the driver and the kernel you are using. You probably want to downgrade to 256.44; that seems to fix things for most people encountering problems with the new driver.

This is what I get in the /var/log/kern.log:
Code:

$ cat kern.log | grep nvidia
Sep  7 21:10:41 WhiteTux kernel: [  20.055223] nvidia: module license 'NVIDIA' taints kernel.
Sep  7 21:10:41 WhiteTux kernel: [  21.829446] nvidia 0000:01:00.0: setting latency timer to 64
Sep  8 20:15:29 WhiteTux kernel: [  20.420446] nvidia: module license 'NVIDIA' taints kernel.
Sep  8 20:15:29 WhiteTux kernel: [  22.182150] nvidia 0000:01:00.0: setting latency timer to 64
Sep  8 20:16:42 WhiteTux kernel: [  20.611969] nvidia: module license 'NVIDIA' taints kernel.
Sep  8 20:16:42 WhiteTux kernel: [  21.561322] nvidia 0000:01:00.0: setting latency timer to 64

I don't see irregularities in the log file.

Before I installed version 256.53, I used 256.44, but it has the same problem. That was why I installed version 256.53 by hoping the problem fixed. Too bad, it's not.

Regards,
DakoChan

dakochan 09-08-2010 09:51 AM

Quote:

Originally Posted by tredegar (Post 4090461)
I had to blacklist the nouveau driver, then install the NVIDIA driver.

To blacklist it add the following to /etc/modprobe.d/blacklist.conf
Code:

blacklist nouveau
Then reboot, and re-install the NVIDIA driver.

I disable the nouveau driver in grub:
Code:

menuentry 'Ubuntu, with Linux 2.6.32-24-generic' --class ubuntu --class gnu-linux --class gnu --class os {
        recordfail
        insmod ext2
        set root='(hd0,6)'
        search --no-floppy --fs-uuid --set d9772b68-31fb-4b78-b1c4-c592dc5675c1
        linux        /boot/vmlinuz-2.6.32-24-generic root=UUID=d9772b68-31fb-4b78-b1c4-c592dc5675c1 ro nouveau.modeset=0  quiet splash
        initrd        /boot/initrd.img-2.6.32-24-generic
}

Is it ok to do this way?

Regards,
DakoChan

tredegar 09-08-2010 03:29 PM

Quote:

I disable the nouveau driver in grub....
Is it ok to do this way?
I don't know.

To be certain, I'd suggest you blacklist it, then reboot, and then reinstall the nvidia driver.

Have you checked on the nvidia site to make sure you are using the correct driver version for your nidia hardware?

dakochan 09-09-2010 08:04 AM

Yes, the driver version is correct.
Maybe I follow your suggestion to blacklist nouveau driver in blacklist.conf.

Thanks.


All times are GMT -5. The time now is 11:43 AM.