LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 02-27-2007, 12:11 PM   #1
Jamamp1
LQ Newbie
 
Registered: Sep 2006
Posts: 5

Rep: Reputation: 0
Problem with monitor not displaying in Ubuntu and Mandriva


I am using a MAG Innovision 19" LDC monitor, model LT926WB. My video card is a Geforce 6600GT. I spent nearly all day trying to install Linux, but I never really had much luck.

On Ubuntu, 6.06 and 6.10, I'm not even able to install it. I boot from CD and it goes to a monitor message "MODE NOT SUPPORTED". So I can't even get to the installation point on that one. I personally think it might be the monitor, because I was able to install it when I had an old 17" CRT.

On Mandriva Free 2007, I get through the installation to the point where I chose to configure my display, but none of the options work. It has a menu where I can choose my monitor model, and my model isn't listed. Every time I test it, it brings up a page with a ton of different colors in itty-bitty blocks. So no real luck there. But at least in Mandriva, I have the option to go into text mode (it defaults to that since the X server won't start due to the graphical mishaps). So I think I have the option to maybe edit the xorg.conf file, and that could possibly resolve the problem.

I've been reading about this issue (actually someone had nearly the exact same problem on this forum, but no resolution was found). I was hoping some tips or clue if possible. I'm at work right now, so I'm sorry if I seem to be a little distracted. I will get any and all the information you guys might request. It seems so easy, but there are little things that always hold me up on it, including that stupid Nvidia card! lol

I appreciate any help that can be given.
 
Old 02-28-2007, 09:23 PM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Ho, another victim. I had the very same happening to me when I installed Mandriva, PCLinuxOS, Fedora, Sabayon and Suse. Only good old Debian didn't pull that one on me.

Cause: misconfigured xorg.conf.

Solution: reconfigure xorg.conf.

Procedure: bring up the xorg.conf file in vi and edit to reflect the proper values.
 
Old 03-01-2007, 11:32 AM   #3
Jamamp1
LQ Newbie
 
Registered: Sep 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I'll give that a shot when I get home and post about the problem. Maybe this thread could help someone else too. Pretty much I tried Mandriva, Ubuntu, and openSUSE after this thread to no avail. I went back to XP!

I've printed out quite a bit of documentation on xorg.conf, and I think I might know how to fix the problem, but I'm not going to know for sure until I test it. I'll just dual-boot my system this time, just in case it doesn't work, I can use XP and run a distro as a virtual machine (another learning experience). But I haven't given up yet, I'll post the results as soon as I can.

Thanks!
 
Old 03-01-2007, 12:06 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Moved: This thread is more suitable in Linux Hardware and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 03-01-2007, 12:13 PM   #5
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
The easiest solution using Mandriva would be to boot into failsafe mode, log in as root with root password and then type
/usr/X11R6/bin/xorg-configure

I'm not so sure about that last bit, if you need to make certain just type:
cd /usr/X11R6/bin
Then type: ls
If you see anything closely resembling the xorg-configure (could be xorgconf, xorgreconf, ...), that's the thing you are after; substitute that for "xorg-configure" in the above command if required.

The command will guide you through a series of pretty easy questions to draw up your own xorg.conf file. Pick "vesa" for a video driver (install the proper driver as soon as you get in - you can simply download them from the mandriva repositories ; use easy urpmi); also be cautious on the side of vertical and horizontal refresh rates: don't specify anything higher than what your screen can actually support.
 
Old 03-01-2007, 06:38 PM   #6
Jamamp1
LQ Newbie
 
Registered: Sep 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Okay, I just edited the xorg.conf file, but it was really tedious. All I did was change the vert/horiz refresh rates. Unfortunately, that didn't make a difference. For some reason, the x server (i think that's what it is), kept resetting every 5 seconds or so. I kept having to press ctrl+alt+backspace to get back to the prompt.

Even after I edited the xorg.conf file it kept restarting itself like that, which is horribly annoying if you can imagine. What else do you suggest I try?
 
Old 03-01-2007, 07:36 PM   #7
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
OK, don't worry. I had the same issue and managed to get there even so.

What distribution did you actually try this out on? Ubuntu or Mandriva? And did you just edit xorg.conf or did you generate a completely new one as described in my previous post?

If it was Mandriva (or Suse), I wouldn't be surprised a simple edit didn't cut it. What struck me most was how stubbornly it clung to its own idea of xorg.conf; any changes would be simply discarded unless I proceeded exactly as described. Also, Mandriva and Suse generated a completely mangled version of xorg.conf with many missing bits and most of them in the wrong place, too. Also, setting graphics driver to "vesa" is just as vital as getting the refresh rates right.

If you're on Ubuntu, it should be sufficient to have a look at the xorg.conf I'm using on Debian (and it's pretty much identical on any of the other ones). Might work on Mandriva /Suse as well, just give it a try. Please note the particulars: this file refers to an ACER 19 inch TFT, a PS2 keyboard and mouse and an ATI 1600 Pro card. If your hardware is similar, it should be safe to copy the parts printed in bold; as for the graphics card, I've put in "vesa", which should work with any type of card. I've put in some comments to point out any changes you may need to make to my model xorg.conf.

In order to make the changes, just boot and at the command line:

Type su - (including the space and the dash) + enter
Type your root password + enter
First back up your xorg.conf by typing : cp /etc/X11/xorg.conf /etc/X11/xorg.conf.copy (+ enter; that's what you do after every single command, of course)
Type vi /etc/X11/xorg.conf to bring up your xorg.conf
- Scroll through the screen using the arrows and locate the horizontal and vertical resolutions as well as the driver device section
- Were you able to determine the max resolution (horizontal and vertical)? Now's the time to use them. Type i (be careful, from now on you can actually make changes, wrong ones too!) and correct the resolution values; if necessary, also the driver (we'll use vesa). Pay close attention to the SYNTAX (i.e. the way that data are organized; e.g. if you see that values in a line are separated by a space, make sure to stick to the rule if you're adding something).
- When you're done, type ESC (you leave editing mode)
- Type :w + enter (changes get written out)
- Type :q + enter (quit Vi editor)
You're back at the command line; time to check whether it has helped: type startx or init 5. If all is OK, you should now see a graphical log-in screen.

If you make any mistakes along the way, you'll have to restore your backup by typing
cp /etc/X11/xorg.conf.copy /etc/X11/xorg.conf
and confirm that the current xorg.conf should be overwritten.
Then you start all over.

As pointed out, this procedure may not work on Mandriva and/or Suse.

Here, finally, is my xorg.conf model.


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection


Section "Files" # Don't touch this part at this time; leave as it was generated

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module" # leave this as generated, even when certain parts are missing or different
Load "dbe"
Load "glx"
Load "GLcore"
Load "record"
Load "freetype"
Load "type1"
Load "i2c"
Load "bitmap"
Load "ddc"
SubSection "extmod" # simply use "Load extmod" if using Nvidia; leave out following 2 lines in that case
Option "omit xfree86-dga"
EndSubSection
Load "dri"
Load "int10"
Load "vbe"
EndSection


Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105" # use your type of keyboard instead; should have been set already
Option "XkbLayout" "be" # use your keyboard layout instead; should have been set already
EndSection


Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection


Section "ServerFlags" # This part can be left out or left at whatever values were generated
Option "AIGLX" "off" # this option is ATI specific
EndSection

Section "Monitor"
Identifier "Monitor0"
Option "VendorName" "ACR" # replace with name of your monitor
Option "ModelName" "ACER AL1951" # replace with name of your model
HorizSync 30.-82.0 # minimum and maximum horizontal refresh rates; adjust if necessary
VertRefresh 50.0-75.0 # minimum and maximum vertical refresh rates; adjust if necessary
Option "DPMS" "true"
EndSection


Section "Device"
Identifier "ATI" # or use "Nvidia" if that's what you have
Driver "vesa"
BoardName "ATI Technologies Inc RV530 [Radeon X1600]"
# replace with model of your card
Option "UseInternalAGPART" "no"
Option "backingstore" "true"
Option "no_accel" "no"
Option "no_dri" "no"
Option "mtrr" "off"
Option "Capabilities" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
Option "PseudoColorVisuals" "off"
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
Option "FSAAEnable" "on"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMPosX0" "0.000000"
Option "FSAAMPosY0" "0.000000"
Option "FSAAMPosX1" "0.000000"
Option "FSAAMPosY1" "0.000000"
Option "FSAAMPosX2" "0.000000"
Option "FSAAMPosY2" "0.000000"
Option "FSAAMPosX3" "0.000000"
Option "FSAAMPosY3" "0.000000"
Option "FSAAMPosX4" "0.000000"
Option "FSAAMPosY4" "0.000000
Option "FSAAMPosX5" "0.000000"
Option "FSAAMPosY5" "0.000000"
Option "UseFastTLS" "1"
Option "BlockSignalsOnLock" "on"
Option "UseInternalAGPGART" "no"
Option "ForceGenericCPU" "no"
BusID "PCI:1:0:0"
EndSection


Section "Screen"
Identifier "Screen0"
Device "ATI" # or use "Nvidia" if that's what you have
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubSection
EndSection


Section "DRI"
Group 0 # this is required on Mandriva only
Mode 0666 # Suse uses 0660 instead
EndSection


Section "Extensions" # leave this for now or keep as generated by your system
Option "Composite" "disable"
EndSection

So, there' some work for you. Please post back whether it works or not.

Last edited by jay73; 03-01-2007 at 07:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Monitor problem using Ubuntu norgaard Ubuntu 4 07-17-2006 04:21 AM
monitor not displaying anything after installation of Nvidia. jennylu89 Linux - Newbie 2 06-11-2006 04:22 PM
Philips monitor not displaying. Vlad_Einhorn Linux - Hardware 7 09-22-2005 12:17 AM
1 tv and 1 monitor, both displaying the same rbirmann Linux - Hardware 2 08-12-2004 04:38 PM
displaying redhat through my windows monitor Da5d&Cnfuzd Linux - General 6 01-08-2003 06:06 AM


All times are GMT -5. The time now is 11:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration