LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 07-11-2009, 06:59 AM   #1
Glyph13
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Rep: Reputation: 0
Problem with Microphone: Realtek ALC883


lspci:

Code:
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc RV410 [Radeon X700 Pro (PCIE)]
01:00.1 Display controller: ATI Technologies Inc RV410 [Radeon X700 Pro (PCIE)] (Secondary)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
03:06.0 Communication controller: Agere Systems V.92 56K WinModem (rev 03)
uname -r

Code:
2.6.26-2-686
OS:

Code:
Debian - Lenny - 32 bit
cat /proc/asound/card0/codec#* | grep Codec
Code:
Codec: Realtek ALC883
The output works just fine, it's the input on my front-mic that will not work proerly.

In Ventrilo, a mux will not show up with the HDA ATI SB. (the only available mixer)

I've checked the aslamixer volume controls, etc... so it is not muted.
Returns "ABS Zero" when monitoring mic input.

I've checked around google, and ran a search. Nothing seems to pertain to this problem.

If you might need any more information, let me know.

Last edited by Glyph13; 07-11-2009 at 07:10 AM.
 
Old 07-12-2009, 12:49 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,044

Rep: Reputation: Disabled
Quote:
Originally Posted by Glyph13 View Post
I've checked the aslamixer volume controls, etc... so it is not muted.
Returns "ABS Zero" when monitoring mic input.

I've checked around google, and ran a search. Nothing seems to pertain to this problem.

If you might need any more information, let me know.
In your input settings is the mic capture active?
jdk
 
Old 07-13-2009, 09:00 AM   #3
Glyph13
LQ Newbie
 
Registered: Jul 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
In your input settings is the mic capture active?
jdk
Thanks for the tip, I overlooked that!
Had to mute some settings, and adjust the volume. But, it works perfectly now!

If anyone needs the exact settings:

Playback:
Master: 100
Headphone: Muted
PCM: 100
Front: 100
Front MI: Muted
Front mic boost: 0
Surround: muted
Center: muted
LFE: Muted
Line: muted
CD: muted
Mic: 71
Mic boost: 0
IEC958: muted
IEC958 D: muted
PC Speak: muted
Channel: 2

Capture
Front mi: 0
Mic boost: 0
iec958: disabled
Capture: enabled - 29
capture 1: disabled - 0
digital: 28
input source: mic (Not front mic!)

Using an M2A-VM asus motherboard with onboard sound.
Also, would like to add that i'm using Xfce.

Last edited by Glyph13; 07-13-2009 at 10:30 AM.
 
Old 07-13-2009, 09:35 AM   #4
monsm
Member
 
Registered: Feb 2005
Location: London, UK
Distribution: Gentoo
Posts: 568

Rep: Reputation: 37
Tell me about it. I had this problem on a different soundcard yesterday, also now solved. Its tricky some times (at least for me) to find the correct settings to change, specially the things that affect the microphone.

I tried Alsamixer, alsamixer-gui and one more. But it was KMix (from KDE) that I found easiest and clearest to use (this is all under XFCE).

In addition I had to set the "mic boost" on for it to work to any resonable level.

Mons
 
  


Reply

Tags
alc, alsa, asus, debian, realtek


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
microphone does not work with Realtek ALC883 HDA fakie_flip Linux - Hardware 47 03-26-2012 07:25 PM
ALSA: Realtek ALC883 Microphone Not Working pandamine Linux - Hardware 1 03-26-2012 07:15 PM
Realtek ALC883 Microphone is not being detected. sirdarckcat Linux - Hardware 1 06-01-2008 11:50 PM
Kmix - microphone - Nvidia MCP51 High Definition audio - realtek ALC883 farfrael Linux - Hardware 5 03-03-2008 11:09 PM
KMix problem with Realtek ALC883 sound ccin1492 Linux - Hardware 12 12-11-2007 04:20 PM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration