LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Problem with glxgears on Debian Squeeze (http://www.linuxquestions.org/questions/linux-hardware-18/problem-with-glxgears-on-debian-squeeze-942118/)

codeman1234 04-27-2012 12:01 PM

Problem with glxgears on Debian Squeeze
 
Hello,

I have a laptop Acer Aspire 5742G with Nvidia Optimus, I have installed Debian Squeeze on it and I used the Debian Wiki to install Bumblebee on it because of the Nvidia Optimus, my video card is Nvidia Geforce GT 540M, my lspci is the following:

Code:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)

Everything is fine until using OpenGL on my laptop, when I tried to do the following command I get the following:

Code:

glxgears
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

or try to use the optirun command from bumblebee

Code:

optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) Apr 27 18:49:03 NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.

[ERROR]Aborting because fallback start is disabled.

What I need to do so I can have my nvidia working at its full potential

Please Help, I tried to find and answer on google but all the solutions I found did not work.

Thank you!!

cascade9 04-27-2012 12:27 PM

You'll need to get newer nVidia drivers. Squeeze only has 195.XX drivers, need 270.41.06 or higher.

codeman1234 04-27-2012 01:14 PM

Quote:

Originally Posted by cascade9 (Post 4664694)
You'll need to get newer nVidia drivers. Squeeze only has 195.XX drivers, need 270.41.06 or higher.

Hello cascade,

before anything thanks for responding, so how can I do that? I need to install wheezy or what options I have, can you explain it a bit more, please

What about Ubuntu or other Distro instead?

Cheers!!

TobiSGD 04-27-2012 01:33 PM

Just use the squeeze-backports repository, the driver version is 275.36 in that repository.

codeman1234 04-27-2012 01:37 PM

Quote:

Originally Posted by TobiSGD (Post 4664730)
Just use the squeeze-backports repository, the driver version is 275.36 in that repository.

Hello Tobi,

so to do that I use the following command:

sudo apt-get install -t squeeze-backports nvidia-glx linux-headers-$(uname -r) nvidia-kernel-dkms

please confirm, or tell me what is the right command and if I need more than the following repositories:

Quote:

deb http://suwako.nomanga.net/debian sid main contrib
deb-src http://suwako.nomanga.net/debian sid main
Cheers!

TobiSGD 04-27-2012 01:40 PM

First you have to add the backports repository to your /etc/sources.list (using a text editor as root) and update the package database
Code:

apt-get update
The just install the drivers with your command.

codeman1234 04-27-2012 02:14 PM

Quote:

Originally Posted by TobiSGD (Post 4664733)
First you have to add the backports repository to your /etc/sources.list (using a text editor as root) and update the package database
Code:

apt-get update
The just install the drivers with your command.

Hello Tobi,

I just did the apt-get update

Code:

apt-get install -t squeeze-backports nvidia-glx linux-headers-$(uname -r) nvidia-kernel-dkms
Reading package lists... Done
Building dependency tree     
Reading state information... Done
nvidia-glx is already the newest version.
nvidia-kernel-dkms is already the newest version.
linux-headers-2.6.32-5-amd64 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 108 not upgraded.

It says it is already installed as you can see, what I am doing wrong? because I still dont get glxgears to work as you can see below:

Quote:

glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
Cheers!!

cascade9 04-27-2012 02:32 PM

Looks like you havent added the backports repo. Or you have just added 'main', you will need 'non-free'.

Add this line-

deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free

Useful info and a few pics showing how to add the backpotrs repo with synaptic (GUI) here-

http://wiki.debian.org/Backports

Edit-
Quote:

Originally Posted by codeman1234 (Post 4664722)
before anything thanks for responding, so how can I do that? I need to install wheezy or what options I have, can you explain it a bit more, please

Theres a few ways to get newer nVidia drivers with debian. The most common are manually d/l and install the drivers from nVidia, or use debian backports.

For a few technical reasons I prefer backports over manual installation.

codeman1234 04-27-2012 03:10 PM

Hello Cascade,

I add the new repository that you mention to my sources list and disable the other one I had of backports and yes it updated some new packages I restarted and it seems to be working because when I do the following command I get this:

Quote:

optirun glxgears
2489 frames in 5.0 seconds = 497.632 FPS
2396 frames in 5.0 seconds = 479.053 FPS
2528 frames in 5.0 seconds = 505.495 FPS
2480 frames in 5.0 seconds = 495.996 FPS
[VGL] ERROR: in readback--
[VGL] 241: Window has been deleted by window manager
But, when I do only glxgears I get the following:
Quote:

glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
Is that right because of bumblebee? Because I see it working a lot better, can someone please confirm it!

Cheers!!

codeman1234 04-27-2012 08:50 PM

For what I am seeing it seems to be everything working all right except opengl it seems I am missing some packages because I get some errors when I tried to run compiz fusion icon or cairo dock with opengl here are the errors I get

Quote:

fusion-icon
* Error: the "FusionIcon" module is missing. If you did not install fusion-icon to /usr, you may need to add the appropriate site-packages directory to your PYTHONPATH
root@CalSci:/home/charlie# export PYTHONPATH="$PYTHONPATH:/usr/lib/python2.5/site-packages"
root@CalSci:/home/charlie# fusion-icon
* Detected Session: gnome
* Searching for installed applications...
Backend : ini
Integration : true
Profile : default
Initializing decoration options...done
* No GLX_EXT_texture_from_pixmap with direct rendering context
... nor with indirect rendering, this isn't going to work!
* Using the GTK Interface
No protocol specified
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
warnings.warn(str(e), _gtk.Warning)
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: Warning: invalid (NULL) pointer instance
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: GtkWarning: gdk_screen_get_root_window: assertion `GDK_IS_SCREEN (screen)' failed
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: GtkWarning: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: GtkWarning: gdk_x11_display_get_xdisplay: assertion `GDK_IS_DISPLAY (display)' failed
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
/usr/lib/python2.5/site-packages/FusionIcon/interface_gtk/main.py:207: GtkWarning: gdk_screen_get_number: assertion `GDK_IS_SCREEN (screen)' failed
icon = gtk.status_icon_new_from_icon_name('fusion-icon')
Segmentation fault

Quote:

cairo-dock -o
Xlib: extension "GLX" missing on display ":0.0".
warning : (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:171)
couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...
Xlib: extension "GLX" missing on display ":0.0".
warning : (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:189)
still couldn't find an appropriate visual ourself, trying something else, this may not work with some drivers ...
Xlib: extension "GLX" missing on display ":0.0".
warning : (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:200)
no luck, trying without double-buffer and stencil ...
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
warning : (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:212)
we could not get an ARGB-visual, trying to get an RGB one (fake transparency will be used in return) ...
Xlib: extension "GLX" missing on display ":0.0".
Segmentation fault
What I am missing?

Cheers!!

codeman1234 04-28-2012 03:45 PM

Also I tried to install openGL Screensavers like MatrixGL and dont seem to work either when I preview it, comes out a blank screen and on the top left corner is a yellow triangle like the signal of warning!!!

Any idea what I am missing since anything with openGL works neither compiz, emulators, cairo-dock and screensavers.

please help, I been trying to find info on google about it but, nothing at all!!

Please help!!

Cheers!

codeman1234 04-28-2012 04:55 PM

Please help, it is driving me crazy!!!

descendant_command 04-28-2012 07:55 PM

I have exactly the same laptop & graphics chip.

Just checked on my squeeze install (which previously had the nvidia driver installed via the nvidia script for testing purposes) and
Code:

aptitude install -t squeeze-backports nvidia-kernel-dkms
worked perfectly (removing the nvidia script cruft and blacklisting the nouveau module in the process).
I have the stock kernel and already had the headers installed and never installed bumblebee.

I would remove bumblebee and any mods it required/made.

cascade9 04-29-2012 04:59 AM

I'm no bumblebee expert. Maybe you can find something in the troubleshooting page?

https://github.com/Bumblebee-Project...roubleshooting

AFAIK removing bumblebee will stop you from using the nVidia GPU at all, everything will be done by the intel video chip. If you do that you might as well turn off the nVidia GPU, its just sitting there eating power for no reason....

codeman1234 04-29-2012 07:36 AM

Hello guys,

first of all thanks for the reply and for all your help, I finally solve this problem, now I got bumblebee installed, my laptop no overheats, my battery works a lot better and my opengl is working fine.

Here is how I solved it, once you installed all the bumblebee stuff and your nvidia is working fine then open a terminal as root and put the following command:

update-alternatives --set glx /usr/lib/mesa-diverted

Reboot Computer

And That's it should be working


All times are GMT -5. The time now is 02:45 PM.