LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-10-2004, 03:00 PM   #1
Mitchua
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Rep: Reputation: 0
Problem with fglrx module (ati-drivers-3.9.0-r1) with kernel 2.6.7


I just upgraded my Gentoo machine to use kernel 2.6.7. I emerged ati-drivers and everything went smoothly. However, the fglrx module wouldn't load. dmesg reports:

fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
[fglrx] module loaded - fglrx 3.9.0 [May 11 2004] on minor 0
[fglrx] module unloaded - fglrx 3.9.0 [May 11 2004] on minor 0
fglrx: version magic '2.6.3-gentoo-r1 K7 gcc-3.3' should be '2.6.7 K7 gcc-3.3'
fglrx: version magic '2.6.3-gentoo-r1 K7 gcc-3.3' should be '2.6.7 K7 gcc-3.3'

but "modinfo fglrx" reports:

author: Fire GL - ATI Research GmbH, Germany
description: ATI Fire GL
license: Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
vermagic: 2.6.7 K7 gcc-3.3
depends:

Why is dmesg reporting that the wrong module is being loaded?

When I do "modprobe -r fglrx" then "modprobe fglrx" I get:
FATAL: Error inserting fglrx (/lib/modules/2.6.7/kernel/drivers/char/drm/fglrx.ko): Invalid module format

Please please help. I need my Wolfenstein in Linux :-)

Thank you.

--Mitchua

Last edited by Mitchua; 07-10-2004 at 03:06 PM.
 
Old 07-10-2004, 08:36 PM   #2
Mitchua
LQ Newbie
 
Registered: Feb 2004
Posts: 11

Original Poster
Rep: Reputation: 0
I found the problem: When I had compiled the kernel I hadn't set /usr/src/linux to point to the correct directory. I created a link from /usr/src/linux->/usr/src/linux-2.6.7, recompiled and installed the new kernel, emerged the ati-drivers, and VOILA, all was well again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ati Fglrx amd64 latest drivers + 2.6.13 kernel problem ssobeht Linux - Hardware 3 11-18-2005 06:01 AM
Problems initialising ati-fglrx kernel module in FC3 St00gE Linux - Newbie 6 05-26-2005 10:50 AM
checking for ati fglrx kernel module...........failed MicahCarrick Linux - Hardware 1 05-06-2005 01:50 PM
ATi fglrx drivers in Gentoo + kernel 2.6.10 vharishankar Linux - Distributions 1 03-08-2005 01:26 AM
[Suse 9.2] Installing kernel-module (ATI Drivers) problem Simkin Linux - Software 0 01-31-2005 03:58 AM


All times are GMT -5. The time now is 07:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration