LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-18-2007, 05:26 AM   #1
Michalxo
LQ Newbie
 
Registered: Oct 2006
Location: Slovakia
Distribution: Ubuntu 6.06 Dapper
Posts: 7

Rep: Reputation: 0
problem with ALSA, no sound through alsa, oss works SB Live! 5.1


Hi all, I have a problem with alsa. I can't here any sound using alsa driver, but oss works. When I play XMMS with alsa output it says this:
Code:
ALSA lib confmisc.c:1283:(snd_func_refer) Unable to find definition 'defaults.namehint.extended'
ALSA lib conf.c:3500:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3972:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm_direct.c:1427:(_snd_pcm_direct_get_slave_ipc_offset) Unknown slave PCM hw:0,0

** WARNING **: alsa_setup(): Failed to open pcm device (default): No such file or directory
every other output works good. When Iam booting UBUNTU (dapper) I cant here that drums in background when Iam logging in, just beep.
I've tried compile alsa using this: http://alsa-project.org/alsa-doc/doc...module=emu10k1

Code:
~$ lsmod |grep snd
snd_emu10k1_synth       7296  0
snd_emux_synth         37760  1 snd_emu10k1_synth
snd_seq_virmidi         7680  1 snd_emux_synth
snd_seq_midi_emul       7168  1 snd_emux_synth
snd_seq_oss            34816  0
snd_seq_midi            8992  0
snd_seq_midi_event      7552  3 snd_seq_virmidi,snd_seq_oss,snd_seq_midi
snd_seq                52176  8 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_emu10k1           131776  3 snd_emu10k1_synth
snd_rawmidi            25504  3 snd_seq_virmidi,snd_seq_midi,snd_emu10k1
snd_ac97_codec        101284  1 snd_emu10k1
ac97_bus                2304  1 snd_ac97_codec
snd_pcm_oss            48160  1
snd_mixer_oss          18816  1 snd_pcm_oss
snd_pcm                82056  3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_seq_device          8460  7 snd_emu10k1_synth,snd_emux_synth,snd_seq_oss,snd_seq_midi,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer              25092  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc         10760  2 snd_emu10k1,snd_pcm
snd_util_mem            4608  2 snd_emux_synth,snd_emu10k1
snd_hwdep               9732  2 snd_emux_synth,snd_emu10k1
snd                    58984  15 snd_emux_synth,snd_seq_virmidi,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
soundcore              10208  2 snd
Iam a n00b, so plz help me someone... it was working correctly before using this manual, https://help.ubuntu.com/community/HdaIntelSoundHowto because ubutnu didn't recognize my soundcard even after 2 reboots, so I got this advice & unfortunately it all has s*** can someone help me PLZ ?
Iam using ubuntu dapper SB Live! 5.1 Creative Labs

if you need some more info, I'll paste here more just help me plz

Last edited by Michalxo; 01-18-2007 at 05:30 AM.
 
Old 01-18-2007, 01:44 PM   #2
Michalxo
LQ Newbie
 
Registered: Oct 2006
Location: Slovakia
Distribution: Ubuntu 6.06 Dapper
Posts: 7

Original Poster
Rep: Reputation: 0
plz some1 help me..
 
Old 01-21-2007, 05:24 AM   #3
Michalxo
LQ Newbie
 
Registered: Oct 2006
Location: Slovakia
Distribution: Ubuntu 6.06 Dapper
Posts: 7

Original Poster
Rep: Reputation: 0
reintalled dapper

now works
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why does my sb live (emu10k1) sound better with oss than alsa? haimeltjnfg Linux - Hardware 2 08-29-2004 02:19 AM
Alsa vs Oss with a creative live card. Marcus_Wille Linux - Software 1 05-27-2004 05:21 PM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 02:34 PM
ALSA-oss compatability works, but not programs intended for alsa ? qwijibow Linux - Software 5 03-14-2004 07:28 AM
Problems in RH 9 with alsa and esd oss works fine (VIA VT8233) husfeldt Linux - Hardware 1 08-28-2003 06:59 AM


All times are GMT -5. The time now is 04:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration