Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 12-06-2007, 12:01 AM   #1
LQ Newbie
Registered: Mar 2007
Distribution: Ubuntu
Posts: 18

Rep: Reputation: 0
Problem loading graphics driver on Mint 4.0

Hello all.

I just performed a fresh install of Linux Mint 4.0, and just about everything works fine, but my video driver won't load. I know that the correct driver for my video card is the i810 driver, but when I attempt to load it, it won't work. I'm pretty sure I've used this driver before (with other distros), and I've used Compiz successfully which means I obviously have had my graphics driver working properly before.

Can anybody give me any advice?

Old 12-06-2007, 01:12 AM   #2
LQ Newbie
Registered: Nov 2007
Posts: 10

Rep: Reputation: 0

Try installing the following code
sudo aptitude purge envy
sudo rm ¬*rf /usr/share/envy
Edit//ignore this line-really stupid typo sudo apt¬*get clean
sudo apt-¬*get clean
sudo dpkg ¬*i envy_0.9.7¬*0ubuntu11_all.deb
rm envy_0.9.7¬*0ubuntu11_all.deb
Then uninstall and install the driver again with envy

Actually someone in another linux forum had a similar

Last edited by rockaway; 12-06-2007 at 01:13 AM.
Old 12-06-2007, 11:52 AM   #3
LQ Newbie
Registered: Mar 2007
Distribution: Ubuntu
Posts: 18

Original Poster
Rep: Reputation: 0
I was actually able to fix it. Someone at Ubuntu's IRC channel helped me out. All I had to do was edit my xorg.conf file and change the driver under Section "Device" from "vesa" to "intel." Once I restarted X, it worked perfectly.

Last edited by Pandemic187; 12-06-2007 at 11:53 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install SiS 660 driver? Linux Mint 2.2 lancest Ubuntu 2 03-04-2007 12:23 AM
Graphics driver problem Rick069 Debian 4 02-14-2006 02:58 PM
Problem loading graphics module Martin Bishop Linux - Newbie 1 11-26-2003 02:43 AM
Problem loading graphics module for 9800 plus Martin Bishop Linux - Hardware 0 11-25-2003 11:54 PM
Problem loading graphics module Martin Bishop Linux - Software 0 11-25-2003 11:32 PM

All times are GMT -5. The time now is 09:52 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration