LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-12-2009, 12:45 PM   #1
DDayWalKeR
LQ Newbie
 
Registered: Nov 2009
Posts: 9

Rep: Reputation: 0
Question Problem installing ATI Radeon 4870


I have tried everything but my ATI keeps freezing Ubuntu. I cant get into Display options although I can get into Catalyst's Control Panel but anyway I chance options there and it's like if nothing happened. I installed Ubuntu's repository drivers by console with this next commands:

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

I download this ati-driver-installer-8.33.6-x86.x86_64.run that I think that will end my problems but cant manage to get it installed. Can anyone tell a few tips on how to install this drivers or what can I do to fix this problem?

Thanks!!!
 
Old 11-15-2009, 05:47 PM   #2
AuroraZero
Member
 
Registered: Oct 2009
Location: Michigan
Distribution: SlackWare 13.37, Android, Slax, Centos 5.9 Final, Centos 6
Posts: 187

Rep: Reputation: 31
Quote:
Originally Posted by DDayWalKeR View Post
I have tried everything but my ATI keeps freezing Ubuntu. I cant get into Display options although I can get into Catalyst's Control Panel but anyway I chance options there and it's like if nothing happened. I installed Ubuntu's repository drivers by console with this next commands:

sudo apt-get update
sudo apt-get install linux-restricted-modules-$(uname -r) #Okay if it is already installed
sudo apt-get install xorg-driver-fglrx
sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv

I download this ati-driver-installer-8.33.6-x86.x86_64.run that I think that will end my problems but cant manage to get it installed. Can anyone tell a few tips on how to install this drivers or what can I do to fix this problem?

Thanks!!!
What kernel version are you using? The older ATI drivers will not work on the newer kernels without a patch. The newer ATI drivers work but the card support does not work for older cards. Catch 22 I know and it sucks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon hd 4870 Ellops Linux - Hardware 7 10-08-2009 08:36 PM
ATI Radeon HD 4870 Yoruichi Linux - General 8 04-29-2009 07:18 AM
LXer: ATI Radeon HD 4870 512MB LXer Syndicated Linux News 0 07-03-2008 12:10 PM
Problem installing ATI Sapphire Radeon x550 alcaphone Fedora 2 07-29-2006 12:10 PM
Problem installing Debain with ATI Radeon 9800 AIW seeleung Debian 3 09-23-2004 06:12 PM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration