LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-25-2006, 09:55 AM   #1
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
Problem installing ATI fglrx driver - ??


Hi there

I have installed Suse 10.2 on my Compaq Presario R3000 laptop. The graphics card is (sadly) a built in ATI mobility Radeon 9000 IGB. This is listed by the laptop as a RS300 5835 - which I think is the chipset?

I have closely followed the instructions on Suse ATI installer how to.

This tells me to download the ATI installer program which I did. I ran this to make a rpm package for my distro - this seemed to work out alright. The instructions this generated are:

Quote:
ATI fglrx driver configuration (including 3D support)
-----------------------------------------------------

Switch to runlevel 3 ("init 3") and use the following command as user
"root" to configure the ATI fglrx driver (including 3D support).

sax2 -r -m 0=fglrx -b /usr/share/doc/packages/fglrx/sax2-profile

On (open)SUSE 10.1 (Alpha) or later it's no longer required to
specify the profile, so use "sax2 -r -m 0=fglrx" instead.

There's no need to try to enable 3D support via SaX2. It's already
enabled automatically when SaX2 is starting.

Known Issues:
- driver only supports 24bit color depth
- enabling of 3D support through SaX2 does not work (see above)
Well I did all of the above, but when running in run level init 3 and typing in the command:
Quote:
sax2 -r -m 0=fglrx
I got the following error message:


Quote:
AHBlaptop:~ # sax2 -r -m 0=fglrx
SaX: initializing please wait...
SaX: your current configuration will not be read in

SaX: wrong module syntax...
SaX: syntax: -m CardNr=CardModule[,...]
Any ideas what has gone wrong? I don't understand the error message above.
Thanks - and Happy Christmas!
 
Old 12-25-2006, 11:35 AM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,455

Rep: Reputation: 83
Did you check
http://www.linuxquestions.org/questi...d.php?t=402003
??

Happy Penguins!
 
Old 12-25-2006, 01:01 PM   #3
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Yes I did read that first, thanks - but that is for slackware and the guide I followed was SuSE specific.

I really need advice on where my procedure went wrong.
 
Old 01-04-2007, 04:48 PM   #4
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
I still can't solve this one. I've read the Suse documentation and it mentions:

Quote:
Also, try running

>fglrxinfo

If fglrx is installed, it should report something like "[YOUR CHIPSET] Generic", if it reports Mesa, you have a problem. Otherwise, you're all set! Enjoy your smooth framerates and high resolutions!
So I did that and got:

Quote:
AHBlaptop:/home/adrian # fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R200 20060602 AGP 4x x86/MMX/SSE2 NO-TCL
OpenGL version string: 1.3 Mesa 6.5.1

AHBlaptop:/home/adrian #
So I have a problem!

Any ideas folks? I'd love to get this driver installed.
 
Old 01-05-2007, 01:23 PM   #5
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Original Poster
Rep: Reputation: 30
Since doing the above, my laptop won't boot other than in text mode!! If I type init 5 in text mode, nothing happens.

Not only did the ATI driver not work, but it broke my Suse 10.2 install. I'm never buying an ATI product again.

Help still appreciated.
 
Old 01-13-2007, 02:32 AM   #6
0x29a
LQ Newbie
 
Registered: Jun 2004
Posts: 16

Rep: Reputation: 0
Hey Adrian,

I feel your pain. I battled with the ATI driver on SuSE 10.2 x86_64 for several hours and got to a point where sax2 wouldn't even load anymore. It gave that same message you got
Quote:
SaX: initializing please wait...
SaX: your current configuration will not be read in
And then it never loaded. The same thing was happening in KDE when running yast2. Click the "Graphics Card and Monitor" icon, and nothing... Another frustrating thing was when after generating and installing the rpms going in to YaST and setting things up in that new weird way and clicking on "test" and it just sitting there again...

YaST, sax and SuSE in general have gone steadily downhill IMHO. I mean sax2 won't even let me select a generic video card driver like "radeon" or "nv" that I've found. And why does the video driver show next to the monitor label?!?! It's crazy. It seems like I had the driver installed at one point, but I couldn't get YaST to set the monitor correctly, and I'm too lazy right now to do it all by hand. Oh well. I've installed Kubuntu for now which the ATI driver setup has it's own problems with, but it's the 32-bit version because getting opera to run on the 64-bit is more of a hassle than it's worth.

Okay, I've ranted enough. I'll try again in a couple of days when I get un-frustrated, and if I have any success, I'll let you know. I wouldn't blame ATI yet, though.
 
Old 01-17-2007, 04:51 PM   #7
ratzoid
Member
 
Registered: Oct 2004
Location: Germany
Distribution: SuSE
Posts: 33

Rep: Reputation: 15
The only thing I can think of is that the 0 is a number zero not the letter o.
 
Old 01-17-2007, 04:59 PM   #8
0x29a
LQ Newbie
 
Registered: Jun 2004
Posts: 16

Rep: Reputation: 0
Quote:
Originally Posted by ratzoid
The only thing I can think of is that the 0 is a number zero not the letter o.
Yeah, it always is when using
Code:
sax2 -m 0=fglrx
I've never used or recall seeing a "-r" switch, though.

Last edited by 0x29a; 01-17-2007 at 08:32 PM.
 
Old 01-29-2007, 04:18 PM   #9
ratzoid
Member
 
Registered: Oct 2004
Location: Germany
Distribution: SuSE
Posts: 33

Rep: Reputation: 15
I have some news that is just a bitter pill! I have an ATI Moblity Radeon 9000 im the
laptop too. I came across this link which shoots us down in flames.
http://opensuse.us/viewtopic.php?t=1...85354560db1f79

Maybe I'll go back to 10.1 or see if I can figure out how to roll back the xorg to 7.1 or less. Let me know if you come up with a better solution for SuSE 10.2

Read the nasty stuff in red.

Last edited by ratzoid; 01-29-2007 at 04:21 PM.
 
Old 02-09-2007, 05:50 PM   #10
Valdoror
LQ Newbie
 
Registered: Sep 2006
Location: Lyon - France
Distribution: openSuSE 10.1
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by 0x29a
Code:
sax2 -m 0=fglrx
I've never used or recall seeing a "-r" switch, though.
I've got a problem similar to yours: I followed the same instructions (sax2 -m 0=fglrx) and everything was ok (1280x1024 - 3D ATI accelerated) until:

- I updated my kernel to version 2.6.16.27 (=> I lost 3D acceleration) and
- I re-issued the above sax2 command in order to re-activate 3D (=> my resolution dropped down to 1024x768 but 3D was back).

Now whenever I click the Test button in sax2 I get a black screen with a non blinking cursor at the top left

I had a look at xorg.conf and noticed all modelines have disappeared (compared to a backup copy of xorg.conf), as well as all modes (resolutions) except 1024x768...

I tried to start X with my backup copy of xorg.conf but I still had that black screen.

I can't leave this screen with any key combination.

'sax2 -r' stands for "Remove detection database and re-init the hardware database". Ok. But what are these databases ? Is there a way to restore them in their original state ?

I'm ok for further investigations but I lack ideas as where to head to...

Last edited by Valdoror; 02-10-2007 at 04:41 PM.
 
Old 02-10-2007, 04:32 PM   #11
Valdoror
LQ Newbie
 
Registered: Sep 2006
Location: Lyon - France
Distribution: openSuSE 10.1
Posts: 2

Rep: Reputation: 0
Fortunately, I could solve (very easily) my own problem: get that 1280x1024 resolution back ! All I did was:

init 3
sax2 -r (+ acceptation of the default config, without testing it or I would have received the usual black screen)
init 5

The new version of xorg.conf seemed to be easier to read...

Then, I modified all "Modes" lines in xorg.conf (Screen section) in order to get this:

Modes "1280x1024" "1024x768"

All I did was to add the resolution I wanted back ("1280x1024") in first position...

Ctrl+Alt+Del and happily, I could change the resolution with Ctrl+Alt++ and recover a decent resolution

I did not try to get the black screen again, in order to see if a lacking resolution in xorg.conf leads to this kind of crash.

For Adrian (if he didn't give up): I've read an important note in the howto you followed: "Unfortunately you need to recompile the "fglrx" kernel module right after any kernel (security) update. Use "fglrx-kernel-build.sh" for this".

Is the fglrx module loaded into your kernel ('lsmod' as root) ?

Is the 'Load "glx"' string present in the "Module" section of your xorg.conf ?
 
Old 02-22-2007, 07:17 PM   #12
Hawky
Member
 
Registered: Oct 2004
Distribution: Ubuntu (Desktops), CentOS (Servers)
Posts: 69

Rep: Reputation: 15
I know just how you feel. I've got a compaq Presario R3145EA (R3000 Series) Notebook with exactly the same card you have. It's been trouble ever since I bought it. Even Windows had problems (eg. Doom 3, Tomb Raider Legends, many more.....)

I'm running Suse 10.2 now with no 3D support until I can find a 'proper' fix for it.

It's funny how other distros work perfectly like Mandriva (after a kernel change), Kubuntu (worked out of the box), Fedora (worked out of the box).

....but SUSE the "leading distribution" just can't get it's act together.

The next PC I buy is going to have an Nvidia or an Intel card in it. From what I've experienced so far (we have 5 computers at home) Intel seem to be best supported for graphics drivers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing ATI driver, fglrx itz2000 Slackware 32 12-07-2006 03:46 AM
ATI fglrx Driver RavenFrost Slackware 1 04-11-2006 08:46 AM
Problem of Radeon M300 with ATI fglrx Driver! shreks Linux - Hardware 1 02-11-2006 04:37 PM
fglrx-driver vs ATI kernel driver for ATI Radeon 9200 in Debian Debian_Poland Debian 3 02-01-2006 02:10 PM
ATI fglrx driver problems on a Sony Vaio (but can be a common problem...) MachineH Linux - Laptop and Netbook 0 08-08-2004 02:31 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration