LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-16-2005, 09:13 AM   #1
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Rep: Reputation: 31
Power off no longer works


I have Knoppix 3.9 installed on a Medion 1.8 GHz PC with 256 MB RAM.
There is just one problem, when I shut down the PC, it does not turn the power off, however this used to work.
Has anyone come across this before ? I have searched the net but without success.
 
Old 07-16-2005, 09:28 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Some things may be different in Knoppix, but basically you either use ACPI or APM to shutdown the box. You didn't give a lot of information, but I'm assuming it's stopping all the services but leaving you with a message which says, "Power down." Try this:

http://www.linuxtux.org/~juhl/slackwarefaq/#34

The principle, and use of APM or ACPI is the same.
 
Old 07-17-2005, 10:30 AM   #3
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
Thanks for the help.
I checked and the apmd deamon is running (if I run ./apmd start as root, it tells that apmd is already running).

So it should shut down, however it does not. I am trying to turn it off as KDE turn off.
The message is that it just says no more services running.

Sorry for the lack of info in the original post.
 
Old 07-17-2005, 11:42 AM   #4
ride153
Member
 
Registered: Apr 2005
Location: Northeast USA
Distribution: current is PCLOS (server) and Suse (desktop)
Posts: 102

Rep: Reputation: 15
use the halt command
 
Old 07-18-2005, 04:07 PM   #5
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
No that does not work, it just shuts down KDE and gives a message no more processes in this run level.
 
Old 07-18-2005, 09:03 PM   #6
ride153
Member
 
Registered: Apr 2005
Location: Northeast USA
Distribution: current is PCLOS (server) and Suse (desktop)
Posts: 102

Rep: Reputation: 15
first log out of KDE
than run HALT as root
 
Old 07-24-2005, 01:54 PM   #7
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
Thanks for that suggestion but that does not work either !!!

The worst thing of all, is that when I turn it off at the back it is often temperemental about turning back on.
 
Old 07-24-2005, 08:14 PM   #8
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
For power off to turn your power off in Linux, you must either use APM or ACPI.

You state you're running APM, so then you need to be sure you have the APM module by issuing "lsmod" and if it's there, add this line to your /etc/lilo.conf file:
Code:
append="apm=power-off"
It should go after the line which tells LiLO where your boot record is stored, like this:
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
append="apm=power-off"
If you already have an append line, such as append="elevator=cfq", then you would add another append statement like this append="elevator=cfq apm=power-off" keeping both (or more than two) append statements inside one set of quotes, separated by a space.

If this doesn't work for you, read the instructions that came with Knoppix-3.9 and/or try to find a Knoppix forum or IRC help channel.

I can give you another Enable power-off HOW-TO; but since Knoppix is based on Debian, which doesn't follow published Linux standards, such as the Linux File System Standard, it might not work the same.

What have you changed since as you stated in your first post
Quote:
however this used to work
that has caused this to stop working?
 
Old 07-25-2005, 09:25 AM   #9
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
Hi Chinaman,

Thanks for all this. I will give it a go and see.

I don't think that I have changed anything to stop it from working.

I added my java installation to my path, but apart from that I have not changed anything, certainly not the kernel.

Of course, one possibility is that there is a hardware problem although I certainly hope that this is not the problem.
 
Old 07-25-2005, 09:28 AM   #10
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
That turning it off at the back...do you not have a power switch on the front? I assume you're turning the power supply itself off. At any rate, having a problem turning it back on sounds like your power supply is going out. I don't know how to have them checked, but I guess some computer guys with a volt/ohm meter or whatever could do it. For me it's just trial and (mostly) error.
 
Old 07-25-2005, 03:59 PM   #11
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
More details

APM is enabled
Code:
lsmod | grep apm
apm                    22252  2

In lilo.conf
Code:
image=/vmlinuz
        append="lang=de apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga=791 quiet BOOT_IMAGE=knoppix"

This has not been changed since I installed knoppix.

I do have a power on button on the front but it does not turn the PC off (either in Win XP or any type of Linux) just on. Thanks for the tips on power supply, that could be the problem.

I will try the command poweroff but I don't think it will work
 
Old 07-25-2005, 07:44 PM   #12
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Also sounds like your BIOS is not set to let you turn it off, or your power switch is defective.
 
Old 07-26-2005, 03:39 AM   #13
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Mandriva 2008 Spring
Posts: 652

Original Poster
Rep: Reputation: 31
The turn power off still works in Win XP, so presumably the BIOS is correct.
The power switch has always been like that, actually at work some PCs are designed in the same way the front button only turns on not off.
I suppose it is a safety design to stop people annoying you by turning off the PC.

I used to have Mandrake 8.2 on my PC and that did not have APM enabled.
However at that time my PC did not mind being turned off at the back.
I will have to get someone to look at it.

Last edited by davholla; 07-26-2005 at 03:42 AM.
 
Old 07-26-2005, 12:08 PM   #14
NetRAVEN5000
Member
 
Registered: May 2005
Distribution: Ubuntu 9.04
Posts: 320

Rep: Reputation: 30
Quote:
The power switch has always been like that, actually at work some PCs are designed in the same way the front button only turns on not off.
I suppose it is a safety design to stop people annoying you by turning off the PC.
No, this is a feature in modern PCs - I believe it's called "soft-off" - it's where the motherboard controls if and when the power button actually does something, and what it does. The reason for it is that turning your PC on and off real fast is bad for it. Most motherboards even take it a step further and allow you to make the power button make your computer go into sleep mode.

I believe there's a kernel option for this - maybe you don't have it enabled in the kernel, even though you've got the daemons and everything?

Anyways, if you want a work-around until you figure it out, hold the power button down. It should turn off in about 4 seconds, but DON'T count - I've told people to do this before, and, trust me, EVERYONE counts faster than they think they're counting. Watch the clock, but don't follow it too closely - 4 seconds is just a general guideline; don't worry until it's been 10 seconds or so and it doesn't turn off.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse no longer works in 9.3 gejoroni Suse/Novell 11 07-13-2005 02:13 AM
Emacs no longer works linmix Linux - Software 3 08-05-2004 02:26 AM
Abiword no longer works KMcD Linux - Software 2 03-31-2004 03:56 AM
k3b no longer works guygriffiths Linux - Software 0 03-06-2004 01:20 PM
CD-RW drive no longer works wmeler Linux - Hardware 8 02-27-2004 02:07 PM


All times are GMT -5. The time now is 01:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration