LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   poor sound quality (http://www.linuxquestions.org/questions/linux-hardware-18/poor-sound-quality-481488/)

verbose 09-08-2006 12:29 AM

poor sound quality
 
I recently bought a C-Media CMI8738/C3DX sound card and the audio quality in Linux is just awful (it's just extremely muffled). I can max out Master and PCM with very little increase in sound output. I haven't tried that other OS (Windows is it...) since I can't get the drive to boot, so I don't know how the audio is in there, but I'm assuming it's much better.

I've tried muting everything except Master and PCM in alsamixer with no effect.
My alsa version is 1.0.11.

lspci:
00:07.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
Flags: bus master, medium devsel, latency 64, IRQ 201
I/O ports at 5000 [size=256]
Capabilities: [c0] Power Management version 2

lsmod|grep snd:
snd_cmipci 31808 2
gameport 14536 1 snd_cmipci
snd_pcm_oss 44224 0
snd_mixer_oss 15904 1 snd_pcm_oss
snd_pcm 77060 2 snd_cmipci,snd_pcm_oss
snd_page_alloc 10024 1 snd_pcm
snd_opl3_lib 9696 1 snd_cmipci
snd_timer 21636 2 snd_pcm,snd_opl3_lib
snd_hwdep 8836 1 snd_opl3_lib
snd_mpu401_uart 7296 1 snd_cmipci
snd_rawmidi 22976 1 snd_mpu401_uart
snd_seq_device 8524 2 snd_opl3_lib,snd_rawmidi
snd 48384 14 snd_cmipci,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_ra wmidi,snd_seq_device
soundcore 9216 1 snd


Thanks


edit: I've looked at the HCL for my sound card and it's all positive reviews. Also, I was using the integrated i810 video/audio chip before this card and the sound quality was perfect for my tastes. Surely this pci card is capable of much more than it's giving now.

cs-cam 09-08-2006 07:57 PM

You said you have Master and PCM maxed out? Try turning PCM down to about 88%, works here to fix slight distortion.

verbose 09-08-2006 08:38 PM

Well, actually I said I can max it out with very little effect, but that's just semantics. As it is right now, I have both Master and PCM at 74%. If I make PCM 90%, the sound quality is better but it's still unacceptable. As I've said, my integrated audio solution put out much better sound.

Electro 09-08-2006 09:04 PM

Try exchanging the sound card for Audiotrak Prodigy 7.1LT. You will get execellent sound quality. Unfortunately, this sound card is always out of stock.

If you do not want to exchange the sound card, try upgrading ALSA to 1.0.12 or the unstable release 1.0.13.

verbose 09-08-2006 10:05 PM

Well... the thing is, I just bought this sound card for really cheap off ebay and I'd rather get this one working. In the HCL, the card received very good reviews. No qualms about sound quality or anything.

The latest apt-get alsa version for etch is the same as in unstable. Is there any particular reason you think the latest driver will work any better than 1.0.11?

verbose 09-09-2006 12:35 AM

I was thinking maybe if I used this tool (cmictl) to reconfigure some of the sound card settings, I'd see better results, but no such luck.

These are the settings the tool allows you to change...
SPDIF in :ON
SPDIF out :OFF
SPDIF loop :ON
Legacy to SPDIF :OFF
SPDIF monitor :ON
SPDIF out voltage :0.5V
SPDIF rate :48kHz
Surround :ON
Line IN Jack :Line IN (2 speaker mode)
Reverse front and rear :OFF
Input signal phase :Normal

I tried just enabling them all but sound was still nearly inaudible.

verbose 09-11-2006 04:29 AM

I decided to just buy another sound card. The box says Audigy SE but lspci says different--Audigy LS. I have absolutely NO sound with this card. I've searched high and low for a solution but I've still yet to find one, so I will likely create another thread for this new problem.


All times are GMT -5. The time now is 05:13 PM.