LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Closed Thread
 
Search this Thread
Old 06-24-2009, 04:01 AM   #1
uditchandna
LQ Newbie
 
Registered: Jun 2009
Posts: 4

Rep: Reputation: 0
pls help, powerpclinux gcc problem


i am new to linux just 2 months and have been assigned to develop an application in motif(Xm) and then create its binary fil to be run on pwerpc.

i successfully implemented Xt and X11 code on (Embedded linux developmnt kit ELDK )using CROSSCOMPILER but the embedded linux gcc gives error on Xm code that

/bin/ld: cant find lXm

and if i provide link to the motif libraries it says incompatible version of libXm.so

anyone please suggest where i am wrong and what should i do how to give ppc-linux gcc's ld the Xm libraries

BY THE WAY I HAVE INSTALLED Lesstif 0.9.5.2 and want to design app for powerpc 74xx series

thanx for helping me in advance
 
Old 06-24-2009, 06:25 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,408

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread

Tags
cross, motif, pc, xm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] gcc-gnat depends on OLDER version - pls help! emmalg Linux - Software 5 06-16-2009 07:56 AM
QUAINT !!! is this a gcc bug ? pls check out this simple C program.() cryincold Programming 9 02-09-2008 02:43 AM
GCC First Pass throwing errors...pls help! chakkaradeepcc Linux From Scratch 2 04-11-2005 01:20 PM
pls pls pls help me ! i'm tired with httpd config on fedora apache 2.0.48 AngelOfTheDamn Fedora 0 01-24-2004 05:12 PM


All times are GMT -5. The time now is 09:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration