LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   please help! Couldn't open /dev/video0 (http://www.linuxquestions.org/questions/linux-hardware-18/please-help-couldnt-open-dev-video0-378400/)

jrmontg 10-30-2005 02:58 PM

please help! Couldn't open /dev/video0
 
I am trying to use my ATI TV wonder card but every tv program that I use says: Couldn't open /dev/video0

I am using Centos 4

Thanks
\Jeff

maroonbaboon 10-30-2005 04:32 PM

You probably don't have the necessary drivers loaded. Have you checked the output of 'lsmod'? You are looking for a driver called 'bttv'.

If it is not there you can try loading it by hand with 'modprobe bttv' (as root) and see what happens.

If you have a copy of the kernel source there is detailed documentation in

Documentation/video4linux/bttv

jrmontg 10-30-2005 05:10 PM

Thank you for your reply. It is not listed in lsmod and I get this when I do the modprobe
/sbin/modprobe bttv
FATAL: Module bttv not found.

I did a locate bttv and nothing was found. Please advise.

maroonbaboon 10-30-2005 06:47 PM

Probably your kernel was built without bttv support. Some alternatives:

1. You can check if your distro provides an alternative kernel, or extra packages you can add to your existing kernel.

2. You can compile/install your own kernel. See the documentation in the source mentioned above for getting TV to work.

3. You can try a different distro. For example, there is a good chance that a recent Knoppix live CD will work straight away, and you can try it without touching your current setup.


All times are GMT -5. The time now is 02:58 PM.