LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   PixelView Play TV Pro - TV/Radio doesn't work. HELP! (http://www.linuxquestions.org/questions/linux-hardware-18/pixelview-play-tv-pro-tv-radio-doesnt-work-help-213757/)

vxc69 08-05-2004 10:14 AM

PixelView Play TV Pro - TV/Radio doesn't work. HELP!
 
So I search the HCL's for a compatible TV Card. I find PixelView Play TV Pro, bought it, fixed it and installed a fresh copy of Mandrake 10 Official.

The card was detected and TV-Time had been installed automatically. I opened TV Time but there was nothing - no sound or picture (video).

So I go to configure your computer>>Hardware>>TV Card.

Here mandrake installs xawTV and pop's up a xawTV configuration window. I choose the correct values (i.e PAL - Country=All - User=Me). Then it does a channel search. After everything completed, I opened XawTV and again the result was no sound and no video.

I know some of you have configured PixelView Pro TV.

So how did you do it? What am I doing wrong?

Please help :cry:

p.s: Yes, I have connected the Antenna to the card. Both radio and TV antenna's. BTW, Kradio doesn't work either - it doesn't detect /dev/radio.

vxc69 08-05-2004 11:17 AM

HELP
 
Anyone??????????:cry: :cry: :cry:

J.W. 08-05-2004 02:07 PM

vxc69 - per the LQ Rules, please do not bump your post until at least 24 or 48 hours have elapsed without a reply. Keep in mind that the LQ membership is global, and it's unrealistic to expect that everyone here will have seen your post in only one hour. I know it can be frustrating waiting for a response, but please be patient. If/when someone who can offer advice sees your post, he/she will reply. -- J.W.

jimdaworm 08-06-2004 03:26 AM

Hey J.W. / vxc69

I had a similar problem, I think quite often linux automatically detects the wrong card. This thread has the info you need to make sure.

http://www.linuxquestions.org/questi...threadid=44506

From the list of cards it says that yours is:
Quote:

card=37 - Prolink PixelView PlayTV pro
And from:
Quote:

http://www.linuxquestions.org/hcl/showproduct.php?product=1127
We get that your tuner is a:
Quote:

Philips NTSC
Going back to the first link I am guessing that its this tuner
Quote:

type=17 - Philips NTSC_M (MK2)
So no we have that it is a card=38 and tuner=17 (You might need to fiddle with these a bit),
so what I do is go to my /etc/modprobe.conf
(only modprobe.conf only exists with kernel 2.6.x or it should be called that with with Suse 9.1 and slack 10.0) and edit that to put in somthing like this:

Quote:

#TV Card
alias char-major-89 i2c-dev
alias char-major-81 bttv
options bttv card=38 tuner=17 radio=1
Then restart your computer and see if the tv works, you might as I said need to try some other tuner numbers or somthing. Now I am no expert on this so if some one can correct any mistakes I have made good on you!

Good luck!;)

vxc69 08-07-2004 11:19 PM

Hey folks.

First of all I'm real sorry JW.

Next, jimdaworm, what you gave me worked like a charm. Now Kradio detects /dev/radio and I can even scan for channels on TvTime.

Everything seems to work so far. :)

Thanks a lot for your help. To show you my appreciation I give you boobies!

( o Y o )

vxc ;)

jimdaworm 08-08-2004 02:41 AM

No worries vxc69, it took me ages to figure that out!!! Anyway with the amount of help people have given me on this forum its about time I start helping people out!!!!!!!!

Good luck:)

J.W. 08-08-2004 03:43 PM

vxc69 - no trouble, it' s just that if everybody bumped their posts every couple of hours, the result would be that any useful replies would be interspersed with a few dozen "bump" posts, which would make finding useful information more difficult.

Thanks though for posting back indicating that the solution worked (thanks also jimdaworm for suggesting it) because it is always beneficial to have some indication as to whether or not a proposal worked. -- J.W.

jimdaworm 08-13-2004 08:08 AM

Thats what I love about this forum/GNU its great everyone just shares what they know with the people who need to know! :)

DaveQB 09-01-2004 02:40 AM

i had the same problem and a mate who i bought the card off gave me the values like you have found out vxc69 cept for the local here ie:
  • modprobe bttv card=37 pll=1 radio=1
    modprobe tuner type=5

All works great!! (cept XawTV doesnt, TVtime works great! and Gv4l records and watches fine too)

But now my problem is the radio.
Kradio cant scan for any stations; it doesnt find a single one. I didnt have an audio loopback cable so added an internal going into the AUX of the Mainboard (like my previous card was set-up (and works in Windows))
KRadio doesnt have a selection for AUX so i tried them all but to no avail.

Any ideas guys ??

Thanx for reading

jimdaworm 09-01-2004 07:28 AM

Hey DaveQB. First do you happen to have a ati graphics card and running their drivers?? I found that they conflicted with xawtv and it just crashed everything unless I ran it with the -d option.

Second did you look up your card and make sure that it should be set to radio 1??? I have it setup in my modprobe.conf like this:

Quote:

#TV Card
alias char-major-89 i2c-dev
alias char-major-81 bttv
options bttv card=78 tuner=32 radio=1
Thirdly have you tried other programs like gnome radio... or maby somthing really simple... I canīt remember what its called but I used one that worked without a gui.

Good luck:)

DaveQB 09-01-2004 07:35 AM

Thanx for the reply

Quote:

Originally posted by jimdaworm
Hey DaveQB. First do you happen to have a ati graphics card and running their drivers?? I found that they conflicted with xawtv and it just crashed everything unless I ran it with the -d option.
I do indeed have an ATI card, 9800SE PowerColour, clocks good

I just tried the -d argument but it didnt make a diff. Thats ok i prefer TVTime anyway :)

Quote:

Second did you look up your card and make sure that it should be set to radio 1??? I have it setup in my modprobe.conf
Yes, its the PixelView PlayTV Pro which has a Radio tuner on it. The arguments i showed up there ^ were the ones a mate gave me that he used with this card and had the Radio working no sweat.



Quote:

Thirdly have you tried other programs like gnome radio... or maby somthing really simple... I canīt remember what its called but I used one that worked without a gui.

Good luck:)
Yeah i tried gnomeradio just after i posted here and no diff there.

I have since changed the internal audio cable from the AUX pins to the CD pins and now i get static sound when i unmute the CD channel. The radio auto scans and seems to detect some signals, but nothing on a recognise station and there's definately no change in the sound (remains statis)

Any other ideas guys ??

Thanx again

jimdaworm 09-01-2004 05:55 PM

DaveQB firstly doesnīt your motherboard/sound card have a line in?? That would be the normal place to put the input... where you start plugging it into other inputs they have all sorts of different īlevelsī which can result in things not working properly.

So just to get this straight you can watch tv and the sound works fine when you do?? If not I would suggest you check your cable.

My cable goes from my tv card to my line in (make sure you donīt plug it into the remote or somthing:) )

Good luck

DaveQB 09-01-2004 06:05 PM

yeah i go directly to the LINE IN from my VCR and unmuting LINE IN is fine. I havent a loopback audio cable so i used the internal connector and a CD-ROM Audio cable to connect to the boards CD/AUX pins.

Always worked before in Windows

jimdaworm 09-02-2004 06:22 AM

Sorry you have lost me when it comes to the vcr. Does it work if you just plug a cable from the output of your tv card to your line in on your sound card??

Also
Quote:

So just to get this straight you can watch tv and the sound works fine when you do??

DaveQB 09-02-2004 10:52 AM

Quote:

Originally posted by jimdaworm


Also
Quote:

So just to get this straight you can watch tv and the sound works fine when you do??


Quote:

Originally posted by DaveQB
yeah i go directly to the LINE IN from my VCR and unmuting LINE IN is fine.


All times are GMT -5. The time now is 09:26 AM.