LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-02-2003, 04:25 PM   #1
Jeriko
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
Philips Widescreen Monitor Woes


I have a Philips 170W4 widescreen 1280x768 resolution monitor that I'm having a very hard time getting to work properly under SuSE 8.2 / KDE. I should mention that I'm a total newbie to Linux, and have just learned how to open up and edit the XF86Config file so this is probably where the answer lies.

I suspect I need a Modeline for it. I tried the modeline generator at xtiming.sourceforge.net but it for the monitor's recommended mode of 1280x768 @ 60Hz I was getting a Dot rate of over 79MHz, over the monitor's maximum of 75MHz.

The full specs of my monitor are in this PDF(I'm leaving out the www and all because I'm new and can't post URL's)

consumer.philips.com/global/b2c/ce/catalog/assets/downloads/170w4p_us_lft.pdf


Ho do I get this monitor working at its full resolution? The only thing I can manage is 1024x768. There's no option of 1280x768 under the Monitors / LCD tab.

-J
 
Old 09-02-2003, 05:11 PM   #2
Jeriko
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
One other question - can I "force" the 79.75MHz dot rate that I'm getting on the generator down by simply typing in my monitor's maximum of 75 instead? I'm not really sure what the limits of change to those generated modelines are.

For example, I'm getting:

"Modeline "1280x768@60" 79.75 1280 1312 1608 1640 768 783 791 807

Horizontal sync frequency: 48.62 kHz"

Can I just change it to:

"Modeline "1280x768@60" 75 1280 1312 1608 1640 768 783 791 807


Horizontal sync frequency: 48.62 kHz"

or would that 75 necessitate the need for the other numbers there to change somehow?


-J
 
Old 09-02-2003, 05:34 PM   #3
Jeriko
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
All right, I got it working but the best I can do is 1280x768@56Hz. I just editted out the 79.75 and replaced it with 75.

Modeline "1280x768@60" 79.75 1280 1312 1608 1640 768 783 791 807

to

Modeline "1280x768@60" 75 1280 1312 1608 1640 768 783 791 807

Philips recommends using the monitor at 1280x768@60 though. Not knowing much about monitor rates, is this risking damage tot he monitor in any way? My only other option seems to be to exceed the dot rate of 75MHz and push it to 79.75. I don't know which is preferable.

-J
 
Old 09-05-2003, 02:04 AM   #4
faheyd
Member
 
Registered: Jun 2003
Location: Northern California (NorCal)
Distribution: Ubuntu 7.04 and DSL/Puppy etc
Posts: 342

Rep: Reputation: 30
Your choices are dependent on your tolerance to risk, and of course, your extended warranty.
 
Old 07-05-2004, 06:46 PM   #5
zafod
LQ Newbie
 
Registered: Jul 2004
Distribution: SuSE
Posts: 3

Rep: Reputation: 0
Phillips Widescreen Monitor 170W4

I tried the xmode command like this:

$ xmode -x 1280 -y 768 -r 60
46
58
Modeline "1280x768" 77.37 1280 1344 1480 1680 768 769 772 794

Then I changed the 3rd field to 75 (the monitor's dot clock).
Everything looks superb except that the top 4 or so pixels are off the top of the screen. I know you can't just change the dot clock without adjusting the other numbers (base resolution plus back/front port) but I haven't been able to find this stuff in any documentation from Phillips.
But it's pretty close.
 
Old 07-05-2004, 11:50 PM   #6
faheyd
Member
 
Registered: Jun 2003
Location: Northern California (NorCal)
Distribution: Ubuntu 7.04 and DSL/Puppy etc
Posts: 342

Rep: Reputation: 30
/usr/X11/bin/xvidtune

Try /usr/X11/bin/xvidtune and see if you can fine tune it. Right down the settings that work after testing, and put them in your /etc/X11/XF86Config-4 file (or similar) to permanently use them.

Correct above statement: "Right down" change to "Write down"

Darn English language gets me when I'm not paying close attention to detail!

Last edited by faheyd; 07-06-2004 at 02:03 PM.
 
Old 07-06-2004, 01:44 PM   #7
zafod
LQ Newbie
 
Registered: Jul 2004
Distribution: SuSE
Posts: 3

Rep: Reputation: 0
Many thanks, that's done the trick. I clicked the "move down" button twice. As far as I can tell the following modeline gives a perfect display:

Modeline "1280x768" 75.00 1280 1344 1480 1680 768 769 772 802
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Philips monitor not displaying. Vlad_Einhorn Linux - Hardware 7 09-22-2005 01:17 AM
Sax2 / Xserver / Monitor woes Judah Linux - Hardware 5 01-05-2005 05:11 PM
Problem with philips 150s lcd monitor feder4 Linux - Hardware 0 08-05-2004 10:30 AM
Dual monitor setup woes... slackMeUp Slackware 2 03-02-2004 06:30 PM
Monitor drivers for Philips 202P40 22" Osten Linux - Hardware 1 01-10-2004 12:33 PM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration